Fix build of qtwayland 5.9 without evdev
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Fri, 19 Jan 2018 10:19:12 +0000 (11:19 +0100)
committerronan <ronan.lemartret@gmail.com>
Tue, 13 Feb 2018 16:22:38 +0000 (17:22 +0100)
This fixes a FTBS due to no evdev present.

Change-Id: If00dff352e4b270b2dbd1d7df15869d984c883b8
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-qt/qt5/qtwayland/0099_qtwayland_no_evdev.patch [new file with mode: 0644]
recipes-qt/qt5/qtwayland_%.bbappend

diff --git a/recipes-qt/qt5/qtwayland/0099_qtwayland_no_evdev.patch b/recipes-qt/qt5/qtwayland/0099_qtwayland_no_evdev.patch
new file mode 100644 (file)
index 0000000..e243ef2
--- /dev/null
@@ -0,0 +1,14 @@
+diff --git a/tests/auto/compositor/compositor/compositor.pro b/tests/auto/compositor/compositor/compositor.pro
+index f0cdaf32..64b60218 100644
+--- a/tests/auto/compositor/compositor/compositor.pro
++++ b/tests/auto/compositor/compositor/compositor.pro
+@@ -7,9 +7,6 @@ QT += core-private gui-private waylandcompositor waylandcompositor-private
+ QMAKE_USE += wayland-client wayland-server
+-qtConfig(xkbcommon-evdev)
+-    QMAKE_USE += xkbcommon_evdev
+-
+ WAYLANDCLIENTSOURCES += \
+             ../../../../src/3rdparty/protocol/xdg-shell.xml \
+             ../../../../src/3rdparty/protocol/ivi-application.xml \
index a6a8f00..9807840 100644 (file)
@@ -32,3 +32,5 @@ SRC_URI_append_checkforkrogoth = "\
 
 DEPENDS_append_koelsch = " libegl gles-user-module"
 DEPENDS_append_porter = " ${@base_conditional('PREFERRED_PROVIDER_virtual/egl', 'mesa', 'mesa', 'libegl gles-user-module', d)}"
+
+SRC_URI_append = " file://0099_qtwayland_no_evdev.patch "