Merge remote-tracking branch 'agl/sandbox/locust2001/rocko' into HEAD 31/13431/1
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Wed, 14 Feb 2018 09:56:32 +0000 (10:56 +0100)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Wed, 14 Feb 2018 09:56:32 +0000 (10:56 +0100)
* agl/sandbox/locust2001/rocko:
  ninja,harfbuzz: Remove .bbappend
  libdbus-c++:Fix build error in GCC-7
  qtbase: Remove -no-use-gold-linker option
  unicens-config: Add bash to rdeps
  libdbus-c++: Remove bbappend file
  opencv: Rename .bbappend to match new version from meta-openembedded

Bug-AGL: SPEC-1181

Change-Id: I0fc0ee1e50dc20b57b943b7128d157d51eb9cafa
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-config/unicens-config/unicens-config.bb
recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch [new file with mode: 0644]
recipes-core/dbus/libdbus-c++_0.9.0.bbappend
recipes-devtools/ninja/ninja_%.bbappend [deleted file]
recipes-graphics/harfbuzz/harfbuzz_%.bbappend [deleted file]
recipes-qt/qt5/qtbase_%.bbappend
recipes-support/opencv/opencv_3.3.bbappend [moved from recipes-support/opencv/opencv_3.2.bbappend with 100% similarity]

index 706b2c8..f33ffb2 100644 (file)
@@ -2,11 +2,14 @@ DESCRIPTION = "Configure MOST driver"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
+RDEPENDS_${PN} = "bash"
+
 SRC_URI = "\
     file://unicens-config.service \
     file://unicens-config.sh \
 "
 
+
 inherit systemd
 
 SYSTEMD_PACKAGES = "${PN}"
diff --git a/recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch b/recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch
new file mode 100644 (file)
index 0000000..c4fafef
--- /dev/null
@@ -0,0 +1,45 @@
+--- libdbus-c++-0.9.0/include/dbus-c++/dispatcher.h.threading  2017-02-15 13:40:53.796004263 +0000
++++ libdbus-c++-0.9.0/include/dbus-c++/dispatcher.h    2017-02-15 13:40:46.907000493 +0000
+@@ -188,6 +188,7 @@
+ /* classes for multithreading support
+ */
++#if 0
+ class DXXAPI Mutex
+ {
+ public:
+@@ -243,9 +244,11 @@
+ typedef bool (*CondVarWaitTimeoutFn)(CondVar *cv, Mutex *mx, int timeout);
+ typedef void (*CondVarWakeOneFn)(CondVar *cv);
+ typedef void (*CondVarWakeAllFn)(CondVar *cv);
++#endif
+ void DXXAPI _init_threading();
++#if 0
+ void DXXAPI _init_threading(
+   MutexNewFn, MutexFreeFn, MutexLockFn, MutexUnlockFn,
+   CondVarNewFn, CondVarFreeFn, CondVarWaitFn, CondVarWaitTimeoutFn, CondVarWakeOneFn, CondVarWakeAllFn
+@@ -312,6 +315,7 @@
+     cv->wake_all();
+   }
+ };
++#endif
+ } /* namespace DBus */
+--- libdbus-c++-0.9.0/src/dispatcher.cpp.threading     2017-02-15 13:48:22.627249868 +0000
++++ libdbus-c++-0.9.0/src/dispatcher.cpp       2017-02-15 13:48:29.164253445 +0000
+@@ -253,6 +253,7 @@
+ #endif//DBUS_HAS_THREADS_INIT_DEFAULT
+ }
++#if 0
+ void DBus::_init_threading(
+   MutexNewFn m1,
+   MutexFreeFn m2,
+@@ -318,3 +319,4 @@
+ #endif//DBUS_HAS_RECURSIVE_MUTEX
+   dbus_threads_init(&functions);
+ }
++#endif
index ea83587..dac44b5 100644 (file)
@@ -1 +1,2 @@
-PNBLACKLIST[libdbus-c++] = ""
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+SRC_URI_append = "file://dbus-c++-threading.patch"
diff --git a/recipes-devtools/ninja/ninja_%.bbappend b/recipes-devtools/ninja/ninja_%.bbappend
deleted file mode 100644 (file)
index efc347a..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-BBCLASSEXTEND += "nativesdk"
-
diff --git a/recipes-graphics/harfbuzz/harfbuzz_%.bbappend b/recipes-graphics/harfbuzz/harfbuzz_%.bbappend
deleted file mode 100644 (file)
index 7ac439a..0000000
+++ /dev/null
@@ -1 +0,0 @@
-PACKAGECONFIG_append = " icu"
index 203b326..d568b12 100644 (file)
@@ -14,6 +14,3 @@ EXTRA_OECONF_append = ""
 
 # '-qpa wayland-egl' set wayland-egl as default of platform plagins
 PACKAGECONFIG[wayland]="-qpa wayland-egl -no-qpa-platform-guard"
-
-# Temporarily fix bug due to binutils 2.28
-QT_CONFIG_FLAGS_append = " -no-use-gold-linker"