most: add patch to enable building against >= 5.9 kernels 77/26177/1
authorScott Murray <scott.murray@konsulko.com>
Fri, 12 Mar 2021 00:34:53 +0000 (19:34 -0500)
committerScott Murray <scott.murray@konsulko.com>
Sun, 14 Mar 2021 16:52:23 +0000 (12:52 -0400)
Add patch to enable building the standalone MOST driver against
kernels 5.9 or newer.

Bug-AGL: SPEC-3819

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I6004937adb7e3522b86f531da03ad67ea4512354

recipes-kernel/most/files/0014-Fix-build-with-5.9-kernel.patch [new file with mode: 0644]
recipes-kernel/most/most.bbappend

diff --git a/recipes-kernel/most/files/0014-Fix-build-with-5.9-kernel.patch b/recipes-kernel/most/files/0014-Fix-build-with-5.9-kernel.patch
new file mode 100644 (file)
index 0000000..fd430c9
--- /dev/null
@@ -0,0 +1,39 @@
+Fix building against 5.9 or newer kernels
+
+DECLARE_TASKLET was replaced with DECLARE_TASKLET_OLD in 5.9.
+Marking as inappropriate for upstream for now, as it seems the
+standalone version of the driver has been superceded by the version
+in the staging tree in the mainline kernel, and there are no obvious
+signs of maintenance.
+
+Upstream-Status: Inappropriate [no upstream]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+---
+ driver/hdm-dim2/dim2_hdm.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/hdm-dim2/dim2_hdm.c b/hdm-dim2/dim2_hdm.c
+index 1847091..fc02c6b 100644
+--- a/hdm-dim2/dim2_hdm.c
++++ b/hdm-dim2/dim2_hdm.c
+@@ -14,6 +14,7 @@
+ #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
+ #include <linux/module.h>
++#include <linux/version.h>
+ #include <linux/of_platform.h>
+ #include <linux/printk.h>
+ #include <linux/kernel.h>
+@@ -53,7 +54,11 @@ MODULE_PARM_DESC(fcnt, "Num of frames per sub-buffer for sync channels as a powe
+ static DEFINE_SPINLOCK(dim_lock);
+ static void dim2_tasklet_fn(unsigned long data);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,9,0)
+ static DECLARE_TASKLET(dim2_tasklet, dim2_tasklet_fn, 0);
++#else
++static DECLARE_TASKLET_OLD(dim2_tasklet, dim2_tasklet_fn);
++#endif
+ /**
+  * struct hdm_channel - private structure to keep channel specific data
index b5a140f..85bae74 100644 (file)
@@ -13,4 +13,5 @@ SRC_URI_append = " \
         file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch \
         file://0012-Fix-build-with-5.4-kernel.patch \
         file://0013-Fix-build-with-5.7-kernel.patch \
+        file://0014-Fix-build-with-5.9-kernel.patch \
 "