Restrict addition of low-level-can-service to m3ulcb qemux86-64 and intel-corei7-64 41/10341/1
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Mon, 24 Jul 2017 21:12:10 +0000 (23:12 +0200)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Mon, 24 Jul 2017 21:12:19 +0000 (23:12 +0200)
Not all boards use a kernel >= 4.8 . This service binding needs features introduced in Kernel 4.8 .

Thus restrict it to m3 and x86-64 for now. Other targets can added later.

Bug-AGL: SPEC-772

Change-Id: I03acdc11e40497d8b8bda702b6e556f234af9ff6
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-appfw/packagegroups/packagegroup-agl-appfw-connectivity.bb

index b5fae76..093146e 100644 (file)
@@ -16,8 +16,11 @@ RDEPENDS_${PN} += "\
     "
 
 AGL_APPS = " \
-    low-level-can-service \
     "
+# restricted due to dependency on Kernel >= 4.8 which is not available in all repositories
+AGL_APPS_append_m3ulcb = " low-level-can-service "
+AGL_APPS_append_intel-corei7-64 = " low-level-can-service "
+AGL_APPS_append_qemux86-64 = " low-level-can-service "
 
 RDEPENDS_${PN}_append = " \
     ${AGL_APPS} \