fix MOST driver dependency issues 73/9673/2
authorChristian Gromm <christian.gromm@microchip.com>
Fri, 9 Jun 2017 09:27:04 +0000 (11:27 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 12 Jun 2017 08:34:59 +0000 (08:34 +0000)
This patch adds a new "most" receipe for building the MOST driver. The
receipe replaces the old ones, as it builds all modules at once. Hence,
the receipes aim*, hdm* and mostcore are removed. Additionally, the *.bb
file for the demo platform is modified to reflect these changes.

This patch is needed to avoid dependency issues among the modules of the
driver stack. Although, the problem has been reported with SPEC 438 and a
patch set to fix it has been introduced with Change #8447, it is still
present on RaspberryPi.

Change-Id: Id6104ee6d9bf1b7d9744761a6529461176fdd8b2
Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
12 files changed:
recipes-kernel/aim-cdev/aim-cdev.bb [deleted file]
recipes-kernel/aim-network/aim-network.bb [deleted file]
recipes-kernel/aim-sound/aim-sound.bb [deleted file]
recipes-kernel/aim-v4l2/aim-v4l2.bb [deleted file]
recipes-kernel/hdm-dim2/hdm-dim2.bb [deleted file]
recipes-kernel/hdm-i2c/hdm-i2c.bb [deleted file]
recipes-kernel/hdm-usb/hdm-usb.bb [deleted file]
recipes-kernel/most/files/0001-aim-network-3.10.31-ltsi-backport.patch [moved from recipes-kernel/aim-network/files/0001-aim-network-backport-patch-for-3.10.31-ltsi.patch with 92% similarity]
recipes-kernel/most/files/0001-aim-sound-3.10.31-ltsi-backport.patch [moved from recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch with 88% similarity]
recipes-kernel/most/most.bb [new file with mode: 0644]
recipes-kernel/mostcore/mostcore.bb [deleted file]
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb

diff --git a/recipes-kernel/aim-cdev/aim-cdev.bb b/recipes-kernel/aim-cdev/aim-cdev.bb
deleted file mode 100644 (file)
index e8c101e..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Build character device driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
-    # modprobe automatically at boot
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${sysconfdir}/modules-load.d
-        echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
-    fi
-}
diff --git a/recipes-kernel/aim-network/aim-network.bb b/recipes-kernel/aim-network/aim-network.bb
deleted file mode 100644 (file)
index 7ef192c..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "Build networking driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-SRC_URI_append_porter = " file://0001-aim-network-backport-patch-for-3.10.31-ltsi.patch"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
-    # modprobe automatically at boot
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${sysconfdir}/modules-load.d
-        echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
-    fi
-}
diff --git a/recipes-kernel/aim-sound/aim-sound.bb b/recipes-kernel/aim-sound/aim-sound.bb
deleted file mode 100644 (file)
index cb2b983..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "Build ALSA driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-SRC_URI_append_porter = " file://0001-aim-sound-3.10.31-ltsi-backport.patch"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
-    # modprobe automatically at boot
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${sysconfdir}/modules-load.d
-        echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
-    fi
-}
diff --git a/recipes-kernel/aim-v4l2/aim-v4l2.bb b/recipes-kernel/aim-v4l2/aim-v4l2.bb
deleted file mode 100644 (file)
index 5233eed..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Build V4L2 driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
-    # modprobe automatically at boot
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${sysconfdir}/modules-load.d
-        echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
-    fi
-}
diff --git a/recipes-kernel/hdm-dim2/hdm-dim2.bb b/recipes-kernel/hdm-dim2/hdm-dim2.bb
deleted file mode 100644 (file)
index a917929..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Build DIM2 adapter driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
-    # modprobe automatically at boot
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${sysconfdir}/modules-load.d
-        echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
-    fi
-}
diff --git a/recipes-kernel/hdm-i2c/hdm-i2c.bb b/recipes-kernel/hdm-i2c/hdm-i2c.bb
deleted file mode 100644 (file)
index 90216ec..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Build I2C adapter driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
-    # modprobe automatically at boot
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${sysconfdir}/modules-load.d
-        echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
-    fi
-}
diff --git a/recipes-kernel/hdm-usb/hdm-usb.bb b/recipes-kernel/hdm-usb/hdm-usb.bb
deleted file mode 100644 (file)
index df45e37..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "Build USB adapter driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
-    # modprobe automatically at boot
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${sysconfdir}/modules-load.d
-        echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
-    fi
-}
@@ -8,10 +8,10 @@ Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
  aim-network/networking.c | 7 +++----
  1 file changed, 3 insertions(+), 4 deletions(-)
 
-diff --git a/networking.c b/aim-network/networking.c
+diff --git a/aim-network/networking.c b/aim-network/networking.c
 index ce1764c..e04b523 100644
---- a/networking.c
-+++ b/networking.c
+--- a/aim-network/networking.c
++++ b/aim-network/networking.c
 @@ -362,8 +362,7 @@ static int aim_probe_channel(struct most_interface *iface, int channel_idx,
  
        if (nd->tx.linked || nd->rx.linked) {
@@ -11,10 +11,10 @@ Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
  aim-sound/sound.c |    2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/sound.c b/aim-sound/sound.c
+diff --git a/aim-sound/sound.c b/aim-sound/sound.c
 index 3dc625c..af0af2d 100644
---- a/sound.c
-+++ b/sound.c
+--- a/aim-sound/sound.c
++++ b/aim-sound/sound.c
 @@ -595,7 +595,7 @@ static int audio_probe_channel(struct most_interface *iface, int channel_id,
                return ret;
        }
diff --git a/recipes-kernel/most/most.bb b/recipes-kernel/most/most.bb
new file mode 100644 (file)
index 0000000..512610a
--- /dev/null
@@ -0,0 +1,32 @@
+DESCRIPTION = "Build MOST driver"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+inherit module
+
+PV = "0.1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
+SRC_URI_append_porter = " file://0001-aim-network-3.10.31-ltsi-backport.patch \
+                          file://0001-aim-sound-3.10.31-ltsi-backport.patch \
+                        "
+S = "${WORKDIR}/git/driver"
+SRCREV = "${AUTOREV}"
+
+# The inherit of module.bbclass will automatically name module packages with
+# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+    # modprobe automatically at boot
+    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+        install -d ${D}${sysconfdir}/modules-load.d
+        echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
+        echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
+        echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
+        echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
+        echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
+        echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
+        echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
+        echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf
+    fi
+}
diff --git a/recipes-kernel/mostcore/mostcore.bb b/recipes-kernel/mostcore/mostcore.bb
deleted file mode 100644 (file)
index 35865ce..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION = "Build MOST core driver"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
-    # modprobe automatically at boot
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${sysconfdir}/modules-load.d
-        echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf
-    fi
-}
index 1ad6f2c..1df09f0 100755 (executable)
@@ -21,15 +21,8 @@ RDEPENDS_${PN} += "\
 
 MOST_DRIVERS = " "
 MOST_DRIVERS_append = " \
-    aim-cdev \
-    aim-network \
-    aim-sound \
-    aim-v4l2 \
-    hdm-dim2 \
-    hdm-i2c \
-    hdm-usb \
     mocca-usb \
-    mostcore \
+    most \
     "
 
 # HVAC dependencies depend on drivers above