bluez-glib libqtappfw: fix S definitions 64/27064/1
authorScott Murray <scott.murray@konsulko.com>
Wed, 22 Dec 2021 20:41:45 +0000 (15:41 -0500)
committerScott Murray <scott.murray@konsulko.com>
Wed, 22 Dec 2021 20:41:45 +0000 (15:41 -0500)
Bitbake in poky master now warns if the path in the S variable
definition has a trailing '/', remove a couple of occurrences
that were recently added by accident to reduce "next" branch
maintenance.

Bug-AGL: SPEC-3819

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I038c6e4c821f331d458255b66660d46eb895c4b9

recipes-connectivity/bluez-glib/bluez-glib_git.bb
recipes-demo/libqtappfw/libqtappfw_git.bb

index 0a3d5f1..676c069 100644 (file)
@@ -6,9 +6,9 @@ DEPENDS = "systemd glib-2.0"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/bluez-glib;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "701f44587eabaa78dc1c180d8ca0ac8f848941d5"
-S = "${WORKDIR}/git/"
+S = "${WORKDIR}/git"
 
 # PV needs to be modified with SRCPV to work AUTOREV correctly
 PV = "1.0+git${SRCPV}"
 
-inherit meson
+inherit meson pkgconfig
index edf2af0..3b99ef1 100644 (file)
@@ -10,11 +10,11 @@ DEPENDS = "qtbase qtdeclarative glib-2.0 bluez-glib"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "0fee9bfb0f656b78f34c44542329760be2980892"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 # PV needs to be modified with SRCPV to work AUTOREV correctly
 PV = "2.0+git${SRCPV}"
 
-inherit cmake_qt5
+inherit cmake_qt5 pkgconfig
 
 BBCLASSEXTEND = "nativesdk"