Restore camera-gstreamer 50/27250/2 12.93.0 marlin/12.93.0 marlin_12.93.0
authorScott Murray <scott.murray@konsulko.com>
Mon, 7 Mar 2022 21:37:34 +0000 (16:37 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 8 Mar 2022 14:50:03 +0000 (14:50 +0000)
Restore an updated version of the camera-gstreamer application
recipe so that those interested can build it for testing purposes.

Bug-AGL: SPEC-4284

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I32ffbc2411c4898cd7fb735d603d9d1107199cec

recipes-demo/camera-gstreamer/camera-gstreamer_git.bb [new file with mode: 0644]

diff --git a/recipes-demo/camera-gstreamer/camera-gstreamer_git.bb b/recipes-demo/camera-gstreamer/camera-gstreamer_git.bb
new file mode 100644 (file)
index 0000000..e9fa575
--- /dev/null
@@ -0,0 +1,27 @@
+SUMMARY     = "Camera gstreamer demo application"
+DESCRIPTION = "AGL demonstration of displaying incoming camera feed"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/camera-gstreamer"
+SECTION     = "apps"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+    wayland wayland-native \
+    gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/camera-gstreamer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+S  = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+RDEPENDS:${PN} += " \
+    gstreamer1.0-plugins-base \
+    gstreamer1.0-plugins-good \
+    gstreamer1.0-plugins-bad \
+"