python3-grpcio: rename bbappend master next
authorScott Murray <scott.murray@konsulko.com>
Wed, 20 Mar 2024 16:14:04 +0000 (12:14 -0400)
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>
Wed, 24 Apr 2024 15:25:38 +0000 (15:25 +0000)
Rename python3-grpcio bbappend for newer version in scarthgap.

Bug-AGL: SPEC-4578

Change-Id: I4023d82282da0948ab0254bc73fda570a6f5bfa1
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
23 files changed:
conf/layer.conf
recipes-connectivity/cannelloni/cannelloni_%.bbappend [deleted file]
recipes-connectivity/cannelloni/cannelloni_agldemo.inc [deleted file]
recipes-connectivity/kuksa-val/kuksa-dbc-feeder/0001-dbc2val-add-installation-mechanism.patch
recipes-connectivity/kuksa-val/kuksa-val/0006-kuksa-val-server-OverlayLoader-explicitly-include-fs.patch [new file with mode: 0644]
recipes-connectivity/kuksa-val/kuksa-val_git.bb
recipes-connectivity/ofono/files/0001-provision-allow-duplicate-entries-from-mbpi_lookup_a.patch [deleted file]
recipes-connectivity/ofono/files/ofono.conf [deleted file]
recipes-connectivity/ofono/ofono_%.bbappend [deleted file]
recipes-connectivity/ofono/ofono_agldemo.inc [deleted file]
recipes-devtools/python/python3-cantools_39.%.bbappend [moved from recipes-devtools/python/python3-cantools_37.0.7.bbappend with 100% similarity]
recipes-devtools/python/python3-grpcio_1.62.1.bbappend [moved from recipes-devtools/python/python3-grpcio_1.45.0.bbappend with 100% similarity]
recipes-devtools/python/python3-pyqt5_5.15.9.bbappend [moved from recipes-devtools/python/python3-pyqt5_5.15.1.bbappend with 100% similarity]
recipes-graphics/libvncserver/libvncserver_0.9.14.bb [deleted file]
recipes-kernel/linux/linux/can-devices.cfg
recipes-kernel/linux/linux/most_deps.cfg
recipes-kernel/linux/linux/wifi.cfg
recipes-platform/images/agl-ivi-crosssdk.inc
recipes-qt/qt/qtwayland/0001-qwaylandintegration-Keep-previous-check-related-to-i.patch
recipes-support/icu/icu_70.1.bbappend [deleted file]
recipes-support/icu/icu_74-1.bbappend [new file with mode: 0644]
recipes-support/icu/icu_74-1_agldemo.inc [moved from recipes-support/icu/icu_70.1_agldemo.inc with 100% similarity]
templates/feature/agl-demo/50_bblayers.conf.inc

index 8aff0f9..7556a86 100644 (file)
@@ -14,6 +14,6 @@ BBFILES_DYNAMIC += " \
     aglcontainermc:${LAYERDIR}/dynamic-layers/meta-agl-ic-container/*/*/*.bbappend \
 "
 
-LAYERSERIES_COMPAT_agldemo = "kirkstone"
+LAYERSERIES_COMPAT_agldemo = "scarthgap"
 
 LAYERDEPENDS_agldemo = "aglcore qt5-layer openembedded-layer networking-layer multimedia-layer flutter-layer meta-app-framework"
diff --git a/recipes-connectivity/cannelloni/cannelloni_%.bbappend b/recipes-connectivity/cannelloni/cannelloni_%.bbappend
deleted file mode 100644 (file)
index 4619406..0000000
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'cannelloni_agldemo.inc', '', d)}
diff --git a/recipes-connectivity/cannelloni/cannelloni_agldemo.inc b/recipes-connectivity/cannelloni/cannelloni_agldemo.inc
deleted file mode 100644 (file)
index c83d535..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-PV = "1.0.0+git${SRCPV}"
-SRCREV = "071d2d0a2b7997d697fa1228423b329f817a237a"
index 1e1ff5d..58ad325 100644 (file)
@@ -66,7 +66,7 @@ index 0000000..65f9157
 +    version_config={
 +        "template": "{tag}",
 +        "dev_template": "{tag}-{ccount}",
-+        "dirty_template": "{tag}-{ccount}-dirty",
++        "dirty_template": "{tag}+{ccount}-dirty",
 +        "starting_version": "0.1.0",
 +        "version_callback": None,
 +        "version_file": None,
diff --git a/recipes-connectivity/kuksa-val/kuksa-val/0006-kuksa-val-server-OverlayLoader-explicitly-include-fs.patch b/recipes-connectivity/kuksa-val/kuksa-val/0006-kuksa-val-server-OverlayLoader-explicitly-include-fs.patch
new file mode 100644 (file)
index 0000000..0f40a7c
--- /dev/null
@@ -0,0 +1,35 @@
+From 60561b755cbfbb3aa99b1a0d736cc89540636c00 Mon Sep 17 00:00:00 2001
+From: Denys Dmytriyenko <denys@konsulko.com>
+Date: Wed, 7 Jun 2023 21:16:30 +0000
+Subject: [PATCH] kuksa-val-server: OverlayLoader: explicitly include fstream
+ header
+
+Otherwise gcc13 now errors out:
+
+| .../kuksa-val-server/src/OverlayLoader.cpp: In function 'void applyOverlays(std::shared_ptr<ILogger>, std::vector<boost::filesystem::path>, std::shared_ptr<IVssDatabase>)':
+| .../kuksa-val-server/src/OverlayLoader.cpp:70:24: error: variable 'std::ifstream is' has initializer but incomplete type
+|    70 |       std::ifstream is(p.generic_string());
+|       |                        ^
+
+Upstream-Status: Pending
+
+Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
+---
+ kuksa-val-server/src/OverlayLoader.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/kuksa-val-server/src/OverlayLoader.cpp b/kuksa-val-server/src/OverlayLoader.cpp
+index bed9234..abd1945 100644
+--- a/kuksa-val-server/src/OverlayLoader.cpp
++++ b/kuksa-val-server/src/OverlayLoader.cpp
+@@ -23,6 +23,7 @@
+ /* helper fuctions to load overlays during server startup */
+ #include <stdexcept>
++#include <fstream>
+ #include <jsoncons/json.hpp>
+ #include "OverlayLoader.hpp"
+-- 
+2.25.1
+
index c564eab..64daba2 100644 (file)
@@ -19,6 +19,7 @@ SRC_URI += "file://kuksa-val.service \
             file://0003-Make-install-locations-configurable.patch;patchdir=.. \
             file://0004-Disable-default-fetch-and-build-of-googletest.patch;patchdir=.. \
             file://0005-kuksa-val-server-Add-missing-check_git-dependency.patch;patchdir=.. \
+            file://0006-kuksa-val-server-OverlayLoader-explicitly-include-fs.patch;patchdir=.. \
 "
 
 S = "${WORKDIR}/git/kuksa-val-server"
diff --git a/recipes-connectivity/ofono/files/0001-provision-allow-duplicate-entries-from-mbpi_lookup_a.patch b/recipes-connectivity/ofono/files/0001-provision-allow-duplicate-entries-from-mbpi_lookup_a.patch
deleted file mode 100644 (file)
index 7b44e48..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From 7782f8f9d9634ebeddafefedab10ba254f9cc34a Mon Sep 17 00:00:00 2001
-From: Matt Ranostay <matt.ranostay@konsulko.com>
-Date: Fri, 1 Mar 2019 17:53:17 +0900
-Subject: [PATCH] provision: allow duplicate entries from mbpi_lookup_apn()
- results
-
-Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
----
- plugins/provision.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/plugins/provision.c b/plugins/provision.c
-index 99c299eb..aa0b05e4 100644
---- a/plugins/provision.c
-+++ b/plugins/provision.c
-@@ -50,7 +50,7 @@ static int provision_get_settings(const char *mcc, const char *mnc,
-       DBG("Provisioning for MCC %s, MNC %s, SPN '%s'", mcc, mnc, spn);
--      apns = mbpi_lookup_apn(mcc, mnc, FALSE, &error);
-+      apns = mbpi_lookup_apn(mcc, mnc, TRUE, &error);
-       if (apns == NULL) {
-               if (error != NULL) {
-                       ofono_error("%s", error->message);
--- 
-2.20.1
-
diff --git a/recipes-connectivity/ofono/files/ofono.conf b/recipes-connectivity/ofono/files/ofono.conf
deleted file mode 100644 (file)
index e47214c..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-<!-- This configuration file specifies the required security policies
-     for oFono core daemon to work. -->
-
-<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
- "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
-
-  <!-- ../system.conf have denied everything, so we just punch some holes -->
-
-  <policy user="root">
-    <allow own="org.ofono"/>
-    <allow send_destination="org.ofono"/>
-    <allow send_interface="org.ofono.Manager"/>
-    <allow send_interface="org.ofono.SimToolkitAgent"/>
-    <allow send_interface="org.ofono.PushNotificationAgent"/>
-    <allow send_interface="org.ofono.SmartMessagingAgent"/>
-    <allow send_interface="org.ofono.PositioningRequestAgent"/>
-    <allow send_interface="org.ofono.HandsfreeAudioAgent"/>
-    <allow send_interface="org.ofono.Modem"/>
-  </policy>
-
-  <policy at_console="true">
-    <allow send_destination="org.ofono"/>
-  </policy>
-
-  <policy context="default">
-    <deny send_destination="org.ofono"/>
-  </policy>
-
-</busconfig>
diff --git a/recipes-connectivity/ofono/ofono_%.bbappend b/recipes-connectivity/ofono/ofono_%.bbappend
deleted file mode 100644 (file)
index 0386aa9..0000000
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'ofono_agldemo.inc', '', d)}
diff --git a/recipes-connectivity/ofono/ofono_agldemo.inc b/recipes-connectivity/ofono/ofono_agldemo.inc
deleted file mode 100644 (file)
index 2619835..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI:append = "\
-    file://ofono.conf \
-    file://0001-provision-allow-duplicate-entries-from-mbpi_lookup_a.patch \
-    "
-
-do_install:append() {
-    install -m 0644 ${WORKDIR}/ofono.conf ${D}${sysconfdir}/dbus-1/system.d/ofono.conf
-}
-
-SYSTEMD_AUTO_ENABLE = "enable"
diff --git a/recipes-graphics/libvncserver/libvncserver_0.9.14.bb b/recipes-graphics/libvncserver/libvncserver_0.9.14.bb
deleted file mode 100644 (file)
index 3278817..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-DESCRIPTION = "library for easy implementation of a RDP/VNC server"
-HOMEPAGE = "https://libvnc.github.io"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f"
-
-SRC_URI = "git://github.com/LibVNC/libvncserver;branch=master;protocol=https"
-SRCREV := "10e9eb75f73e973725dc75c373de5d89807af028"
-
-S = "${WORKDIR}/git"
-
-inherit cmake
-
-# ffmpeg support is not currently compatible with ffmpeg 5.0
-PACKAGECONFIG ??= " \
-    24bpp \
-    filetransfer \
-    gcrypt \
-    gnutls \
-    jpeg \
-    lzo \
-    png \
-    pthread \
-    ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)} \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '',d)} \
-    sdl \
-    websockets \
-    zlib \
-"
-
-PACKAGECONFIG[24bpp] = "-DWITH_24BPP=ON,-DWITH_24BPP=OFF,"
-PACKAGECONFIG[filetransfer] = "-DWITH_TIGHTVNC_FILETRANSFER=ON,-DWITH_TIGHTVNC_FILETRANSFER=OFF,"
-PACKAGECONFIG[ffmpeg] = "-DWITH_FFMPEG=ON,-DWITH_FFMPEG=OFF,ffmpeg,ffmpeg"
-PACKAGECONFIG[gcrypt] = "-DWITH_GCRYPT=ON,-DWITH_GCRYPT=OFF,libgcrypt,libgcrypt"
-PACKAGECONFIG[gnutls] = "-DWITH_GNUTLS=ON,-DWITH_GNUTLS=OFF,gnutls"
-PACKAGECONFIG[jpeg] = "-DWITH_JPEG=ON,-DWITH_JPEG=OFF,jpeg"
-PACKAGECONFIG[ipv6] = "-DWITH_IPv6=ON,-DWITH_IPv6=OFF,"
-PACKAGECONFIG[lzo] = "-DWITH_LZO=ON,-DWITH_LZO=OFF,lzo"
-PACKAGECONFIG[openssl] = "-DWITH_OPENSSL=ON,-DWITH_OPENSSL=OFF,openssl"
-PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng,libpng"
-PACKAGECONFIG[pthread] = "-DWITH_THREADS=ON,-DWITH_THREADS=OFF,"
-PACKAGECONFIG[systemd] = "-DWITH_SYSTEMD=ON,-DWITH_SYSTEMD=OFF,systemd"
-PACKAGECONFIG[sasl] = "-DWITH_SASL=ON,-DWITH_SASL=OFF,cyrus-sasl"
-PACKAGECONFIG[sdl] = "-DWITH_SDL=ON,-DWITH_SDL=OFF,libsdl2"
-PACKAGECONFIG[websockets] = "-DWITH_WEBSOCKETS=ON,-DWITH_WEBSOCKETS=OFF,"
-PACKAGECONFIG[zlib] = "-DWITH_ZLIB=ON,-DWITH_ZLIB=OFF,zlib"
-
-PACKAGE_BEFORE_PN = "libvncclient"
-FILES:libvncclient = "${libdir}/libvncclient.*"
-
-
-
-EXTRA_OECMAKE = "-DMAKE_INSTALL_LIBDIR=${libdir}"
index 2b4f317..77a8bff 100644 (file)
@@ -4,7 +4,6 @@
 CONFIG_CAN_SLCAN=m
 CONFIG_CAN_DEV=m
 CONFIG_CAN_CALC_BITTIMING=y
-# CONFIG_CAN_LEDS is not set
 CONFIG_CAN_C_CAN=m
 CONFIG_CAN_C_CAN_PLATFORM=m
 # CONFIG_CAN_SJA1000 is not set
@@ -20,7 +19,7 @@ CONFIG_CAN_MCP251X=m
 # CAN USB interfaces
 #
 # CONFIG_CAN_EMS_USB is not set
-CONFIG_CAN_ESD_USB2=m
+CONFIG_CAN_ESD_USB=m
 CONFIG_CAN_GS_USB=m
 CONFIG_CAN_KVASER_USB=m
 CONFIG_CAN_PEAK_USB=m
index 15ddbd2..53964a5 100644 (file)
@@ -6,4 +6,3 @@ CONFIG_MEDIA_DIGITAL_TV_SUPPORT=y
 CONFIG_MEDIA_CONTROLLER=y
 CONFIG_VIDEO_DEV=m
 CONFIG_VIDEO_V4L2_SUBDEV_API=y
-CONFIG_VIDEO_V4L2=m
index 879a6f2..e289062 100644 (file)
@@ -2,5 +2,4 @@ CONFIG_CFG80211=m
 CONFIG_MAC80211=m
 CONFIG_WLAN_VENDOR_ATH=y
 CONFIG_ATH9K_HTC=m
-CONFIG_STAGING=y
-CONFIG_R8188EU=m
+CONFIG_RTL8XXXU=m
index 551c034..f9f99d8 100644 (file)
@@ -18,4 +18,7 @@ TOOLCHAIN_HOST_TASK += "nativesdk-grpc nativesdk-grpc-dev"
 # Add gcc-sanitizers to support building applications using the SDK with
 # AddressSanitizer support to detect use-after-frees along with other
 # memory issue.
-TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
+TOOLCHAIN_SANITIZERS_TASKS = "gcc-sanitizers"
+# gcc-sanitizers is currently (scarthgap) not supported on RISC-V
+TOOLCHAIN_SANITIZERS_TASKS:riscv64 = ""
+TOOLCHAIN_TARGET_TASK += "${TOOLCHAIN_SANITIZERS_TASKS}"
index 77362da..b34f84d 100644 (file)
@@ -21,7 +21,7 @@ index c53ccb78..6d3d9559 100644
      }
  #endif
  
--    qCDebug(lcQpaWayland) << "using input method:" << inputContext()->metaObject()->className();
+-    qCDebug(lcQpaWayland) << "using input method:" << (inputContext() ? inputContext()->metaObject()->className() : "<none>");
 +    bool mUsingInputContextFromCompositor = qobject_cast<QWaylandInputContext *>(mInputContext.data());
 +    if (mUsingInputContextFromCompositor)
 +        qCDebug(lcQpaWayland) << "using input method:" << inputContext()->metaObject()->className();
diff --git a/recipes-support/icu/icu_70.1.bbappend b/recipes-support/icu/icu_70.1.bbappend
deleted file mode 100644 (file)
index b30ade4..0000000
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'icu_70.1_agldemo.inc', '', d)}
\ No newline at end of file
diff --git a/recipes-support/icu/icu_74-1.bbappend b/recipes-support/icu/icu_74-1.bbappend
new file mode 100644 (file)
index 0000000..cf4061e
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'icu_74-1_agldemo.inc', '', d)}
index 37b44ec..384a3b3 100644 (file)
@@ -9,3 +9,6 @@ AGL_META_MULTIMEDIA = "${METADIR}/external/meta-openembedded/meta-multimedia"
 AGL_META_NETWORKING = "${METADIR}/external/meta-openembedded/meta-networking"
 AGL_META_PYTHON = "${METADIR}/external/meta-openembedded/meta-python"
 AGL_META_QT5 = "${METADIR}/external/meta-qt5"
+
+# Needed to satisfy uutils-coreutils DEPENDS when using SELinux
+AGL_META_CLANG = "${METADIR}/external/meta-clang"