recipes-config: unicens-config: fix file permission 67/12167/1
authorChristian Gromm <christian.gromm@microchip.com>
Tue, 28 Nov 2017 09:57:56 +0000 (10:57 +0100)
committerChristian Gromm <christian.gromm@microchip.com>
Tue, 28 Nov 2017 09:59:13 +0000 (10:59 +0100)
This patch changes the permission of the file unicens-config.service to
644.  It is needed because an executable service file is considered a
security risk. This patch fixes JIRA SPEC-1137.

Change-Id: Idab5080450be358b5775ce4dbb1737f2bcd34a5f
Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Reported-by: Dominig Ar Foll <dominig.arfoll@fridu.net>
recipes-config/unicens-config/unicens-config.bb

index e8f5b78..706b2c8 100644 (file)
@@ -21,7 +21,7 @@ do_compile() {
 
 do_install() {
     install -d ${D}${systemd_system_unitdir}
-    install -m 0755 ${WORKDIR}/unicens-config.service ${D}${systemd_system_unitdir}
+    install -m 0644 ${WORKDIR}/unicens-config.service ${D}${systemd_system_unitdir}
     install -d ${D}${bindir}
     install -m 0755 ${WORKDIR}/unicens-config.sh ${D}${bindir}
 }