Explicitly add CA certificate package to cluster images 65/29365/3
authorScott Murray <scott.murray@konsulko.com>
Fri, 24 Nov 2023 05:20:45 +0000 (00:20 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 28 Nov 2023 12:27:48 +0000 (12:27 +0000)
Explicitly add kuksa-certificates-ca-agl to the cluster demo images so
it will be included in both regular and agl-demo-preload builds.  Also
remove obsolete dependency on kuksa-val-certificates-client from the
cluster-dashboard recipe.  These changes fix the regular vs
agl-demo-preload behavior for the agl-cluster-demo-platform build.

Bug-AGL: SPEC-4986

Change-Id: I62b1d976c66824fde50a3effdcdd34b428e82d54
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29472
ci-image-build: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
ci-image-boot-test: Jenkins Job builder account
Tested-by: Jenkins Job builder account
(cherry picked from commit b5ca98fe204a7ec6f4a1cf84c19ffeb5f4deb128)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29365
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
recipes-platform/images/agl-cluster-demo-platform-flutter.bb
recipes-platform/images/agl-cluster-demo-platform.bb

index 1404f67..fc0b35c 100644 (file)
@@ -54,5 +54,4 @@ RDEPENDS:${PN} += " \
     qtquickcontrols2-qmlplugins \
     qtgraphicaleffects-qmlplugins \
     qtsvg-plugins \
-    kuksa-val-certificates-client \
 "
index a6514c7..114e770 100644 (file)
@@ -29,6 +29,7 @@ IMAGE_INSTALL += "\
     packagegroup-agl-networking \
     cluster-receiver \
     \
+    kuksa-certificates-agl-ca \
     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "${IMAGE_KUKSA_PACKAGES}", d)} \
     simple-can-simulator \
     "
index f0b04a6..e7074c8 100644 (file)
@@ -13,6 +13,7 @@ REQUIRED_DISTRO_FEATURES = "wayland"
 # add packages for cluster demo platform (include demo apps) here
 IMAGE_INSTALL += " \
     packagegroup-agl-cluster-demo-platform \
+    kuksa-certificates-agl-ca \
     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config", "", d)} \
     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
     ${@bb.utils.contains("AGL_FEATURES", "AGLCI", "qemu-set-display", "", d)} \