recipes-demo-hmi: Remove qtaglextras and *-windowmanager depends
authorMarius Vlad <marius.vlad@collabora.com>
Thu, 14 May 2020 14:12:48 +0000 (17:12 +0300)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Wed, 24 Jun 2020 11:47:22 +0000 (13:47 +0200)
Bug-AGL: SPEC-3342

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: I3a5e73e30cae02c97d7d0ab6ca041b32a8862e73

17 files changed:
recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb
recipes-demo-hmi/dashboard/dashboard_git.bb
recipes-demo-hmi/homescreen/homescreen_git.bb
recipes-demo-hmi/hvac/hvac_git.bb
recipes-demo-hmi/launcher/launcher_git.bb
recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
recipes-demo-hmi/messaging/messaging_git.bb
recipes-demo-hmi/mixer/mixer_git.bb
recipes-demo-hmi/navigation/navigation-demo_git.bb
recipes-demo-hmi/navigation/ondemandnavi_git.bb
recipes-demo-hmi/navigation/poiapp_git.bb
recipes-demo-hmi/navigation/tbtnavi_git.bb
recipes-demo-hmi/onscreenapp/onscreenapp_git.bb
recipes-demo-hmi/phone/phone_git.bb
recipes-demo-hmi/radio/radio_git.bb
recipes-demo-hmi/settings/settings_git.bb
recipes-demo-hmi/taskmanager/taskmanager_git.bb

index f98704e..d406d85 100644 (file)
@@ -8,7 +8,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS = " \
        qtquickcontrols2 \
-       qlibwindowmanager \
        qlibhomescreen \
        af-binder \
        libqtappfw \
@@ -27,7 +26,6 @@ OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel'
 RDEPENDS_${PN} = " \
        libqtappfw \
        libafbwsc \
-       qlibwindowmanager \
        qlibhomescreen \
        agl-service-voice-high-capabilities \
 "
index 822207b..70a8793 100644 (file)
@@ -13,7 +13,7 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 qttools-native qtaglextras libqtappfw"
+DEPENDS += "qtquickcontrols2 qttools-native libqtappfw"
 
 inherit qmake5 aglwgt
 
index a49c305..715862c 100644 (file)
@@ -10,10 +10,8 @@ DEPENDS = "\
         qtdeclarative \
         qtquickcontrols2 \
         agl-service-homescreen \
-        agl-service-windowmanager \
         agl-service-weather \
         libqtappfw \
-        qlibwindowmanager \
         libhomescreen \
         libafb-helpers-qt \
 "
index 6091e51..5e36e2d 100644 (file)
@@ -14,8 +14,9 @@ S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS += "qtquickcontrols2 libhomescreen \
-            qlibwindowmanager qttools-native \
-            qtaglextras libqtappfw"
+            qttools-native \
+            libqtappfw"
+
 RDEPENDS_${PN} = "agl-service-hvac libqtappfw"
 
 inherit qmake5 aglwgt
index 8c3f72f..d9ecb54 100644 (file)
@@ -10,7 +10,6 @@ DEPENDS = "\
         qtdeclarative \
         qtquickcontrols2 \
         qtwebsockets \
-        qlibwindowmanager \
         qlibhomescreen \
 "
 
index 2e84681..974b202 100644 (file)
@@ -17,7 +17,6 @@ DEPENDS += "qtquickcontrols2 \
             qtwebsockets \
             libqtappfw \
             libhomescreen \
-            qlibwindowmanager \
 "
 
 inherit qmake5 aglwgt
index f6b545d..d2e3ff8 100644 (file)
@@ -16,7 +16,6 @@ S  = "${WORKDIR}/git"
 DEPENDS += "qtquickcontrols2 \
             libqtappfw \
             libhomescreen \
-            qlibwindowmanager \
 "
 
 inherit qmake5 aglwgt
index 9524bed..1e4a271 100644 (file)
@@ -15,7 +15,6 @@ S  = "${WORKDIR}/git"
 # build-time dependencies
 DEPENDS += "qtquickcontrols2 \
             qtwebsockets \
-            qtaglextras \
             libafb-helpers-qt \
 "
 
index b1d0407..7f3fcdf 100644 (file)
@@ -17,7 +17,6 @@ RPROVIDES_${PN} = "virtual/navigation"
 
 DEPENDS  += "qtquickcontrols2 \
              libhomescreen \
-             qlibwindowmanager \
              qtvirtualkeyboard \
              qtlocation \
             "
index c52655e..c06dcae 100644 (file)
@@ -8,9 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS += "qtquickcontrols2 \
             qlibhomescreen \
-            qlibwindowmanager \
             qtlocation \
-            qtaglextras \
             libqtappfw \
 "
 
index b8db9ac..bd3fc64 100644 (file)
@@ -7,7 +7,7 @@ LICENSE          = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
 
 DEPENDS += "qtbase json-c \
-            qlibwindowmanager libhomescreen \
+            libhomescreen \
             libqtappfw \
            "
 
index a61f2c9..e27fe73 100644 (file)
@@ -14,7 +14,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
 DEPENDS += "qtbase \
             qtquickcontrols2 \
             qlibhomescreen \
-            qlibwindowmanager \
             qtlocation \
             libqtappfw \
 "
index ae905ea..b0f63d1 100644 (file)
@@ -13,6 +13,6 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 libhomescreen qlibhomescreen libwindowmanager qlibwindowmanager"
+DEPENDS += "qtquickcontrols2 libhomescreen qlibhomescreen"
 
 inherit qmake5 aglwgt
index cab30ea..a878185 100644 (file)
@@ -16,7 +16,6 @@ S  = "${WORKDIR}/git"
 DEPENDS += "qtquickcontrols2 \
             libqtappfw \
             libhomescreen \
-            qlibwindowmanager \
             gstreamer1.0 \
 "
 
index 3a89af5..7b0934f 100644 (file)
@@ -18,7 +18,7 @@ S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS = "qtquickcontrols2 rtl-sdr"
-DEPENDS += "libhomescreen qlibwindowmanager libqtappfw"
+DEPENDS += "libhomescreen libqtappfw"
 
 inherit qmake5 aglwgt
 
index 17b83dc..776c764 100644 (file)
@@ -14,7 +14,7 @@ S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS += "libqtappfw qtquickcontrols2 qt-qrcode"
-DEPENDS += "libhomescreen qlibwindowmanager qtvirtualkeyboard"
+DEPENDS += "libhomescreen qtvirtualkeyboard"
 
 # runtime dependencies
 RDEPENDS_${PN} += " \
index 13f16fc..68965eb 100644 (file)
@@ -18,7 +18,6 @@ DEPENDS += "qtquickcontrols2 \
             qtcharts \
             libqtappfw \
             libhomescreen \
-            qlibwindowmanager \
 "
 
 inherit qmake5 aglwgt