mapview: It should be run user service instead of system 81/10881/3
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
Mon, 11 Sep 2017 07:07:39 +0000 (16:07 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 9 Oct 2017 21:21:47 +0000 (21:21 +0000)
Change-Id: I65dd87561b80765ae2bbff5fc7f903ffe27394a8
Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
recipes-demo-hmi/navigation/mapviewer/mapviewer.service
recipes-demo-hmi/navigation/mapviewer_%.bbappend

index eba4a0d..c3f5515 100644 (file)
@@ -1,6 +1,6 @@
 [Unit]
 Conflicts=getty@tty1.service
-After=weston.service
+After=weston.service HomeScreen.service
 
 # map viewr is a child application which can work with navigation.
 # This app requires mapdata. It has to be stored at /var/mapdata/navi_data_UK .
@@ -17,6 +17,7 @@ ExecStartPost=/usr/AGL/mapviewer/mapviewer-settings.sh
 
 ExecStop=/usr/bin/killall -s KILL mapview
 Type=simple
+Restart=always
 
 [Install]
-WantedBy=multi-user.target
+WantedBy=default.target
index a4eebfb..4e89af0 100644 (file)
@@ -15,7 +15,8 @@ do_install_append() {
 
     # Install systemd unit files
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-        install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
+        install -d ${D}${systemd_user_unitdir}
+        install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_user_unitdir}/mapviewer.service
     fi
 }
 
@@ -26,6 +27,6 @@ do_install_append() {
 #SYSTEMD_SERVICE_${PN} = "mapviewer.service"
 
 FILES_${PN} += " \
-    ${systemd_system_unitdir}/mapviewer.service \
+    ${systemd_user_unitdir}/mapviewer.service \
     /usr/AGL/mapviewer/ \
     "