osrm-backend: add osrm routing backend recipe 49/11849/3
authorMatt Ranostay <matt.ranostay@konsulko.com>
Mon, 6 Nov 2017 22:07:14 +0000 (00:07 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sat, 11 Nov 2017 10:41:09 +0000 (10:41 +0000)
Add osrm-backend which indexes routing of car, bike, and
walking routes

Bug-AGL: SPEC-1023
Change-Id: I0caeeb228170233d6edd08c66b161c7cfa764e0b
Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
recipes-navigation/osrm-backend/files/0001-cmake-fix-search-paths-for-OE-building.patch [new file with mode: 0644]
recipes-navigation/osrm-backend/osrm-backend_git.bb [new file with mode: 0644]

diff --git a/recipes-navigation/osrm-backend/files/0001-cmake-fix-search-paths-for-OE-building.patch b/recipes-navigation/osrm-backend/files/0001-cmake-fix-search-paths-for-OE-building.patch
new file mode 100644 (file)
index 0000000..80a7b6f
--- /dev/null
@@ -0,0 +1,36 @@
+From a45781fbd39426c0be6d57dcce7ce4679ee63b87 Mon Sep 17 00:00:00 2001
+From: Matt Ranostay <matt.ranostay@konsulko.com>
+Date: Fri, 3 Nov 2017 16:53:34 -0700
+Subject: [PATCH] cmake: fix search paths for OE building
+
+For gcc-6 -isystem breaks #include_next so put recipes
+staging include directory before others
+
+Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 175791651..c5a214102 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -113,6 +113,7 @@ elseif(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
+   endif()
+ endif()
++include_directories(BEFORE ${STAGING_DIR_HOST}/usr/include/)
+ include_directories(BEFORE ${CMAKE_CURRENT_BINARY_DIR}/include/)
+ include_directories(BEFORE ${CMAKE_CURRENT_SOURCE_DIR}/include/)
+ include_directories(SYSTEM ${CMAKE_CURRENT_SOURCE_DIR}/third_party/sol2/)
+@@ -589,7 +590,6 @@ if (ENABLE_STXXL)
+ endif()
+ add_definitions(${OSRM_DEFINES})
+-include_directories(SYSTEM ${DEPENDENCIES_INCLUDE_DIRS})
+ set(BOOST_BASE_LIBRARIES
+    ${Boost_DATE_TIME_LIBRARY}
+-- 
+2.14.2
+
diff --git a/recipes-navigation/osrm-backend/osrm-backend_git.bb b/recipes-navigation/osrm-backend/osrm-backend_git.bb
new file mode 100644 (file)
index 0000000..be93e21
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY     = "Open Source Routing Machine"
+DESCRIPTION = "Open Source Routing Machine C++ backend"
+HOMEPAGE    = "http://map.project-osrm.org"
+SECTION     = "apps"
+
+LICENSE     = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=d7862bc7b1d9f5fbeee5657b31075df1"
+
+SRC_URI = "git://github.com/Project-OSRM/osrm-backend.git;protocol=http \
+           file://0001-cmake-fix-search-paths-for-OE-building.patch \
+           "
+
+SRCREV  = "5b58445535633eb1d6840ef4e8786ff521622867"
+
+FILES_${PN} += " \
+               ${datadir}/osrm/profiles/*.lua \
+               ${datadir}/osrm/profiles/*/*.lua \
+               "
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "boost bzip2 tbb libzip lua osmium protozero expat"
+
+inherit cmake pkgconfig