agl-demo-platform-crosssdk: add libstdc++-staticdev 18/22718/2
authorScott Murray <scott.murray@konsulko.com>
Sun, 20 Oct 2019 13:54:09 +0000 (09:54 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 21 Oct 2019 08:37:05 +0000 (08:37 +0000)
Add libstdc++-staticdev to target toolchain to support building
agl-service-voice-high or other users of the C++17 filesystem standard
library feature.  This can be removed upon upgrade to gcc 9.x, as it
will no longer be necessary.

Bug-AGL: SPEC-2856, SPEC-2857

Change-Id: Ifd50d4e9960fe0bede887317116e6587eca5eb3d
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-platform/images/agl-demo-platform-crosssdk.bb

index 7a9b728..dcd8848 100755 (executable)
@@ -69,3 +69,8 @@ TOOLCHAIN_TARGET_TASK += "mosquitto-dev"
 # dependency of agl-demo, or the speech services are migrated into the
 # core profile.
 TOOLCHAIN_TARGET_TASK += "nlohmann-json-dev"
+
+# Add libstdc++-staticdev to support building agl-service-voice-high or
+# other users of the C++17 filesystem standard library feature.
+# Can be removed upon upgrade to gcc 9.x, as it will no longer be necessary.
+TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"