Update github.com git:// SRC_URIs 01/26801/1
authorScott Murray <scott.murray@konsulko.com>
Tue, 2 Nov 2021 23:17:38 +0000 (19:17 -0400)
committerScott Murray <scott.murray@konsulko.com>
Wed, 3 Nov 2021 18:34:00 +0000 (18:34 +0000)
GitHub is dropping unauthenticated git protocol access in
January 2022, per:

https://github.blog/2021-09-01-improving-git-protocol-security-github/#no-more-unauthenticated-git

While a workaround in the BitBake git fetcher is forthcoming, not
specifying protocol=https for github.com git:// SRC_URIs will start
resulting in warnings in Yocto 3.5/Kirkstone.  To ease our upgrade
path, go ahead and update our affected SRC_URIs.  Note that this has
been done by running the scripts/contrib/convert-srcuri.py script
from latest poky, which also makes git branch specification explicit
since the git fetcher is likely to require that in the future due
to widespread switches from master to main branches.

Bug-AGL: SPEC-4126

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Ibfa59ef83db75f95c4b47b28213b60d8cf19fba1
(cherry picked from commit 94a051785cdb588bc3a475a5490f1f286176d646)

recipes-apis/agl-service-cloudproxy/libcloudproxy_git.bb
recipes-connectivity/cannelloni/cannelloni_git.bb
recipes-connectivity/neardal/neardal_0.14.bb
recipes-connectivity/rtl-sdr/rtl-sdr_0.5.3.bb
recipes-kernel/sllin/sllin.bb
recipes-multimedia/libmp4v2/libmp4v2_git.bb
recipes-multimedia/lightmediascanner/lightmediascanner_0.5.1.bb
recipes-qt/qt-qrcode/qt-qrcode_git.bb
recipes-support/lin-config/lin-config_git.bb
recipes-test/gcovr/gcovr_git.bb
recipes-wam/chromium/chromium84_git.bb

index dddfcc8..520e763 100644 (file)
@@ -12,7 +12,7 @@ DEPENDS = "af-binder json-c"
 
 inherit cmake
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libcloudproxy;protocol=https"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libcloudproxy;protocol=https;branch=master"
 SRCREV = "2d66933b9bf25af66696b097283109c8a6e87151"
 
 S = "${WORKDIR}/git"
index 507dbf0..5378540 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/mguentner/cannelloni"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
-SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https \
+SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https;branch=master \
            file://0001-Fix-compilation-on-latest-gcc-versions.patch \
            "
 
index f8634c4..91b0582 100644 (file)
@@ -1,6 +1,6 @@
 require neardal.inc
 
-SRC_URI = "git://github.com/connectivity/neardal.git;protocol=https \
+SRC_URI = "git://github.com/connectivity/neardal.git;protocol=https;branch=master \
        file://ncl.patch \
        file://0001-neardal-ncl-fix-segfault-on-help-page-being-displaye.patch  \
        file://0002-neardal-lib-fix-memory-corruption.patch             \
index b442d9f..080b5ec 100644 (file)
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
 
 DEPENDS = "libusb1"
 
-SRC_URI = "git://git.osmocom.org/rtl-sdr \
+SRC_URI = "git://git.osmocom.org/rtl-sdr;branch=master \
            file://0001-remove-I-usr-include-in-pkg-config.patch \
            "
 SRCREV = "e3c03f738f5aef4dc51e2b741fbdb542b9cc1bb1"
index 59994d8..0c6793a 100644 (file)
@@ -6,7 +6,7 @@ inherit module systemd
 
 DEPENDS = "virtual/kernel"
 
-SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https"
+SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https;branch=master"
 SRCREV = "155d885e8ccc907a56f6c86c4b159fac27ef6fec"
 S = "${WORKDIR}/git/sllin"
 
index 2887287..ed6c8b4 100644 (file)
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=eb3014b036b6d2151d944aef6a84c36f"
 inherit autotools-brokensep pkgconfig
 
 SRC_URI = " \
-    git://github.com/sergiomb2/${BPN}.git \
+    git://github.com/sergiomb2/${BPN}.git;branch=master;protocol=https \
     file://0001-add-a-configure-option-to-disable-build-of-man-pages.patch \
     file://gcc10.patch \
 "
index f215876..4be27b1 100644 (file)
@@ -10,7 +10,7 @@ DEPENDS = "file gawk glib-2.0 sqlite3"
 
 PV = "0.5.1+git${SRCPV}"
 SRCREV = "adfddb3486276a5ed2f5008c9e43a811e1271cc9"
-SRC_URI = "git://github.com/profusion/lightmediascanner.git \
+SRC_URI = "git://github.com/profusion/lightmediascanner.git;branch=master;protocol=https \
            file://id3-plugin-support-out-of-tree-build.patch \
            file://0001-Define-comparison_fn_t-for-non-glibc-systems.patch \
           "
index fcc7139..52f2468 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=94a3f3bdf61243b5e5cf569fbfbbea52"
 
 DEPENDS = "qtbase qtdeclarative qtquickcontrols2 qtsvg qrencode"
 
-SRC_URI = "git://github.com/danielsanfr/qt-qrcode.git;protocol=https \
+SRC_URI = "git://github.com/danielsanfr/qt-qrcode.git;protocol=https;branch=master \
            file://0001-rework-library-build.patch \
            file://0002-fix-dangling-pointer.patch \
            "
index 3858168..0e45a55 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://lin_config.c;beginline=4;endline=9;md5=196a29df19a30d
 
 DEPENDS += "libnl libxml2"
 
-SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https"
+SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https;branch=master"
 SRCREV = "155d885e8ccc907a56f6c86c4b159fac27ef6fec"
 S = "${WORKDIR}/git/lin_config/src"
 
index 6da04cc..5bad0a9 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=221e634a1ceafe02ef74462cbff2fb16"
 
 PV = "4.2+git${SRCPV}"
-SRC_URI = "git://github.com/gcovr/gcovr.git;protocol=https"
+SRC_URI = "git://github.com/gcovr/gcovr.git;protocol=https;branch=master"
 SRCREV = "1bc72e3bb59b9296e962b350691732ddafbd3195"
 
 S = "${WORKDIR}/git"
index aef9e2e..6788cb5 100644 (file)
@@ -2,7 +2,7 @@ require chromium.inc
 
 SRC_URI = "\
     git://github.com/igalia/${PN};branch=koi;protocol=https;rev=${SRCREV_chromium84};name=chromium84 \
-    git://github.com/webosose/chromium-v8;branch=@chromium84;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8 \
+    git://github.com/webosose/chromium-v8;branch=@chromium84;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8;protocol=https \
     file://add-a-delay-to-agl-ready-event.patch \
     file://chromium-quiche-invalid-offsetof.patch \
     file://chromium-skia-no_sanitize.patch \