Fix S definitions in various recipes 01/26101/1
authorScott Murray <scott.murray@konsulko.com>
Thu, 25 Feb 2021 20:55:03 +0000 (15:55 -0500)
committerScott Murray <scott.murray@konsulko.com>
Thu, 25 Feb 2021 21:30:33 +0000 (16:30 -0500)
Bitbake in poky master now warns if the path in the S variable
definition has a trailing '/', remove all occurrences to reduce
"next" branch maintenance.

Bug-AGL: SPEC-3819

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I226095245c208e579b6b176d333918d5e1c70844

16 files changed:
recipes-apis/agl-service-cloudproxy/agl-service-cloudproxy_git.bb
recipes-demo/homescreen-demo-ci/homescreen-demo-ci_git.bb
recipes-demo/homescreen/homescreen_git.bb
recipes-demo/html5-background/html5-background_git.bb
recipes-demo/html5-dashboard/html5-dashboard_git.bb
recipes-demo/html5-homescreen/html5-homescreen_git.bb
recipes-demo/html5-hvac/html5-hvac_git.bb
recipes-demo/html5-launcher/html5-launcher_git.bb
recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
recipes-demo/html5-mixer/html5-mixer_git.bb
recipes-demo/html5-settings/html5-settings_git.bb
recipes-demo/inputeventmanager/inputeventmanager_git.bb
recipes-demo/launcher/launcher_git.bb
recipes-demo/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb
recipes-demo/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
recipes-qt/qt-qrcode/qt-qrcode_git.bb

index 99773a4..03e6a0e 100644 (file)
@@ -9,7 +9,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy;p
 SRCREV = "${AGL_APP_REVISION}"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 DEPENDS = "azure-iot-sdk-c aws-iot-device-sdk-embedded-c glib-2.0 nlohmann-json"
 
index c3814f1..8155b65 100644 (file)
@@ -26,7 +26,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen-demo-ci;proto
 SRCREV  = "${AGL_APP_REVISION}"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
index 2fb000f..1ec938b 100644 (file)
@@ -23,7 +23,7 @@ PV      = "1.0+git${SRCPV}"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 inherit qmake5 systemd pkgconfig aglwgt
 
index c0ac220..4be5607 100644 (file)
@@ -3,7 +3,7 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 SRC_URI = "git://github.com/AGL-web-applications/background.git;protocol=https;branch=master"
 SRCREV = "3b8dae349d428c0230b9885f86d421d43cda5638"
index ac87475..7f37567 100644 (file)
@@ -5,7 +5,7 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
index 37ca707..f927cb7 100644 (file)
@@ -5,7 +5,7 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
index 7fc89ae..91654b4 100644 (file)
@@ -5,7 +5,7 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
index 47760f6..ab99cf5 100644 (file)
@@ -5,7 +5,7 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
index a87b9bc..ddb2ee2 100644 (file)
@@ -5,7 +5,7 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
index 97b1195..e643c59 100644 (file)
@@ -5,7 +5,7 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
index a167b14..010c691 100644 (file)
@@ -5,7 +5,7 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-settings;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
index 16ee007..8a0c72c 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "InputEventManager"
 HOMEPAGE    = "http://docs.automotivelinux.org"
 LICENSE     = "Apache-2.0"
 SECTION     = "apps"
-S           = "${WORKDIR}/git/"
+S           = "${WORKDIR}/git"
 
 inherit qmake5 systemd
 DEPENDS = " qtbase "
index 3637070..115ebcc 100644 (file)
@@ -22,7 +22,7 @@ PV      = "1.0+git${SRCPV}"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 inherit qmake5 systemd pkgconfig aglwgt
 
index 605c4ce..be2eace 100644 (file)
@@ -10,7 +10,7 @@ PV = "1.0+git${SRCPV}"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl-style;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "c02692a3c20d9aed1192137a67d5be882c60e71f"
 
-S = "${WORKDIR}/git/"
+S = "${WORKDIR}/git"
 
 inherit qmake5
 
index faab221..a81e1a9 100644 (file)
@@ -10,7 +10,7 @@ PV = "1.0+git${SRCPV}"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "22b538aae1f69de5273f1e42a854cfab23a32b60"
 
-S = "${WORKDIR}/git/"
+S = "${WORKDIR}/git"
 
 inherit qmake5
 
index 0a7ae73..fcc7139 100644 (file)
@@ -14,6 +14,6 @@ SRC_URI = "git://github.com/danielsanfr/qt-qrcode.git;protocol=https \
 SRCREV = "2d57d9c6e2341689d10f9360a16a08831a4a820b"
 
 PV = "git${SRCPV}"
-S = "${WORKDIR}/git/"
+S = "${WORKDIR}/git"
 
 inherit qmake5