Add base demo images 78/29278/2
authorScott Murray <scott.murray@konsulko.com>
Sat, 14 Oct 2023 00:14:00 +0000 (20:14 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 17 Oct 2023 10:57:24 +0000 (10:57 +0000)
Some rework to add agl-ivi-demo-base and agl-ivi-demo-base-flutter
images that have all of the required demo services and configuration,
but not our demo UI applications. As part of this, move some of the
conditional package inclusion logic out of the demo platform
packagegroups into the image recipes to make the packagegroup contents
stable, and add applaunchd to the IVI services packagegroup so it'll
always get pulled in. Some of this may still get redone in the future
per SPEC-4813.

Bug-AGL: SPEC-4933

Change-Id: Ief4b7ef3f0720315cbdc579f62b1196c66e237cd
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29278
Reviewed-by: Lisandro P�rez Meyer <lpmeyer@ics.com>
Reviewed-by: Hiroyuki Ishii <ishii.hiroyuki002@jp.panasonic.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

recipes-platform/images/agl-ivi-demo-base-flutter.bb [new file with mode: 0644]
recipes-platform/images/agl-ivi-demo-base.bb [new file with mode: 0644]
recipes-platform/images/agl-ivi-demo-platform-flutter.bb
recipes-platform/images/agl-ivi-demo-platform.bb
recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb

diff --git a/recipes-platform/images/agl-ivi-demo-base-flutter.bb b/recipes-platform/images/agl-ivi-demo-base-flutter.bb
new file mode 100644 (file)
index 0000000..70fd2c5
--- /dev/null
@@ -0,0 +1,9 @@
+require agl-ivi-demo-base.bb
+
+DESCRIPTION = "AGL Flutter demo base image"
+
+IMAGE_INSTALL += " \
+    packagegroup-agl-demo-platform-flutter \
+    weston-ini-conf-flutter \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
+"
diff --git a/recipes-platform/images/agl-ivi-demo-base.bb b/recipes-platform/images/agl-ivi-demo-base.bb
new file mode 100644 (file)
index 0000000..da8d2ee
--- /dev/null
@@ -0,0 +1,23 @@
+require agl-image-ivi.bb
+
+DESCRIPTION = "AGL demo base image"
+
+require agl-demo-features.inc
+require agl-demo-container-guest-integration.inc
+
+AGL_DEVEL_INSTALL += "\
+    packagegroup-agl-kuksa-val-databroker-devel \
+    simple-can-simulator \
+    unzip \
+    mpc \
+"
+
+AGL_APPS_INSTALL = ""
+
+IMAGE_INSTALL += " \
+    ${AGL_APPS_INSTALL} \
+    ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "${AGL_DEVEL_INSTALL}" , "", d)} \
+"
+
+
+
index 9d67ee3..dfebce0 100644 (file)
@@ -1,21 +1,21 @@
-require agl-image-ivi.bb
+require agl-ivi-demo-base-flutter.bb
 
-DESCRIPTION = "AGL Flutter based Demo Platform image"
+DESCRIPTION = "AGL Flutter Demo Platform image"
 
-require agl-demo-features.inc
-require agl-demo-container-guest-integration.inc
-
-# Add packages for demo platform (include demo apps) here
-
-AGL_DEVEL_INSTALL += "\
-    packagegroup-agl-kuksa-val-databroker-devel \
-    simple-can-simulator \
+AGL_APPS_INSTALL += " \
+    flutter-homescreen \
+    flutter-dashboard \
+    flutter-hvac \
+    ondemandnavi \
+    settings \
+    mediaplayer \
+    messaging \
+    phone \
+    radio \
 "
 
 IMAGE_INSTALL += " \
-    packagegroup-agl-demo-platform-flutter \
-    weston-ini-conf-flutter \
-    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
-    ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "${AGL_DEVEL_INSTALL}" , "", d)} \
+    qtquickcontrols2-agl \
+    qtquickcontrols2-agl-style \
 "
 
index d860cd5..318bae4 100644 (file)
@@ -1,20 +1,22 @@
-require agl-image-ivi.bb
+require agl-ivi-demo-base.bb
 
-DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and demos."
+DESCRIPTION = "AGL Qt Demo Platform image"
 
-require agl-demo-features.inc
-require agl-demo-container-guest-integration.inc
-
-# Add packages for demo platform (include demo apps) here
-
-AGL_DEVEL_INSTALL += "\
-    packagegroup-agl-kuksa-val-databroker-devel \
-    simple-can-simulator \
+AGL_APPS_INSTALL += " \
+    dashboard \
+    hvac \
+    ondemandnavi \
+    settings \
+    mediaplayer \
+    messaging \
+    phone \
+    radio \
+    window-management-client-grpc \
+    camera-gstreamer \
 "
 
 IMAGE_INSTALL += " \
     packagegroup-agl-demo-platform \
     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
-    ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "${AGL_DEVEL_INSTALL}" , "", d)} \
 "
 
index 8e64544..e01c315 100644 (file)
@@ -16,24 +16,10 @@ RDEPENDS:${PN} += "\
     packagegroup-agl-demo \
     "
 
-AGL_APPS = " \
-    flutter-dashboard \
-    flutter-hvac \
-    ondemandnavi \
-    settings \
-    mediaplayer \
-    messaging \
-    phone \
-    radio \
-    "
-
 RDEPENDS:${PN}:append = " \
     agl-compositor \
     flutter-auto \
-    flutter-homescreen \
-    qtquickcontrols2-agl \
-    qtquickcontrols2-agl-style \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \
-    ${AGL_APPS} \
+    agl-flutter-env \
+    applaunchd-template-agl-app-flutter \
     psplash-portrait-config \
     "
index 6095f71..cf8268d 100644 (file)
@@ -16,26 +16,11 @@ RDEPENDS:${PN} += "\
     packagegroup-agl-demo \
     "
 
-AGL_APPS = " \
-    dashboard \
-    hvac \
-    ondemandnavi \
-    settings \
-    mediaplayer \
-    messaging \
-    phone \
-    radio \
-    window-management-client-grpc \
-    camera-gstreamer \
-    "
-
 RDEPENDS:${PN}:append = " \
     weston-ini-conf-no-activate \
     homescreen \
     launcher \
     qtquickcontrols2-agl \
     qtquickcontrols2-agl-style \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \
-    ${AGL_APPS} \
     psplash-portrait-config \
     "
index b769426..e4a4a9d 100644 (file)
@@ -8,6 +8,8 @@ PACKAGES = "\
     "
 
 RDEPENDS:${PN} += "\
+    applaunchd \
+    applaunchd-template-agl-app \
     agl-service-hvac \
     agl-service-audiomixer \
     agl-service-radio \