Fix Qt dependency of the CES demo. 61/4261/2
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Thu, 5 Nov 2015 04:13:18 +0000 (13:13 +0900)
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Thu, 5 Nov 2015 07:24:52 +0000 (16:24 +0900)
Fix package names of QtMultimedia and QtQuickControls in RDEPENDS.

Package names of 'qtmultimedia' and 'qtquickcontrols' with meta-qt5/master
work fine, but it caused build and runtime errors with meta-qt5/dizzy.

Correct package names are 'qtmultimedia-qmlplugins' and
'qtquickcontrols-qmlplugins'.

And 'qtsvg-plugins' was also missing.

Change-Id: I43829b144dd7b51ab97a453ffebaf09f2fd859c0
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
recipes-demo-hmi/CES2016-demo/CES2016-demo.bb

index 48e242b..df3a92a 100644 (file)
@@ -10,7 +10,11 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
 SRC_URI     = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/CES2016;protocol=http"
 SRCREV      = "AUTOINC"
 
-RDEPENDS_${PN}_append = "qtmultimedia qtquickcontrols"
+RDEPENDS_${PN} += " \
+    qtmultimedia-qmlplugins \
+    qtquickcontrols-qmlplugins \
+    qtsvg-plugins \
+    "
 
 # custom configure and install as these are just qml files