ofono: remove bbappend
authorScott Murray <scott.murray@konsulko.com>
Wed, 20 Mar 2024 16:12:23 +0000 (12:12 -0400)
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>
Wed, 24 Apr 2024 15:25:38 +0000 (15:25 +0000)
Remove our ofono bbappend since the local patch no longer applies
and the custom configuration has not been tested in several years.

Bug-AGL: SPEC-4578

Change-Id: Iadff9ea539519342f94d14bbe5d63e21367638f5
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-connectivity/ofono/files/0001-provision-allow-duplicate-entries-from-mbpi_lookup_a.patch [deleted file]
recipes-connectivity/ofono/files/ofono.conf [deleted file]
recipes-connectivity/ofono/ofono_%.bbappend [deleted file]
recipes-connectivity/ofono/ofono_agldemo.inc [deleted file]

diff --git a/recipes-connectivity/ofono/files/0001-provision-allow-duplicate-entries-from-mbpi_lookup_a.patch b/recipes-connectivity/ofono/files/0001-provision-allow-duplicate-entries-from-mbpi_lookup_a.patch
deleted file mode 100644 (file)
index 02bf5a6..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From 7782f8f9d9634ebeddafefedab10ba254f9cc34a Mon Sep 17 00:00:00 2001
-From: Matt Ranostay <matt.ranostay@konsulko.com>
-Date: Fri, 1 Mar 2019 17:53:17 +0900
-Subject: [PATCH] provision: allow duplicate entries from mbpi_lookup_apn()
- results
-
-Upstream-Status: Pending
-
-Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
----
- plugins/provision.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/plugins/provision.c b/plugins/provision.c
-index 99c299eb..aa0b05e4 100644
---- a/plugins/provision.c
-+++ b/plugins/provision.c
-@@ -50,7 +50,7 @@ static int provision_get_settings(const char *mcc, const char *mnc,
-       DBG("Provisioning for MCC %s, MNC %s, SPN '%s'", mcc, mnc, spn);
--      apns = mbpi_lookup_apn(mcc, mnc, FALSE, &error);
-+      apns = mbpi_lookup_apn(mcc, mnc, TRUE, &error);
-       if (apns == NULL) {
-               if (error != NULL) {
-                       ofono_error("%s", error->message);
--- 
-2.20.1
-
diff --git a/recipes-connectivity/ofono/files/ofono.conf b/recipes-connectivity/ofono/files/ofono.conf
deleted file mode 100644 (file)
index e47214c..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-<!-- This configuration file specifies the required security policies
-     for oFono core daemon to work. -->
-
-<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
- "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
-
-  <!-- ../system.conf have denied everything, so we just punch some holes -->
-
-  <policy user="root">
-    <allow own="org.ofono"/>
-    <allow send_destination="org.ofono"/>
-    <allow send_interface="org.ofono.Manager"/>
-    <allow send_interface="org.ofono.SimToolkitAgent"/>
-    <allow send_interface="org.ofono.PushNotificationAgent"/>
-    <allow send_interface="org.ofono.SmartMessagingAgent"/>
-    <allow send_interface="org.ofono.PositioningRequestAgent"/>
-    <allow send_interface="org.ofono.HandsfreeAudioAgent"/>
-    <allow send_interface="org.ofono.Modem"/>
-  </policy>
-
-  <policy at_console="true">
-    <allow send_destination="org.ofono"/>
-  </policy>
-
-  <policy context="default">
-    <deny send_destination="org.ofono"/>
-  </policy>
-
-</busconfig>
diff --git a/recipes-connectivity/ofono/ofono_%.bbappend b/recipes-connectivity/ofono/ofono_%.bbappend
deleted file mode 100644 (file)
index 0386aa9..0000000
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'ofono_agldemo.inc', '', d)}
diff --git a/recipes-connectivity/ofono/ofono_agldemo.inc b/recipes-connectivity/ofono/ofono_agldemo.inc
deleted file mode 100644 (file)
index 2619835..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI:append = "\
-    file://ofono.conf \
-    file://0001-provision-allow-duplicate-entries-from-mbpi_lookup_a.patch \
-    "
-
-do_install:append() {
-    install -m 0644 ${WORKDIR}/ofono.conf ${D}${sysconfdir}/dbus-1/system.d/ofono.conf
-}
-
-SYSTEMD_AUTO_ENABLE = "enable"