recipes-demo: Add videoplayer recipe. 46/27846/5
authorVasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>
Fri, 29 Jul 2022 12:29:32 +0000 (14:29 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 22 Sep 2022 11:20:22 +0000 (11:20 +0000)
videoplayer BitBake recipe imported from attachment to AGL JIRA ticket
[1] with adaptation for AGL NN.

videoplayer suggested as an application to play video in [2]. Out from
the box mediaplayer does not support video (only audio is supported).

[1]: https://jira.automotivelinux.org/browse/SPEC-2389
[2]: https://jira.automotivelinux.org/browse/SPEC-4028

Bug-AGL: SPEC-4148
Change-Id: Ifd20f3e00ad1a99d0d05b8fb361ff7a8eb7a78f2
Signed-off-by: Vasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>
recipes-demo/videoplayer/videoplayer_git.bb [new file with mode: 0644]

diff --git a/recipes-demo/videoplayer/videoplayer_git.bb b/recipes-demo/videoplayer/videoplayer_git.bb
new file mode 100644 (file)
index 0000000..36c8375
--- /dev/null
@@ -0,0 +1,31 @@
+SUMMARY     = "Video Player for AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating Media Player on AGL Distribution"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/videoplayer"
+SECTION     = "apps"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/videoplayer;protocol=https;nobranch=1"
+SRCREV = "2f4d09aec6531c64356a52255bcfaf8df7c4f3e4"
+
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += " \
+    qtquickcontrols2 \
+    libqtappfw \
+    qtmultimedia \
+"
+
+inherit qmake5 agl-app
+
+AGL_APP_NAME = "Video"
+
+RDEPENDS:${PN} += " \
+    qtmultimedia \
+    qtmultimedia-qmlplugins \
+"
+
+FILES:${PN} += "${datadir}/icons"