Add CES2017-demo and change image definition 65/6965/2
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Tue, 1 Nov 2016 14:15:39 +0000 (15:15 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 1 Nov 2016 14:52:08 +0000 (14:52 +0000)
Change-Id: Ia9f4f619bc0c6576e35cd6fc66267938869dd92c
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-demo-hmi/CES2017-demo/CES2017-demo.bb [new file with mode: 0644]
recipes-platform/images/agl-demo-platform.bb

diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
new file mode 100644 (file)
index 0000000..c94950b
--- /dev/null
@@ -0,0 +1,38 @@
+SUMMARY     = "Homescreen for the AGL Demonstrator @ CES2017"
+DESCRIPTION = "Homescreen apps in QML format for the AGL Demonstrator @ CESS2017"
+HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2017"
+
+SECTION     = "apps"
+
+PN = "ces2017-demo"
+
+LICENSE     = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
+
+SRC_URI     = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http"
+SRCREV      = "${AUTOREV}"
+
+PV = "1.0+git"
+
+RDEPENDS_${PN} += " \
+    qtmultimedia-qmlplugins \
+    qtquickcontrols-qmlplugins \
+    qtsvg-plugins \
+    "
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+    ls
+}
+
+# plain copy in own folder for now
+do_install() {
+    mkdir -p ${D}/usr/AGL/CES2017/
+    cp -rf ./* ${D}/usr/AGL/CES2017/
+}
+
+FILES_${PN} = "/usr/AGL/"
index 7fa34e5..6c1f564 100644 (file)
@@ -23,10 +23,9 @@ IMAGE_TTF_FONTS = " \
     ttf-dejavu-serif \
     "
 
-# add packages for CES2016 demo
+# add packages for CES2017 demo
 IMAGE_INSTALL_append = " \
-    als2016-demo \
-    ces2016-demo \
+    ces2017-demo \
     can-utils iproute2 \
     python-curses \
     dhcp-client \