Update for kirkstone variable renames
authorScott Murray <scott.murray@konsulko.com>
Tue, 22 Feb 2022 16:04:27 +0000 (11:04 -0500)
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>
Wed, 13 Apr 2022 13:31:22 +0000 (13:31 +0000)
Apply updates from running the new convert-variable-renames script
from upstream.  There are a few things outside of BitBake variables
that the script still complains about that will need to be addressed
in follow up changes.

Bug-AGL: SPEC-3819

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Icc6056cfdd9759470e99a51fe96d8d793e63a4ff

recipes-multimedia/musicpd/mpd_0.23.5.bb
recipes-multimedia/musicpd/mpd_agldemo.inc

index 3c6f3e4..5596760 100644 (file)
@@ -26,9 +26,9 @@ S = "${WORKDIR}/git"
 
 EXTRA_OEMESON += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-Dsystemd=enabled -Dsystemd_system_unit_dir=${systemd_system_unitdir} -Dsystemd_user_unit_dir=${systemd_system_unitdir}', '-Dsystemd=disabled', d)}"
 
-PACKAGECONFIG ??= "${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "aac", "", d)} \
+PACKAGECONFIG ??= "${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "aac", "", d)} \
                    alsa ao bzip2 daemon \
-                   ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "ffmpeg aac", "", d)} \
+                   ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "ffmpeg aac", "", d)} \
                    fifo flac fluidsynth iso9660 \
                    jack libsamplerate httpd \
                    mms mpg123 modplug sndfile \
index 8bbd591..c2e79f2 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI += "file://0001-Tweaks-to-allow-building-with-older-meson.patch \
 # build.{c_std,cpp_std} options even though they work, so we need to
 # flag them to be ignored in the unknown configure option QA test.
 # This can be removed after upgrading to Yocto Project 3.5.
-UNKNOWN_CONFIGURE_WHITELIST = "build.c_std build.cpp_std"
+UNKNOWN_CONFIGURE_OPT_IGNORE = "build.c_std build.cpp_std"
 
 # This also needs to be pushed upstream.
 PACKAGECONFIG[pipewire] = "-Dpipewire=enabled,-Dpipewire=disabled,pipewire"
@@ -20,10 +20,10 @@ PACKAGECONFIG[pipewire] = "-Dpipewire=enabled,-Dpipewire=disabled,pipewire"
 # Prune the default configuration a bit to remove various streaming/server
 # options that are not required.
 PACKAGECONFIG = " \
-    ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "aac", "", d)} \
+    ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "aac", "", d)} \
     bzip2 \
     daemon \
-    ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "ffmpeg aac", "", d)} \
+    ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "ffmpeg aac", "", d)} \
     flac \
     libsamplerate \
     mpg123 \