Move core speech service to meta-agl-demo 27/25827/1 10.91.0 koi/10.91.0 koi_10.91.0
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 17 Dec 2020 16:17:19 +0000 (17:17 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 17 Dec 2020 16:17:19 +0000 (17:17 +0100)
This moves the generic agl-speechframework to meta-agl-demo.
The alexa-voiceagent bits remain in meta-agl-devel for now.

This fixes a dependency of the settings app.

Bug-AGL: SPEC-3734
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: If177271a4a2584ec71ab53ac02764c8065f8b313

conf/include/agl-demo.inc
recipes-apis/agl-service-voice-high-capabilities/agl-service-voice-high-capabilities_git.bb [new file with mode: 0644]
recipes-apis/agl-service-voice-high/agl-service-voice-high_git.bb [new file with mode: 0644]
recipes-apis/agl-service-voice-high/default-voice-high-config/voice-high.json [new file with mode: 0644]
recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-speech-services.bb [new file with mode: 0644]

index 390f47e..c3c051d 100644 (file)
@@ -11,3 +11,8 @@ FEATURE_PACKAGES_agl-voiceagent-alexa_append = " alexa-viewer"
 
 # enable the layer
 AGL_FEATURES_append = " agldemo"
+
+# voice api inclusion
+PREFERRED_RPROVIDER_virtual/voice-high-config = "default-voice-high-config"
+FEATURE_PACKAGES_agl-speech-framework = "packagegroup-agl-speech-services"
+IMAGE_FEATURES += "agl-speech-framework"
diff --git a/recipes-apis/agl-service-voice-high-capabilities/agl-service-voice-high-capabilities_git.bb b/recipes-apis/agl-service-voice-high-capabilities/agl-service-voice-high-capabilities_git.bb
new file mode 100644 (file)
index 0000000..0ab1f3d
--- /dev/null
@@ -0,0 +1,17 @@
+SUMMARY = "agl-service-voice-high"
+DESCRIPTION = "AGL High Level Voice service"
+HOMEPAGE = "https://git.automotivelinux.org/apps/agl-service-voice-high-capabilities"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "libafb-helpers libappcontroller nlohmann-json"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high-capabilities.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "0.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig aglwgt
diff --git a/recipes-apis/agl-service-voice-high/agl-service-voice-high_git.bb b/recipes-apis/agl-service-voice-high/agl-service-voice-high_git.bb
new file mode 100644 (file)
index 0000000..b3c782b
--- /dev/null
@@ -0,0 +1,19 @@
+SUMMARY = "High level voice service binding"
+DESCRIPTION = "agl-service-voice-high is the binding library"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "json-c systemd af-binder libafb-helpers libappcontroller nlohmann-json glib-2.0"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit cmake aglwgt
+
+RDEPENDS_${PN} += "virtual/voice-high-config"
diff --git a/recipes-apis/agl-service-voice-high/default-voice-high-config/voice-high.json b/recipes-apis/agl-service-voice-high/default-voice-high-config/voice-high.json
new file mode 100644 (file)
index 0000000..1b72b8c
--- /dev/null
@@ -0,0 +1 @@
+{ "default": "" }
diff --git a/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb b/recipes-apis/agl-service-voice-high/default-voice-high-config_1.0.bb
new file mode 100644 (file)
index 0000000..b015dd5
--- /dev/null
@@ -0,0 +1,20 @@
+SUMMARY = "High level voice service binding default voiceagent configuration"
+DESCRIPTION = "Default voiceagent JSON configuration file for agl-service-voice-high binding"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "file://voice-high.json"
+
+inherit allarch
+
+do_compile[noexec] = "1"
+
+do_install () {
+    install -D -m 644 ${WORKDIR}/voice-high.json ${D}${sysconfdir}/xdg/AGL/voice-high.json
+}
+
+RPROVIDES_${PN} += "virtual/voice-high-config"
+
diff --git a/recipes-platform/packagegroups/packagegroup-agl-speech-services.bb b/recipes-platform/packagegroups/packagegroup-agl-speech-services.bb
new file mode 100644 (file)
index 0000000..8dd97f3
--- /dev/null
@@ -0,0 +1,14 @@
+DESCRIPTION = "The set of packages for AGL Speech Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-speech-services \
+    "
+
+RDEPENDS_${PN} += "\
+    agl-service-voice-high \
+    agl-service-voice-high-capabilities \
+    ${PREFERRED_RPROVIDER_virtual/voice-high-config} \
+"