Merge the agl-compositor sandbox into master 59/24859/1
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Wed, 24 Jun 2020 15:53:33 +0000 (17:53 +0200)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Wed, 24 Jun 2020 15:54:18 +0000 (17:54 +0200)
The changes prepared by Marius for agl-compositor
have been reviewed in the sandbox/mvlad/agl-compositor.

This is the merge to master.

Notes:
- weston+ivi-shell+windowmanager are replaced using agl-compositor
- applications have been adapted accordingly
- CI will likely fail as we need to merge all related patches

* gerrit/sandbox/mvlad/agl-compositor:
  Make the agl-compositor the default compositor
  recipes-demo-hmi: Remove qtaglextras and *-windowmanager depends
  packagegroup-agl-demo-platform: Remove qtaglextras dependency
  packagegroup-hmi-framework: Remove *-windowmanager dependency

 recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb                | 6 ++++--
 recipes-demo-hmi/dashboard/dashboard_git.bb                      | 2 +-
 recipes-demo-hmi/homescreen/homescreen_git.bb                    | 6 ++++--
 recipes-demo-hmi/hvac/hvac_git.bb                                | 5 +++--
 recipes-demo-hmi/launcher/launcher_git.bb                        | 5 ++++-
 recipes-demo-hmi/mediaplayer/mediaplayer_git.bb                  | 1 -
 recipes-demo-hmi/messaging/messaging_git.bb                      | 1 -
 recipes-demo-hmi/mixer/mixer_git.bb                              | 1 -
 recipes-demo-hmi/navigation/navigation-demo_git.bb               | 1 -
 recipes-demo-hmi/navigation/ondemandnavi_git.bb                  | 2 --
 recipes-demo-hmi/navigation/poiapp_git.bb                        | 2 +-
 recipes-demo-hmi/navigation/tbtnavi_git.bb                       | 1 -
 recipes-demo-hmi/onscreenapp/onscreenapp_git.bb                  | 2 +-
 recipes-demo-hmi/phone/phone_git.bb                              | 1 -
 recipes-demo-hmi/radio/radio_git.bb                              | 2 +-
 recipes-demo-hmi/settings/settings_git.bb                        | 2 +-
 recipes-demo-hmi/taskmanager/taskmanager_git.bb                  | 1 -
 recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb | 4 +---
 recipes-platform/packagegroups/packagegroup-hmi-framework.bb     | 6 ------
 19 files changed, 21 insertions(+), 30 deletions(-)

Change-Id: I2942a82beee36f283817ae566ec44b5f3219411f
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
19 files changed:
recipes-demo-hmi/alexa-viewer/alexa-viewer_git.bb
recipes-demo-hmi/dashboard/dashboard_git.bb
recipes-demo-hmi/homescreen/homescreen_git.bb
recipes-demo-hmi/hvac/hvac_git.bb
recipes-demo-hmi/launcher/launcher_git.bb
recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
recipes-demo-hmi/messaging/messaging_git.bb
recipes-demo-hmi/mixer/mixer_git.bb
recipes-demo-hmi/navigation/navigation-demo_git.bb
recipes-demo-hmi/navigation/ondemandnavi_git.bb
recipes-demo-hmi/navigation/poiapp_git.bb
recipes-demo-hmi/navigation/tbtnavi_git.bb
recipes-demo-hmi/onscreenapp/onscreenapp_git.bb
recipes-demo-hmi/phone/phone_git.bb
recipes-demo-hmi/radio/radio_git.bb
recipes-demo-hmi/settings/settings_git.bb
recipes-demo-hmi/taskmanager/taskmanager_git.bb
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
recipes-platform/packagegroups/packagegroup-hmi-framework.bb

index f98704e..f73a97a 100644 (file)
@@ -8,10 +8,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS = " \
        qtquickcontrols2 \
-       qlibwindowmanager \
        qlibhomescreen \
        af-binder \
        libqtappfw \
+       wayland-native \
+       wayland \
+       qtwayland \
+       qtwayland-native \
 "
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
@@ -27,7 +30,6 @@ OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel'
 RDEPENDS_${PN} = " \
        libqtappfw \
        libafbwsc \
-       qlibwindowmanager \
        qlibhomescreen \
        agl-service-voice-high-capabilities \
 "
index 822207b..70a8793 100644 (file)
@@ -13,7 +13,7 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 qttools-native qtaglextras libqtappfw"
+DEPENDS += "qtquickcontrols2 qttools-native libqtappfw"
 
 inherit qmake5 aglwgt
 
index a49c305..44a0f52 100644 (file)
@@ -10,12 +10,14 @@ DEPENDS = "\
         qtdeclarative \
         qtquickcontrols2 \
         agl-service-homescreen \
-        agl-service-windowmanager \
         agl-service-weather \
         libqtappfw \
-        qlibwindowmanager \
         libhomescreen \
         libafb-helpers-qt \
+        wayland-native \
+        wayland \
+        qtwayland \
+        qtwayland-native
 "
 
 inherit qmake5 systemd pkgconfig aglwgt
index 6091e51..5e36e2d 100644 (file)
@@ -14,8 +14,9 @@ S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS += "qtquickcontrols2 libhomescreen \
-            qlibwindowmanager qttools-native \
-            qtaglextras libqtappfw"
+            qttools-native \
+            libqtappfw"
+
 RDEPENDS_${PN} = "agl-service-hvac libqtappfw"
 
 inherit qmake5 aglwgt
index 8c3f72f..5b1de01 100644 (file)
@@ -10,8 +10,11 @@ DEPENDS = "\
         qtdeclarative \
         qtquickcontrols2 \
         qtwebsockets \
-        qlibwindowmanager \
         qlibhomescreen \
+        wayland-native \
+        wayland \
+        qtwayland \
+        qtwayland-native \
 "
 
 inherit qmake5 systemd pkgconfig aglwgt
index 2e84681..974b202 100644 (file)
@@ -17,7 +17,6 @@ DEPENDS += "qtquickcontrols2 \
             qtwebsockets \
             libqtappfw \
             libhomescreen \
-            qlibwindowmanager \
 "
 
 inherit qmake5 aglwgt
index f6b545d..d2e3ff8 100644 (file)
@@ -16,7 +16,6 @@ S  = "${WORKDIR}/git"
 DEPENDS += "qtquickcontrols2 \
             libqtappfw \
             libhomescreen \
-            qlibwindowmanager \
 "
 
 inherit qmake5 aglwgt
index 9524bed..1e4a271 100644 (file)
@@ -15,7 +15,6 @@ S  = "${WORKDIR}/git"
 # build-time dependencies
 DEPENDS += "qtquickcontrols2 \
             qtwebsockets \
-            qtaglextras \
             libafb-helpers-qt \
 "
 
index b1d0407..7f3fcdf 100644 (file)
@@ -17,7 +17,6 @@ RPROVIDES_${PN} = "virtual/navigation"
 
 DEPENDS  += "qtquickcontrols2 \
              libhomescreen \
-             qlibwindowmanager \
              qtvirtualkeyboard \
              qtlocation \
             "
index c52655e..c06dcae 100644 (file)
@@ -8,9 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS += "qtquickcontrols2 \
             qlibhomescreen \
-            qlibwindowmanager \
             qtlocation \
-            qtaglextras \
             libqtappfw \
 "
 
index b8db9ac..bd3fc64 100644 (file)
@@ -7,7 +7,7 @@ LICENSE          = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
 
 DEPENDS += "qtbase json-c \
-            qlibwindowmanager libhomescreen \
+            libhomescreen \
             libqtappfw \
            "
 
index a61f2c9..e27fe73 100644 (file)
@@ -14,7 +14,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
 DEPENDS += "qtbase \
             qtquickcontrols2 \
             qlibhomescreen \
-            qlibwindowmanager \
             qtlocation \
             libqtappfw \
 "
index ae905ea..b0f63d1 100644 (file)
@@ -13,6 +13,6 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 libhomescreen qlibhomescreen libwindowmanager qlibwindowmanager"
+DEPENDS += "qtquickcontrols2 libhomescreen qlibhomescreen"
 
 inherit qmake5 aglwgt
index cab30ea..a878185 100644 (file)
@@ -16,7 +16,6 @@ S  = "${WORKDIR}/git"
 DEPENDS += "qtquickcontrols2 \
             libqtappfw \
             libhomescreen \
-            qlibwindowmanager \
             gstreamer1.0 \
 "
 
index 3a89af5..7b0934f 100644 (file)
@@ -18,7 +18,7 @@ S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS = "qtquickcontrols2 rtl-sdr"
-DEPENDS += "libhomescreen qlibwindowmanager libqtappfw"
+DEPENDS += "libhomescreen libqtappfw"
 
 inherit qmake5 aglwgt
 
index 17b83dc..776c764 100644 (file)
@@ -14,7 +14,7 @@ S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS += "libqtappfw qtquickcontrols2 qt-qrcode"
-DEPENDS += "libhomescreen qlibwindowmanager qtvirtualkeyboard"
+DEPENDS += "libhomescreen qtvirtualkeyboard"
 
 # runtime dependencies
 RDEPENDS_${PN} += " \
index 13f16fc..68965eb 100644 (file)
@@ -18,7 +18,6 @@ DEPENDS += "qtquickcontrols2 \
             qtcharts \
             libqtappfw \
             libhomescreen \
-            qlibwindowmanager \
 "
 
 inherit qmake5 aglwgt
index fc0bbfa..812139b 100644 (file)
@@ -37,9 +37,7 @@ AGL_APPS = " \
     virtual/mixer \
     "
 
-QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
-#NOTE: removed libqtappfw from QTAGLEXTRAS as it is no longer
-#      necessary due to replacement by individual recipe RDEPENDS.
+QTAGLEXTRAS = " libqtappfw"
 
 # add support for websocket in Qt and QML
 QTAGLEXTRAS_append = " qtwebsockets qtwebsockets-qmlplugins"
index f7de02c..6e07493 100644 (file)
@@ -16,22 +16,16 @@ PACKAGES = "\
     "
 
 RDEPENDS_${PN} = " \
-  agl-service-windowmanager \
   agl-service-homescreen \
   homescreen \
-  libwindowmanager \
-  qlibwindowmanager \
   libhomescreen \
   qlibhomescreen \
-  runxdg \
   hmi-debug \
   launcher \
 "
-
 # NOTE: Currently no coverage versions of these widgets, they should
 #       be added here when available.
 RDEPENDS_${PN}-devel = " \
-  agl-service-windowmanager-dbg \
   agl-service-homescreen-dbg \
   homescreen-dbg \
   launcher-dbg \