Add systemd service for VOD demo setup 47/7747/2
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Wed, 21 Dec 2016 07:26:19 +0000 (16:26 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 21 Dec 2016 13:01:44 +0000 (13:01 +0000)
This change is for booting all stuff of VOD service demo
for RSE automatically after MOST network manager.

Change-Id: Ia985d0c6a1dad8a6cad201205141152435318b59
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
recipes-demo-hmi/vod-server/files/vod-demo.service [new file with mode: 0644]
recipes-demo-hmi/vod-server/vod-server_0.1.bb

diff --git a/recipes-demo-hmi/vod-server/files/vod-demo.service b/recipes-demo-hmi/vod-server/files/vod-demo.service
new file mode 100644 (file)
index 0000000..c783bd4
--- /dev/null
@@ -0,0 +1,10 @@
+[Unit]
+Description=Video On Demand AGL Demo
+After=WindowManager.service most-network-manager.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/VideoOnDemand -p /home/root/Video
+
+[Install]
+WantedBy=default.target
index 949509d..3d724bd 100644 (file)
@@ -7,14 +7,29 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425
 PV = "0.1"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https"
-SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch"
+SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch \
+            file://vod-demo.service"
 
 S = "${WORKDIR}/git"
 #SRCREV = "8c5f2324d7aa61669324aec1a0ad091fe1379489"
 SRCREV = "${AUTOREV}"
 
 do_install() {
-        install -m 0755 -d ${D}${bindir} 
-       install -m 0755 ${S}/VideoOnDemand ${D}${bindir}/VideoOnDemand
+        install -m 0755 -d ${D}${bindir}
+        install -m 0755 ${S}/VideoOnDemand ${D}${bindir}/VideoOnDemand
+
+        # Install VOD server systemd service (user)
+        if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+            install -m 644 -p -D ${WORKDIR}/vod-demo.service ${D}${systemd_user_unitdir}/vod-demo.service
+
+            # Execute install manually for root user on behalf of systemctl script
+            # because it doesn't support user mode of systemd.
+            install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
+            ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}/home/root/.config/systemd/user/default.target.wants/vod-demo.service
+        fi
 }
 
+FILES_${PN} += " \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/vod-demo.service', '', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
+    "