Add branch rename workarounds 63/27463/1
authorScott Murray <scott.murray@konsulko.com>
Sat, 7 May 2022 12:04:52 +0000 (08:04 -0400)
committerScott Murray <scott.murray@konsulko.com>
Sat, 7 May 2022 12:18:26 +0000 (08:18 -0400)
Add bbappends for ndctl and ttf-noto-emoji recipes to tweak their
SRC_URIs to handle their upstreams renaming the "master" branch to
"main".  This works around the resulting build failures that would
happen otherwise, and patches will be submitted for meta-openembedded
so we can hopefully drop these on the next set of layer updates.

Bug-AGL: SPEC-4361

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Ic7756038cffe7bc370f512c835fb1da5954fc387

recipes-core/ndctl/ndctl_agldemo.inc [new file with mode: 0644]
recipes-core/ndctl/ndctl_v67.bbappend [new file with mode: 0644]
recipes-graphics/ttf-fonts/ttf-noto-emoji_20190815.bbappend [new file with mode: 0644]
recipes-graphics/ttf-fonts/ttf-noto-emoji_agldemo.inc [new file with mode: 0644]

diff --git a/recipes-core/ndctl/ndctl_agldemo.inc b/recipes-core/ndctl/ndctl_agldemo.inc
new file mode 100644 (file)
index 0000000..2a26097
--- /dev/null
@@ -0,0 +1,3 @@
+# Upstream replaced master branch with main, carry local workaround
+# until fix lands in meta-oe.
+SRC_URI = "git://github.com/pmem/ndctl.git;branch=main;protocol=https"
diff --git a/recipes-core/ndctl/ndctl_v67.bbappend b/recipes-core/ndctl/ndctl_v67.bbappend
new file mode 100644 (file)
index 0000000..fe58de1
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'ndctl_agldemo.inc', '', d)}
diff --git a/recipes-graphics/ttf-fonts/ttf-noto-emoji_20190815.bbappend b/recipes-graphics/ttf-fonts/ttf-noto-emoji_20190815.bbappend
new file mode 100644 (file)
index 0000000..d57e3f3
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'ttf-noto-emoji_agldemo.inc', '', d)}
diff --git a/recipes-graphics/ttf-fonts/ttf-noto-emoji_agldemo.inc b/recipes-graphics/ttf-fonts/ttf-noto-emoji_agldemo.inc
new file mode 100644 (file)
index 0000000..0dee6c8
--- /dev/null
@@ -0,0 +1,3 @@
+# Upstream replaced master branch with main, carry local workaround
+# until fix lands in meta-oe.
+SRC_URI = "git://github.com/googlefonts/noto-emoji;protocol=https;branch=main"
\ No newline at end of file