Add bitbake's target for cross SDK (full version) 17/4117/1
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Wed, 7 Oct 2015 12:40:06 +0000 (21:40 +0900)
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Wed, 7 Oct 2015 13:00:16 +0000 (22:00 +0900)
Add recipe for a full cross SDK image (which includes SDK for Qt5)
for AGL Demo Platform of AGL Distribution.

To build SDK,
  $ bitbake agl-demo-platform-crosssdk

To install SDK (e.g. for porter)
  $ cd tmp/deploy/sdk
  $ ./poky-agl-glibc-x86_64-agl-demo-platform-crosssdk-cortexa15hf-vfp-neon-toolchain-1.0.0.sh

To use SDK (e.g. for porter)
  $ source /opt/poky-agl/1.0.0/environment-setup-cortexa15hf-vfp-neon-poky-linux-gnueabi

You can also use QtCreator with this SDK:
  $ source /opt/poky-agl/1.0.0/environment-setup-cortexa15hf-vfp-neon-poky-linux-gnueabi
  $ qtcreator.sh

Before building your Qt projects, you should setup QtCreator once to use SDK.
E.g. configurations for porter,
  From Menu "Tools" -> Submenu "Options",

  1. Option "Build & Run" -> Tab "Compilers" -> Button "Add" -> Select "GCC"
     Name: Poky G++
     Path: /opt/poky-agl/1.0.0/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-g++

  2. Option "Build & Run" -> Tab "Debuggers" -> Button "Add"
     Name: Poky GDB
     Path: /opt/poky-agl/1.0.0/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-gdb

  3. Option "Build & Run" -> Tab "Qt Versions" -> Button "Add"
     Filename: /opt/poky-agl/1.0.0/sysroots/x86_64-pokysdk-linux/usr/bin/qt5/qmake

  4. Option "Build & Run" -> "Tab "Kits" -> Button "Add"
     Name: AGL
     Device Type: Generic Linux Device
     Sysroot: /opt/poky-agl/1.0.0/sysroots/cortexa15hf-vfp-neon-poky-linux-gnueabi
     Compiler: Poky G++
     Debugger: Poky GDB
     Qt Version: Qt 5.3.2(qt5)

Change-Id: I5794c62e0f06db326d7af737ce47aa9767cdd3ef
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
conf/conf-notes.txt
recipes-platform/images/agl-demo-platform-crosssdk.bb [new file with mode: 0644]

index 177b706..b6df8d0 100644 (file)
@@ -1,2 +1,3 @@
 Common targets are:
     agl-demo-platform
+    agl-demo-platform-crosssdk
diff --git a/recipes-platform/images/agl-demo-platform-crosssdk.bb b/recipes-platform/images/agl-demo-platform-crosssdk.bb
new file mode 100644 (file)
index 0000000..e6225be
--- /dev/null
@@ -0,0 +1,12 @@
+SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
+
+DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
+It includes the full meta-toolchain, plus developement headers and libraries \
+to form a standalone cross SDK."
+
+require agl-demo-platform.bb
+
+IMAGE_FEATURES_append = "dev-pkgs"
+IMAGE_INSTALL_append = "kernel-dev"
+
+inherit populate_sdk populate_sdk_qt5