psplash-portrait-config: add recipe 42/27742/2
authorScott Murray <scott.murray@konsulko.com>
Wed, 8 Jun 2022 19:50:30 +0000 (15:50 -0400)
committerScott Murray <scott.murray@konsulko.com>
Wed, 6 Jul 2022 18:32:43 +0000 (14:32 -0400)
Add psplash-portrait-config recipe to install a systemd unit override
for psplash-start.service that forces a 90 degree rotation for
portrait mode, add add it to packagegroup-agl-demo-platform so that
it takes affect in the agl-demo-platform image.

Bug-AGL: SPEC-4433

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Ida64df27a3a3c22bfe2eae8233ff8656800e23d0

recipes-core/psplash/files/psplash-portrait.conf [new file with mode: 0644]
recipes-core/psplash/psplash-portrait-config.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb

diff --git a/recipes-core/psplash/files/psplash-portrait.conf b/recipes-core/psplash/files/psplash-portrait.conf
new file mode 100644 (file)
index 0000000..1423cf9
--- /dev/null
@@ -0,0 +1,3 @@
+[Service]
+ExecStart=
+ExecStart=/usr/bin/psplash --angle 90
diff --git a/recipes-core/psplash/psplash-portrait-config.bb b/recipes-core/psplash/psplash-portrait-config.bb
new file mode 100644 (file)
index 0000000..7afee44
--- /dev/null
@@ -0,0 +1,20 @@
+SUMMARY     = "Systemd unit override for psplash portrait mode for the AGL Demonstrator"
+LICENSE     = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch
+
+SRC_URI = "file://psplash-portrait.conf"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+    # Install override
+    install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
+    install -m 0644 ${WORKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "psplash"
index c7db035..a8be87b 100644 (file)
@@ -34,4 +34,5 @@ RDEPENDS:${PN}:append = " \
     qtquickcontrols2-agl-style \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \
     ${AGL_APPS} \
+    psplash-portrait-config \
     "