Using the Tizen application manager to receive information about installed apps and... 29/6329/1
authorBocklage, Jens <Jens_Bocklage@mentor.com>
Mon, 8 Aug 2016 08:18:11 +0000 (10:18 +0200)
committerBocklage, Jens <Jens_Bocklage@mentor.com>
Mon, 8 Aug 2016 08:29:12 +0000 (10:29 +0200)
This acts as a template for other app framework adoptions.
Using the weston ivi shell to control surfaces.
Using the input event manager to dispatch hard key inputs.
This is a bigger update, so I increased the version number from 0.1.1 to 0.2.0.
Some parts are under development.
I created the components "WindowsManager" and "InputEventManager" because they are not defined in AGL right now.
As soon as they are defined, we should switch to them.

Find more information on the official wiki page: https://wiki.automotivelinux.org/homescreen

Also removed old recipes.

Signed-off-by: Bocklage, Jens <Jens_Bocklage@mentor.com>
recipes-demo-hmi/HomeScreen/HomeScreen_0.1.0.bb [deleted file]
recipes-demo-hmi/HomeScreen/HomeScreen_0.2.0.bb [moved from recipes-demo-hmi/HomeScreen/HomeScreen_0.1.1.bb with 52% similarity]

diff --git a/recipes-demo-hmi/HomeScreen/HomeScreen_0.1.0.bb b/recipes-demo-hmi/HomeScreen/HomeScreen_0.1.0.bb
deleted file mode 100644 (file)
index 42a61d1..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-SUMMARY     = "AGL Home Screen Application"
-DESCRIPTION = "AGL Home Screen Application + Home Screen Simulator + SampleAppTimeDate"
-HOMEPAGE    = "https://wiki.automotivelinux.org/homescreen"
-LICENSE     = "Apache-2.0"
-SECTION     = "apps"
-PV          = "0.1.0+gitr${SRCPV}"
-PR          = "r1"
-S           = "${WORKDIR}/git/"
-
-inherit qmake5
-DEPENDS = "qtbase"
-
-LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV  = "cf47f13164830e5b153db006cc55c3cf126d8d8c"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
-
-
-do_compile_prepend(){
-    PATH=$PATH:${STAGING_BINDIR_NATIVE}/qt5
-    export PATH
-}
-
-do_install() {
-    install -d ${D}/opt/AGL/${PN}
-    install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/opt/AGL/${PN}/
-    install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/opt/AGL/${PN}/
-}
-
-FILES_${PN} += "/opt/AGL/${PN}/"
-FILES_${PN}-dbg += "/opt/AGL/${PN}/.debug"
-
@@ -1,17 +1,22 @@
 SUMMARY     = "AGL Home Screen Application"
-DESCRIPTION = "AGL Home Screen Application + Home Screen Simulator + SampleAppTimeDate"
+DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderTizen + WindowManager + InputEventManager"
 HOMEPAGE    = "https://wiki.automotivelinux.org/homescreen"
 LICENSE     = "Apache-2.0"
 SECTION     = "apps"
-PV          = "0.1.1+gitr${SRCPV}"
+PV          = "0.2.0+gitr${SRCPV}"
 PR          = "r1"
 S           = "${WORKDIR}/git/"
 
 inherit qmake5
-DEPENDS = "qtbase"
+DEPENDS = " qtbase "
+
+# for HomeScreenAppFrameworkBinderTizen:
+DEPENDS += " pkgmgr-info aul "
+# for WindowManager:
+DEPENDS += " wayland-ivi-extension "
 
 LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV  = "3478f65b39560b333ba189e7d86e2c2cebfc9c7a"
+SRCREV  = "0a468d9b5ae7b3e5ba106facf17698d89b1ce200"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
 
 
@@ -24,9 +29,13 @@ do_install() {
     install -d ${D}/opt/AGL/${PN}
     install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/opt/AGL/${PN}/
     install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/opt/AGL/${PN}/
+    install -m 0755 ${B}/HomeScreenAppFrameworkBinderTizen/HomeScreenAppFrameworkBinderTizen ${D}/opt/AGL/${PN}/
+    install -m 0755 ${B}/WindowManager/WindowManager ${D}/opt/AGL/${PN}/
+    install -m 0755 ${B}/InputEventManager/InputEventManager ${D}/opt/AGL/${PN}/
+
 
     install -d ${D}/opt/AGL/${PN}/colorschemes
-    cp ${B}/HomeScreen/colorschemes/* ${D}/opt/AGL/${PN}/colorschemes/
+    cp -r ${B}/HomeScreen/colorschemes/* ${D}/opt/AGL/${PN}/colorschemes/
 }
 
 FILES_${PN} += "/opt/AGL/${PN}/"