camera-gstreamer: Added camera-gstreamer recipe 30/26130/2
authorMarius Vlad <marius.vlad@collabora.com>
Tue, 2 Mar 2021 17:58:33 +0000 (19:58 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 9 Mar 2021 10:26:57 +0000 (10:26 +0000)
Bug-AGL: SPEC-3629

Change-Id: I4495b4dca59d0411c264d90c00d9d9ec3c0ea671
Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
recipes-demo/camera-gstreamer/camera-gstreamer_git.bb [new file with mode: 0644]

diff --git a/recipes-demo/camera-gstreamer/camera-gstreamer_git.bb b/recipes-demo/camera-gstreamer/camera-gstreamer_git.bb
new file mode 100644 (file)
index 0000000..f08e410
--- /dev/null
@@ -0,0 +1,27 @@
+SUMMARY     = "Camera gstreamer demo application"
+DESCRIPTION = "AGL demonstration of displaying incoming camera feed"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/camera-gstreamer"
+SECTION     = "apps"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+    wayland wayland-native \
+    gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/camera-gstreamer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+S  = "${WORKDIR}/git"
+
+inherit cmake pkgconfig aglwgt
+
+RDEPENDS_${PN} += " \
+    gstreamer1.0-plugins-base \
+    gstreamer1.0-plugins-good \
+    gstreamer1.0-plugins-bad \
+"