Add build time dependency to qttools-native 69/12069/2
authorTasuku Suzuki <tasuku.suzuki@qt.io>
Wed, 22 Nov 2017 00:31:41 +0000 (09:31 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 22 Nov 2017 13:25:45 +0000 (13:25 +0000)
To support i18n, the project will need the command called lrelease which
is in qttools.

Change-Id: Ic5a83b5483f27d1260a123ef559b99425f4058e4
Signed-off-by: Tasuku Suzuki <tasuku.suzuki@qt.io>
recipes-demo-hmi/dashboard/dashboard_git.bb

index 795e9e1..289b448 100644 (file)
@@ -13,6 +13,11 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 virtual/libhomescreen qlibwindowmanager"
+DEPENDS += "qtquickcontrols2 virtual/libhomescreen qlibwindowmanager qttools-native"
 
 inherit qmake5 aglwgt
+
+do_configure_append() {
+    # Find native tools
+    sed -i 's:${STAGING_BINDIR}.*/lrelease:${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/lrelease:g' ${B}/app/Makefile
+}