Add recipe for apps/settings-log-utils 16/21116/6
authorwanglu <wang_lu@dl.cn.nexty-ele.com>
Mon, 22 Apr 2019 06:12:29 +0000 (14:12 +0800)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 7 May 2019 14:05:25 +0000 (14:05 +0000)
Bug-AGL:SPEC-2214

Change-Id: I16734e79f7cc2029baffa5fef42f9fd7537659ea
Signed-off-by: wanglu <wang_lu@dl.cn.nexty-ele.com>
recipes-demo-hmi/settings-log-utils/settings-log-utils_git.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/settings-log-utils/settings-log-utils_git.bb b/recipes-demo-hmi/settings-log-utils/settings-log-utils_git.bb
new file mode 100644 (file)
index 0000000..90dc0be
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY     = "App for log record"
+DESCRIPTION = "AGL HMI Application for demonstrating Log Record on AGL Distribution"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings-log-utils"
+SECTION     = "apps"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings-log-utils;protocol=https;branch=master"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "libqtappfw qtquickcontrols2 qtwebsockets opencv boost"
+DEPENDS += "libhomescreen qlibwindowmanager qtvirtualkeyboard"
+
+# runtime dependencies
+RDEPENDS_${PN} += " \
+            agl-service-bluetooth \
+            agl-service-network"
+
+inherit qmake5 aglwgt