Add dev-mapping-ci recipe 71/25871/4
authorScott Murray <scott.murray@konsulko.com>
Wed, 6 Jan 2021 23:35:50 +0000 (18:35 -0500)
committerScott Murray <scott.murray@konsulko.com>
Tue, 12 Jan 2021 15:43:44 +0000 (15:43 +0000)
Add a dev-mapping-ci recipe that installs a CI specific version of
/etc/dev-mapping.conf for the agl-service-can-low-level binding.
Additionally, the dev-mapping-demo recipe files have been moved to
recipes-config/dev-mapping so all the dev-mapping* recipes are in
the same place, and the now required "j1939" bus mapping has been
added to the various dev-mapping files.

To enable use of the new recipe, a definition of the variable
PREFERRED_RPROVIDER_virtual/low-can-dev-mapping has been added to
the agl-demo feature definition that enables it based on the AGLCI
DISTRO_FEATURE.  This is intended to replace the definition in
poky-agl.conf, which will be removed in subsequent cleanup.

Bug-AGL: SPEC-3756

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Ieb80a7f4b76ddd7851acca521dea1a8dd104cf86

conf/include/agl-demo.inc
recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci [new file with mode: 0644]
recipes-config/dev-mapping/dev-mapping-ci_1.0.bb [new file with mode: 0644]
recipes-config/dev-mapping/dev-mapping-demo/dev-mapping.conf.demo [moved from recipes-config/dev-mapping-demo/dev-mapping-demo/dev-mapping.conf.demo with 91% similarity]
recipes-config/dev-mapping/dev-mapping-demo_1.0.bb [moved from recipes-config/dev-mapping-demo/dev-mapping-demo_1.0.bb with 100% similarity]
recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default

index c3c051d..7d6db8c 100644 (file)
@@ -12,6 +12,9 @@ FEATURE_PACKAGES_agl-voiceagent-alexa_append = " alexa-viewer"
 # enable the layer
 AGL_FEATURES_append = " agldemo"
 
+# Set preferred provider for low-can device mapping configuration
+PREFERRED_RPROVIDER_virtual/low-can-dev-mapping ?= "${@bb.utils.contains('DISTRO_FEATURES', 'AGLCI', 'dev-mapping-ci', 'dev-mapping', d)}"
+
 # voice api inclusion
 PREFERRED_RPROVIDER_virtual/voice-high-config = "default-voice-high-config"
 FEATURE_PACKAGES_agl-speech-framework = "packagegroup-agl-speech-services"
diff --git a/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci b/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci
new file mode 100644 (file)
index 0000000..bd5c213
--- /dev/null
@@ -0,0 +1,7 @@
+; Default CAN device mapping
+; Format has to follow ini rules key="value", notice " around value.
+
+[CANbus-mapping]
+hs="vcan0"
+ls="vcan0"
+j1939="vcan0"
diff --git a/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb b/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
new file mode 100644 (file)
index 0000000..cbba573
--- /dev/null
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provides a default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in the low-can binding for the AGL CI setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.ci"
+
+inherit allarch
+
+do_install() {
+    install -d ${D}${sysconfdir}
+    install -m 0644 ${WORKDIR}/dev-mapping.conf.ci ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES_${PN} = "virtual/low-can-dev-mapping"