Upgrade to thud 68/20968/1
authorScott Murray <scott.murray@konsulko.com>
Mon, 18 Feb 2019 22:30:13 +0000 (17:30 -0500)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Tue, 9 Apr 2019 16:27:07 +0000 (18:27 +0200)
Changes include:
- Add LAYERSERIES_COMPAT definition to layer.conf
- Replace libvcard recipe with bbappend now that a recipe is available
  in meta-qt5
- Add OECMAKE_GENERATOR = "Unix Makefiles" to libnaviapi-agl recipe
  for now to work around CMake+ninja issue
- Add patch to navigation app to fix compilation against OpenSSL 1.1
- Remove libssp-dev from agl-demo-platform-crosssdk, upstream have
  removed it from non-mingw32 platform SDKs

Known issues:
- CMake+ninja issue in cmake-apps-module has been worked around with
  OECMAKE_GENERATOR

Bug-AGL: SPEC-1837

Change-Id: I14c5355fb38d5eed064f154f889d61d8e46854b7
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
conf/layer.conf
recipes-connectivity/libvcard/libvcard_%.bbappend [new file with mode: 0644]
recipes-connectivity/libvcard/libvcard_git.bb [deleted file]
recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb
recipes-demo-hmi/navigation/navigation/0002-openssl-1.1-fixes.patch [new file with mode: 0644]
recipes-demo-hmi/navigation/navigation_git.bb
recipes-platform/images/agl-demo-platform-crosssdk.bb

index 0047d61..43a5be7 100644 (file)
@@ -8,3 +8,5 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
 BBFILE_COLLECTIONS += "agl-demo"
 BBFILE_PATTERN_agl-demo = "^${LAYERDIR}/"
 BBFILE_PRIORITY_agl-demo = "7"
+
+LAYERSERIES_COMPAT_agl-demo = "thud"
diff --git a/recipes-connectivity/libvcard/libvcard_%.bbappend b/recipes-connectivity/libvcard/libvcard_%.bbappend
new file mode 100644 (file)
index 0000000..6761a0f
--- /dev/null
@@ -0,0 +1,3 @@
+SRCREV = "9b43ca01865f171cdd8a7d47b6da7c1a41c03e38"
+
+ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-connectivity/libvcard/libvcard_git.bb b/recipes-connectivity/libvcard/libvcard_git.bb
deleted file mode 100644 (file)
index 86e3c0f..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-DESCRIPTION = "Qt vCard library"
-SECTION = "libs"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=f94eaed54ffa1718d593504bae740faf"
-
-DEPENDS += "qtbase"
-
-SRCREV = "9b43ca01865f171cdd8a7d47b6da7c1a41c03e38"
-SRC_URI = "git://github.com/pol51/libvcard.git;protocol=https"
-
-PV = "1.0+gitr${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-inherit cmake_qt5
-
-ALLOW_EMPTY_${PN} = "1"
index af528ff..e4dc844 100755 (executable)
@@ -14,3 +14,5 @@ SRC_URI = "git://github.com/AGLExport/agl-service-navigation;protocol=git;branch
 SRCREV  = "1f1ffc92fcc882aa5e885badbc91a3384f5d77b1"
 S = "${WORKDIR}/git"
 
+# FIXME: Remove once CMake+ninja issues are resolved
+OECMAKE_GENERATOR = "Unix Makefiles"
diff --git a/recipes-demo-hmi/navigation/navigation/0002-openssl-1.1-fixes.patch b/recipes-demo-hmi/navigation/navigation/0002-openssl-1.1-fixes.patch
new file mode 100644 (file)
index 0000000..9506ce1
--- /dev/null
@@ -0,0 +1,31 @@
+gpsnavi: Fix compilation with OpenSSL 1.1
+
+Handle the ERR_load_crypto_strings and ERR_free_strings functions no
+longer being present in OpenSSL 1.1.
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+
+diff --git a/src/sms/sms-core/SMCAL/SMCAL.c b/src/sms/sms-core/SMCAL/SMCAL.c
+index eadab8f..2dfe1f3 100755
+--- a/src/sms/sms-core/SMCAL/SMCAL.c
++++ b/src/sms/sms-core/SMCAL/SMCAL.c
+@@ -158,7 +158,9 @@ void SC_CAL_Initialize_OpenSSL() {
+       // 初期化\r
+       ERR_load_BIO_strings();\r
+       SSL_load_error_strings();\r
++#if OPENSSL_VERSION_NUMBER < 0x10100000L\r
+       ERR_load_crypto_strings();\r
++#endif\r
+       OpenSSL_add_all_algorithms();\r
\r
+       // SSLの初期化(戻り値は常に1)\r
+@@ -542,7 +544,9 @@ E_SC_CAL_RESULT SC_CAL_DisConnect(SMCAL *cal)
+                       if (NULL != cal->ssl.ctx) {\r
+                               SSL_CTX_free((SSL_CTX*)cal->ssl.ctx);\r
+                       }\r
++#if OPENSSL_VERSION_NUMBER < 0x10100000L\r
+                       ERR_free_strings();\r
++#endif\r
\r
+                       cal->ssl.ssl = NULL;\r
+                       cal->ssl.ctx = NULL;\r
index 3ad00b2..b5eeb89 100755 (executable)
@@ -21,6 +21,7 @@ RDEPENDS_${PN} += " agl-service-navigation "
 SRCREV="5048c2e234febeb20df0b193e1bf1ac50f3896a5"
 SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=agl \
          file://0001-add-4A-playback-support.patch \
+         file://0002-openssl-1.1-fixes.patch \
          file://download_mapdata_jp.sh \
          file://download_mapdata_uk.sh \
          file://org.agl.naviapi.conf \
index bce2e6a..2812aec 100755 (executable)
@@ -42,7 +42,6 @@ TOOLCHAIN_TARGET_TASK += " \
     libexif-dev \
     pango-dev \
     libdrm-dev  \
-    libssp-dev \
     lua-dev \
     lua-staticdev \
     libafb-helpers-staticdev \