libdbus-c++:Fix build error in GCC-7
authorChanghyeok Bae <changhyeok.bae@gmail.com>
Mon, 25 Dec 2017 16:26:23 +0000 (16:26 +0000)
committerronan <ronan.lemartret@gmail.com>
Tue, 13 Feb 2018 16:22:38 +0000 (17:22 +0100)
See: https://sourceforge.net/p/dbus-cplusplus/patches/18/

Bug-AGL: SPEC-1181

Change-Id: Ic8f923a03407e58aff2133747a65799f90d15286
Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch [new file with mode: 0644]
recipes-core/dbus/libdbus-c++_0.9.0.bbappend [new file with mode: 0644]

diff --git a/recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch b/recipes-core/dbus/libdbus-c++/dbus-c++-threading.patch
new file mode 100644 (file)
index 0000000..c4fafef
--- /dev/null
@@ -0,0 +1,45 @@
+--- libdbus-c++-0.9.0/include/dbus-c++/dispatcher.h.threading  2017-02-15 13:40:53.796004263 +0000
++++ libdbus-c++-0.9.0/include/dbus-c++/dispatcher.h    2017-02-15 13:40:46.907000493 +0000
+@@ -188,6 +188,7 @@
+ /* classes for multithreading support
+ */
++#if 0
+ class DXXAPI Mutex
+ {
+ public:
+@@ -243,9 +244,11 @@
+ typedef bool (*CondVarWaitTimeoutFn)(CondVar *cv, Mutex *mx, int timeout);
+ typedef void (*CondVarWakeOneFn)(CondVar *cv);
+ typedef void (*CondVarWakeAllFn)(CondVar *cv);
++#endif
+ void DXXAPI _init_threading();
++#if 0
+ void DXXAPI _init_threading(
+   MutexNewFn, MutexFreeFn, MutexLockFn, MutexUnlockFn,
+   CondVarNewFn, CondVarFreeFn, CondVarWaitFn, CondVarWaitTimeoutFn, CondVarWakeOneFn, CondVarWakeAllFn
+@@ -312,6 +315,7 @@
+     cv->wake_all();
+   }
+ };
++#endif
+ } /* namespace DBus */
+--- libdbus-c++-0.9.0/src/dispatcher.cpp.threading     2017-02-15 13:48:22.627249868 +0000
++++ libdbus-c++-0.9.0/src/dispatcher.cpp       2017-02-15 13:48:29.164253445 +0000
+@@ -253,6 +253,7 @@
+ #endif//DBUS_HAS_THREADS_INIT_DEFAULT
+ }
++#if 0
+ void DBus::_init_threading(
+   MutexNewFn m1,
+   MutexFreeFn m2,
+@@ -318,3 +319,4 @@
+ #endif//DBUS_HAS_RECURSIVE_MUTEX
+   dbus_threads_init(&functions);
+ }
++#endif
diff --git a/recipes-core/dbus/libdbus-c++_0.9.0.bbappend b/recipes-core/dbus/libdbus-c++_0.9.0.bbappend
new file mode 100644 (file)
index 0000000..dac44b5
--- /dev/null
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+SRC_URI_append = "file://dbus-c++-threading.patch"