flutter-ics-homescreen: update SRCREV 40/29640/3
authorScott Murray <scott.murray@konsulko.com>
Tue, 30 Jan 2024 21:36:41 +0000 (16:36 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 2 Feb 2024 12:16:48 +0000 (12:16 +0000)
Update SRCREV to pick up:

5587c6a Improve background disabling
6046300 Fix TLS server name parsing
cc99d4d Connect audio settings button
ee592b5 Rotate dashboard gauges
31438c5 Configurable units fixes
5588d1d Tweak idle speed in hybrid animation logic
2d395f4 Initial mediaplayer implementation
4742fde Initial radio implementation
fcd868b Fix late initialization warning
a445ffb Add application launcher support
4ae68f5 Implement audio settings
dda6c85 Hybrid animation from env variable

As well, the configuration yaml file has been updated to work with
the changes, and a radio presets configuration yaml file has been
added.

Bug-AGL: SPEC-4971, SPEC-5001, SPEC-5026, SPEC-5027, SPEC-5028,
         SPEC-5029, SPEC-5030, SPEC-5031, SPEC-5032, SPEC-5043,
         SPEC-5053, SPEC-5054

Change-Id: I0820ab2c7eaba8cbdc8df6fb05e6244df70622d2
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29640
Tested-by: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml
recipes-demo/flutter-ics-homescreen/files/radio-presets.yaml [new file with mode: 0644]
recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb

index eb29ea7..f8e400b 100644 (file)
@@ -1,3 +1,4 @@
-port : 55555
-authorization : "/etc/xdg/AGL/ics-homescreen/ics-homescreen.token"
-use-tls : true
+kuksa:
+  port : 55555
+  authorization : "/etc/xdg/AGL/ics-homescreen/ics-homescreen.token"
+  use-tls : true
diff --git a/recipes-demo/flutter-ics-homescreen/files/radio-presets.yaml b/recipes-demo/flutter-ics-homescreen/files/radio-presets.yaml
new file mode 100644 (file)
index 0000000..6af0837
--- /dev/null
@@ -0,0 +1,13 @@
+fm:
+- frequency: 93100000
+  name: 93.1 The Mountain
+- frequency: 94100000
+  name: Mix 94.1
+- frequency: 96300000
+  name: 96.3 KKLZ
+- frequency: 102700000
+  name: 102.7 VGS
+- frequency: 88900000
+  name: News 88.9
+- frequency: 91500000
+  name: KUNV
index 77ed509..dd50df7 100644 (file)
@@ -11,8 +11,9 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;p
   file://flutter-ics-homescreen.service \
   file://ics-homescreen.yaml \
   file://ics-homescreen.token \
+  file://radio-presets.yaml \
 "
-SRCREV = "71d46d03850653c0229c678de197c6f94fceb477"
+SRCREV = "5587c6ae79b482fbff26442bb239d7d7eb55a337"
 
 S = "${WORKDIR}/git"
 
@@ -33,18 +34,26 @@ DISABLE_BG_ANIMATION:rcar-gen3 = ""
 APP_AOT_EXTRA:append = " ${DISABLE_BG_ANIMATION}"
 
 do_install:append() {
-  install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
-
-  install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
-
-  # VIS authorization token file for KUKSA.val should ideally not
-  # be readable by other users, but currently that's not doable
-  # until a packaging/sandboxing/MAC scheme is (re)implemented or
-  # something like OAuth is plumbed in as an alternative.
-  install -d ${D}${sysconfdir}/xdg/AGL/ics-homescreen
-  install -m 0644 ${WORKDIR}/ics-homescreen.yaml ${D}${sysconfdir}/xdg/AGL/
-  install -m 0644 ${WORKDIR}/ics-homescreen.token ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
+    install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+
+    install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
+
+    # VIS authorization token file for KUKSA.val should ideally not
+    # be readable by other users, but currently that's not doable
+    # until a packaging/sandboxing/MAC scheme is (re)implemented or
+    # something like OAuth is plumbed in as an alternative.
+    install -d ${D}${sysconfdir}/xdg/AGL/ics-homescreen
+    install -m 0644 ${WORKDIR}/ics-homescreen.yaml ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/ics-homescreen.token ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
+    install -m 0644 ${WORKDIR}/radio-presets.yaml ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
 }
 
 FILES:${PN} += "${datadir} ${sysconfdir}/xdg/AGL"
-RDEPENDS:${PN} += "flutter-auto agl-flutter-env"
+
+RDEPENDS:${PN} += " \
+    flutter-auto \
+    agl-flutter-env \
+    applaunchd \
+    agl-service-radio \
+    mpd \
+"