web-runtime: Add wam to agl-demo-platform-html5 image 18/26918/3
authorLorenzo Tilve <ltilve@igalia.com>
Thu, 4 Nov 2021 18:23:03 +0000 (19:23 +0100)
committerLorenzo Tilve <ltilve@igalia.com>
Tue, 7 Dec 2021 08:16:59 +0000 (09:16 +0100)
Include wam dependency on agl-demo-platform-html5 target.

Bug-AGL: SPEC-4121
Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
Change-Id: I3355a0a96b906131fa1d2e11c4b29d3951879ad9

recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
recipes-platform/packagegroups/packagegroup-agl-profile-graphical-html5.bb
recipes-wam/chromium/chromium.inc

index d0c81c6..02b7729 100644 (file)
@@ -19,6 +19,7 @@ RDEPENDS:${PN} += "\
 
 RDEPENDS:${PN} += "\
     packagegroup-hmi-framework \
+    packagegroup-agl-profile-graphical-html5 \
     "
 
 
index d392916..62c30ea 100644 (file)
@@ -13,10 +13,10 @@ ALLOW_EMPTY:${PN} = "1"
 
 RDEPENDS:${PN} += "\
     packagegroup-agl-profile-graphical \
-    packagegroup-agl-appfw-html5 \
 "
 
 RDEPENDS:${PN} += "\
+    wam \
     "
 
 RDEPENDS:profile-graphical-html5 = "${PN}"
index 19fa874..722ba9a 100644 (file)
@@ -12,9 +12,7 @@ LIC_FILES_CHKSUM = "\
 
 require gn-utils.inc
 
-inherit gettext qemu
-#fixme after rework: pythonnative
-#ParseError at /w/workspace/ci-platform-meta-agl-verify-CIB-qemux86-64/repoclone/meta-agl-demo/recipes-wam/chromium/chromium.inc:15: Could not inherit file classes/pythonnative.bbclass
+inherit gettext qemu pythonnative
 
 DEPENDS = "virtual/gettext wayland wayland-native pixman freetype glib-2.0 fontconfig openssl pango cairo icu libxkbcommon libexif dbus pciutils udev libcap alsa-lib virtual/egl elfutils-native libdrm atk at-spi2-atk gperf-native gconf nss nss-native nspr nspr-native bison-native qemu-native"