bluez5: fix: apply patch on bluez v5.22 only 81/5281/2
authorYannick Gicquel <yannick.gicquel@iot.bzh>
Fri, 15 Jan 2016 15:55:17 +0000 (16:55 +0100)
committerGerrit Code Review <gerrit@172.30.200.200>
Mon, 18 Jan 2016 19:03:17 +0000 (19:03 +0000)
Replace 'rev' directive by 'apply' and a check on 'PV' variable.

Tanikawa-san observed a regression while building 'qtsystems' with previous
commit:

(...)
Bitbake fails at qtsystems with c++ compiling errors.

Option 'rev' works only when building code from a revision control system. In bluez5_5.22.bb, source code is downloaded as tarball. "fd0783c8bc524bc9b26514aad1f85814" is not SRCREV, it is md5 of tarball.
(...)

Change-Id: Id595d4c01912567e640d3371bbd0709e53eec748
Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
recipes-connectivity/bluez5/bluez5_%.bbappend

index 19ff2f2..59787fc 100644 (file)
@@ -1,5 +1,7 @@
 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
 
+APPLY_v522 = "${@str('no' if '${PV}' != '5.22' else 'yes')}"
+
 SRC_URI_append = "\
-    file://0001_fix_compile_issue_when_using_in_c++.patch;rev="fd0783c8bc524bc9b26514aad1f85814" \
+    file://0001_fix_compile_issue_when_using_in_c++.patch;apply=${APPLY_v522} \
 "