Add initial support for AGL Navigation API 49/12649/1
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Mon, 11 Dec 2017 14:53:06 +0000 (23:53 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 18 Dec 2017 02:53:25 +0000 (02:53 +0000)
We will commit the initial implementation of AGL Navigation API advanced by Navigation EG.
In initial support, AGL 3.0 equivalent API is reimplemented using afm-binder.

Change-Id: I5e288c81b22fc31b7d68fcfcafb2325ce4bb75c3
Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb b/recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb
new file mode 100644 (file)
index 0000000..933d47d
--- /dev/null
@@ -0,0 +1,17 @@
+SUMMARY     = "Navigation Service Binding"
+DESCRIPTION = "AGL Navigation Service API Binding"
+HOMEPAGE    = "https://github.com/AGLExport/agl-service-navigation"
+SECTION     = "apps"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://github.com/AGLExport/agl-service-navigation;protocol=git;branch=master"
+SRCREV  = "b75e80244471e3486176e5ba476989410ecf5bda"
+
+PV = "0.1+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+DEPENDS = " json-c libdbus-c++ "
+
+inherit cmake aglwgt pkgconfig