output-udev-conf: add recipe 97/28197/1
authorScott Murray <scott.murray@konsulko.com>
Wed, 23 Nov 2022 20:33:04 +0000 (15:33 -0500)
committerScott Murray <scott.murray@konsulko.com>
Wed, 23 Nov 2022 20:35:29 +0000 (15:35 -0500)
Add recipe to install udev rules to force all input devices to be
associated with the HDMI-A-1 output.  The intended use is with the
KVM host image to ensure input devices are matched to the IVI
guest VM.  Also fixed the RDEPENDS for the other udev rule recipes
to depend on udev specifically instead of systemd.

Bug-AGL: SPEC-4618

Change-Id: Ic2efe01f7aed85f89dbda3cb958332ed5db799a1
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-core/udev/output-udev-conf/91-output.rules [new file with mode: 0644]
recipes-core/udev/output-udev-conf_1.0.bb [new file with mode: 0644]
recipes-core/udev/sw-gpsd-udev-conf_1.0.bb
recipes-core/udev/usb-can-udev-conf_1.0.bb

diff --git a/recipes-core/udev/output-udev-conf/91-output.rules b/recipes-core/udev/output-udev-conf/91-output.rules
new file mode 100644 (file)
index 0000000..89af464
--- /dev/null
@@ -0,0 +1,6 @@
+# Associate all input devices with the first display
+#
+# NOTE: Can be more selective with something like:
+# SUBSYSTEM=="input", ATTRS{idVendor}=="*", ATTRS{idProduct}=="004a", OWNER="display", ENV{ID_SEAT}="seat0", ENV{WL_OUTPUT}="HDMI-A-1"
+#
+SUBSYSTEM=="input", OWNER="display", ENV{ID_SEAT}="seat0", ENV{WL_OUTPUT}="HDMI-A-1"
diff --git a/recipes-core/udev/output-udev-conf_1.0.bb b/recipes-core/udev/output-udev-conf_1.0.bb
new file mode 100644 (file)
index 0000000..c4e05ad
--- /dev/null
@@ -0,0 +1,18 @@
+SUMMARY = "Input device output assignment udev configuration"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://91-output.rules"
+
+do_compile[noexec] = "1"
+
+do_install() {
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        install -d ${D}${sysconfdir}/udev/rules.d
+        install -m 0644 ${WORKDIR}/91-output.rules ${D}${sysconfdir}/udev/rules.d/
+    fi
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "udev"
index 0dfd052..bcad0f4 100644 (file)
@@ -13,4 +13,4 @@ do_install() {
     fi
 }
 
-RDEPENDS:${PN} += "systemd"
+RDEPENDS:${PN} += "udev"
index 9c6035e..1b76550 100644 (file)
@@ -22,4 +22,4 @@ do_install() {
 
 FILES:${PN} += "${systemd_system_unitdir}"
 
-RDEPENDS:${PN} += "systemd"
+RDEPENDS:${PN} += "udev"