homescreen-demo-ci: Recipe for homescreen-demo-ci 12/25312/2
authorMarius Vlad <marius.vlad@collabora.com>
Sat, 19 Sep 2020 15:28:49 +0000 (18:28 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 29 Sep 2020 14:14:41 +0000 (14:14 +0000)
homescreen-demo-ci is a qt client shell, useful in providing a way to
take a screenshot that doesn't dynamically update itself. It still uses
qt and has the same dependencies as homescreen.

Bug-AGL: SPEC-3592

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: I732abb386ca0362e896ac3a89325a411a9748968

recipes-demo-hmi/homescreen-demo-ci/homescreen-demo-ci_git.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/homescreen-demo-ci/homescreen-demo-ci_git.bb b/recipes-demo-hmi/homescreen-demo-ci/homescreen-demo-ci_git.bb
new file mode 100644 (file)
index 0000000..c3814f1
--- /dev/null
@@ -0,0 +1,37 @@
+SUMMARY     = "homescreen-demo-ci AGL client shell for testing in CI"
+DESCRIPTION = "homescreen-demo-ci AGL client shell for testing in CI"
+HOMEPAGE    = "http://docs.automotivelinux.org"
+LICENSE     = "MIT"
+SECTION     = "apps"
+LIC_FILES_CHKSUM = "file://COPYING;md5=374fee6a7817f1e1a5a7bfb7b7989553"
+
+DEPENDS = "\
+        qtbase \
+        qtdeclarative \
+        qtquickcontrols2 \
+        agl-service-homescreen \
+        agl-service-weather \
+        libqtappfw \
+        libhomescreen \
+        libafb-helpers-qt \
+        wayland-native \
+        wayland \
+        qtwayland \
+        qtwayland-native \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen-demo-ci;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS_${PN} += " \
+        libqtappfw \
+"