Add aws-iot-device-embedded-c support to crosssdk 51/24951/3
authorAndrey Shamanin <andrei.shamanin@orioninc.com>
Tue, 7 Jul 2020 11:31:49 +0000 (14:31 +0300)
committerAndrey Shamanin <andrei.shamanin@orioninc.com>
Thu, 9 Jul 2020 13:15:41 +0000 (16:15 +0300)
AWS SDK is included to AGL cross SDK, it allows users to use AWS SDK
during appropriate (working with cloud) AGL application development.

Bug-AGL: SPEC-3480

Signed-off-by: Andrey Shamanin <andrei.shamanin@orioninc.com>
Change-Id: I2494396bec28156ba2e732515f9ab2b61a8f71f7

recipes-platform/images/agl-demo-platform-crosssdk.bb

index 35883ae..d71eb88 100644 (file)
@@ -40,6 +40,13 @@ TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
 # memory issue.
 TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
 
-# Add azure-iot-sdk-c to support building agl-service-cloudproxy and
-# other users of Azure sdk.
+# Add azure-iot-sdk-c to support building agl-service-cloudproxy
+# and other users of Azure sdk.
 TOOLCHAIN_TARGET_TASK += "azure-iot-sdk-c umock-c"
+
+# Add aws-iot-device-embedded-c sdk to support building agl-service-cloudproxy
+# and other users of AWS sdk.
+# These packages are required to add static library and headers:
+TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-staticdev"
+TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-dev"
+