openivi-html5: Fix compatibility with IVI shell 53/7353/3
authorLeon Anavi <leon.anavi@konsulko.com>
Wed, 30 Nov 2016 20:51:35 +0000 (22:51 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 1 Dec 2016 21:53:25 +0000 (21:53 +0000)
Update openivi-html5 to latest version and modify
openivi-html5.sh to fix the compatibility with
Weston IVI shell.

Bug-AGL: SPEC-335

Change-Id: I015892f24e78c61283f57897c9741d608bcc383b
Suggested-by: Anton Gerasimov <anton@advancedtelematic.com>
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
recipes-openivi/openivi-html5/openivi-html5/openivi-html5.sh
recipes-openivi/openivi-html5/openivi-html5_git.bb

index 190ab65..b622551 100644 (file)
@@ -22,4 +22,32 @@ if [ -e "$HOMESCREEN_CONFIG" ] ; then
     fi
 fi
 
-/usr/bin/openivi-html5 -f -u $HOMESCREEN
+#the following value shall be modified for your display side
+SCREEN_W=1080
+SCREEN_H=1920
+
+# Demo is configured to FullHD
+QT_W=1080
+QT_H=1920
+
+# Ensure that Weston has been fully loaded
+sleep 8
+
+/usr/bin/openivi-html5 -f -u $HOMESCREEN &
+
+# qmlscene create 2 surfaces
+#   0x80000000 : for off screen buffer ?
+#   0x80000001 : visible
+#
+SURFACE_ID_QML=0x80000001
+
+#
+# layer-add-surfaces wait till 2 surfaces are created.
+#
+layer-add-surfaces 1000 2
+
+/usr/bin/LayerManagerControl set surface $SURFACE_ID_QML destination region 0 0 $SCREEN_W $SCREEN_H
+/usr/bin/LayerManagerControl set surface $SURFACE_ID_QML source region 0 0 $QT_W $QT_H
+/usr/bin/LayerManagerControl set layer 1000 render order $SURFACE_ID_QML
+/usr/bin/LayerManagerControl set surfaces $SURFACE_ID_QML input focus keyboard
+/usr/bin/LayerManagerControl set screen 0 render order 1000
index 1e6a96b..4418b13 100644 (file)
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4641e94ec96f98fabc56ff9cc48be14b"
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 SRC_URI = " \
-       git://github.com/openivimobility/openivi-html5.git;branch=master;tag=7e5d9574758e504b194d16a52e04a1cfe4320138 \
+       git://github.com/openivimobility/openivi-html5.git;branch=master;tag=0b370eea8c7c852365bd717013a523b678abbdba \
        file://openivi-html5.sh \
        file://openivi-html5.service \
 "