Add backports of mpd and related recipes 73/27173/2
authorScott Murray <scott.murray@konsulko.com>
Mon, 14 Feb 2022 22:38:28 +0000 (17:38 -0500)
committerScott Murray <scott.murray@konsulko.com>
Tue, 15 Feb 2022 22:25:18 +0000 (22:25 +0000)
Backport the recipe for the latest (0.23.5) version of mpd
(Music Player Daemon) from meta-openembedded's master branch.
This provides a version with native PipeWire support, and should
help make the upcoming upgrade to Yocto Project 3.5 (aka Kirkstone)
easier.  Additionally, the recipes for the related libmpdclient
library and mpc utility are also backported to ensure compatibility.

The provided bbappend for the mpd recipe tweaks the backport to
build with the older version of meson in dunfell, and applies
configuration to approximate the lightmediascanner set up with
regards to media location and using /var/volatile for metadata
storage for robustness.

Bug-AGL: SPEC-4255

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Ida58289a16079f48c3467d55aef4a608671ffc37

recipes-multimedia/musicpd/files/0001-Tweaks-to-allow-building-with-older-meson.patch [new file with mode: 0644]
recipes-multimedia/musicpd/files/mpd-volatiles.conf [new file with mode: 0644]
recipes-multimedia/musicpd/files/mpd.conf.in [new file with mode: 0644]
recipes-multimedia/musicpd/libmpdclient_2.19.bb [new file with mode: 0644]
recipes-multimedia/musicpd/mpc_0.33.bb [new file with mode: 0644]
recipes-multimedia/musicpd/mpd/mpd.conf.in [new file with mode: 0644]
recipes-multimedia/musicpd/mpd_0.23.5.bb [new file with mode: 0644]
recipes-multimedia/musicpd/mpd_0.23.5.bbappend [new file with mode: 0644]
recipes-multimedia/musicpd/mpd_agldemo.inc [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
recipes-platform/packagegroups/packagegroup-agl-ivi-multimedia.bb

diff --git a/recipes-multimedia/musicpd/files/0001-Tweaks-to-allow-building-with-older-meson.patch b/recipes-multimedia/musicpd/files/0001-Tweaks-to-allow-building-with-older-meson.patch
new file mode 100644 (file)
index 0000000..9dcb370
--- /dev/null
@@ -0,0 +1,55 @@
+From a01163d061fae0114a508be83c0ac83461fba43d Mon Sep 17 00:00:00 2001
+From: Scott Murray <scott.murray@konsulko.com>
+Date: Wed, 2 Feb 2022 14:39:50 -0500
+Subject: [PATCH] Tweaks to allow building with older meson
+
+The requirements for newer meson in meson.build stem from changes
+for building dependencies as sub-projects.  If we avoid triggering
+those, then older meson works fine.  To enable such, manually edit
+out additions from commits f23ecf00da, aef0535c55, 520028dcfc, and
+6b1d0cb01d (not necessarily an exhaustive list), and set the
+minimum meson version to 0.51, as that's where the build flags
+for native vs target became available, and those are being used.
+
+Upstream-Status: Inappropriate [disable feature]
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+---
+ meson.build | 15 +--------------
+ 1 file changed, 1 insertion(+), 14 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 481270567..6264485c8 100644
+--- a/meson.build
++++ b/meson.build
+@@ -2,7 +2,7 @@ project(
+   'mpd',
+   ['c', 'cpp'],
+   version: '0.23.5',
+-  meson_version: '>= 0.56.0',
++  meson_version: '>= 0.51.0',
+   default_options: [
+     'c_std=c11',
+     'build.c_std=c11',
+@@ -10,21 +10,8 @@ project(
+     'build.cpp_std=c++17',
+     'warning_level=3',
+-    # If we build those libraries as Meson subproject, they shall be
+-    # linked statically into the MPD executable.
+-    'expat:default_library=static',
+-    'fmt:default_library=static',
+-    'gtest:default_library=static',
+-    'sqlite3:default_library=static',
+-    'vorbis:default_library=static',
+-
+     # Not interested in compiler warnings from subprojects.
+     'expat:werror=false',
+-    'expat:warning_level=0',
+-    'fmt:warning_level=0',
+-    'gtest:warning_level=0',
+-    'sqlite3:warning_level=0',
+-    'vorbis:warning_level=0',
+   ],
+   license: 'GPLv2+',
+ )
diff --git a/recipes-multimedia/musicpd/files/mpd-volatiles.conf b/recipes-multimedia/musicpd/files/mpd-volatiles.conf
new file mode 100644 (file)
index 0000000..dd7bff0
--- /dev/null
@@ -0,0 +1,2 @@
+d      /var/volatile/lib/mpd   0755    mpd     mpd
+L+     /var/lib/mpd            -       -       -       -       /var/volatile/lib/mpd
diff --git a/recipes-multimedia/musicpd/files/mpd.conf.in b/recipes-multimedia/musicpd/files/mpd.conf.in
new file mode 100644 (file)
index 0000000..6dae60a
--- /dev/null
@@ -0,0 +1,425 @@
+# An example configuration file for MPD
+# See the mpd.conf man page for a more detailed description of each parameter.
+
+
+# Files and directories #######################################################
+#
+# This setting controls the top directory which MPD will search to discover the
+# available audio files and add them to the daemon's online database. This
+# setting defaults to the XDG directory, otherwise the music directory will be
+# be disabled and audio files will only be accepted over ipc socket (using
+# file:// protocol) or streaming files over an accepted protocol.
+#
+music_directory                "/media"
+#
+# This setting sets the MPD internal playlist directory. The purpose of this
+# directory is storage for playlists created by MPD. The server will use
+# playlist files not created by the server but only if they are in the MPD
+# format. This setting defaults to playlist saving being disabled.
+#
+playlist_directory             "%playlist_directory%"
+#
+# This setting sets the location of the MPD database. This file is used to
+# load the database at server start up and store the database while the
+# server is not up. This setting defaults to disabled which will allow
+# MPD to accept files over ipc socket (using file:// protocol) or streaming
+# files over an accepted protocol.
+#
+db_file                        "%db_file%"
+#
+# These settings are the locations for the daemon log files for the daemon.
+# These logs are great for troubleshooting, depending on your log_level
+# settings.
+#
+# The special value "syslog" makes MPD use the local syslog daemon. This
+# setting defaults to logging to syslog, otherwise logging is disabled.
+#
+log_file                       "syslog"
+#
+# This setting sets the location of the file which stores the process ID
+# for use of mpd --kill and some init scripts. This setting is disabled by
+# default and the pid file will not be stored.
+#
+#pid_file                      "/var/run/mpd/mpd.pid"
+#
+# This setting sets the location of the file which contains information about
+# most variables to get MPD back into the same general shape it was in before
+# it was brought down. This setting is disabled by default and the server
+# state will be reset on server start up.
+#
+state_file             "%state_file%"
+#
+# The location of the sticker database.  This is a database which
+# manages dynamic information attached to songs.
+#
+#sticker_file                  "~/.mpd/sticker.sql"
+#
+###############################################################################
+
+
+# General music daemon options ################################################
+#
+# This setting specifies the user that MPD will run as. MPD should never run as
+# root and you may use this setting to make MPD change its user ID after
+# initialization. This setting is disabled by default and MPD is run as the
+# current user.
+#
+user "mpd"
+#
+# This setting specifies the group that MPD will run as. If not specified
+# primary group of user specified with "user" setting will be used (if set).
+# This is useful if MPD needs to be a member of group such as "audio" to
+# have permission to use sound card.
+#
+#group "audio"
+#
+# This setting sets the address for the daemon to listen on. Careful attention
+# should be paid if this is assigned to anything other then the default, any.
+# This setting can deny access to control of the daemon.
+#
+# For network
+bind_to_address                "any"
+#
+# And for Unix Socket
+#bind_to_address               "~/.mpd/socket"
+#
+# This setting is the TCP port that is desired for the daemon to get assigned
+# to.
+#
+#port                          "6600"
+#
+# This setting controls the type of information which is logged. Available
+# setting arguments are "default", "secure" or "verbose". The "verbose" setting
+# argument is recommended for troubleshooting, though can quickly stretch
+# available resources on limited hardware storage.
+#
+#log_level                     "default"
+#
+# If you have a problem with your MP3s ending abruptly it is recommended that
+# you set this argument to "no" to attempt to fix the problem. If this solves
+# the problem, it is highly recommended to fix the MP3 files with vbrfix
+# (available from <http://www.willwap.co.uk/Programs/vbrfix.php>), at which
+# point gapless MP3 playback can be enabled.
+#
+#gapless_mp3_playback                  "yes"
+#
+# This setting enables MPD to create playlists in a format usable by other
+# music players.
+#
+#save_absolute_paths_in_playlists      "no"
+#
+# This setting defines a list of tag types that will be extracted during the
+# audio file discovery process. Optionally, 'comment' can be added to this
+# list.
+#
+#metadata_to_use       "artist,album,title,track,name,genre,date,composer,performer,disc"
+#
+# This setting enables automatic update of MPD's database when files in
+# music_directory are changed.
+#
+auto_update    "yes"
+#
+# Limit the depth of the directories being watched, 0 means only watch
+# the music directory itself.  There is no limit by default.
+#
+auto_update_depth "3"
+#
+###############################################################################
+
+
+# Symbolic link behavior ######################################################
+#
+# If this setting is set to "yes", MPD will discover audio files by following
+# symbolic links outside of the configured music_directory.
+#
+follow_outside_symlinks        "no"
+#
+# If this setting is set to "yes", MPD will discover audio files by following
+# symbolic links inside of the configured music_directory.
+#
+#follow_inside_symlinks                "yes"
+#
+###############################################################################
+
+
+# Zeroconf / Avahi Service Discovery ##########################################
+#
+# If this setting is set to "yes", service information will be published with
+# Zeroconf / Avahi.
+#
+#zeroconf_enabled              "yes"
+#
+# The argument to this setting will be the Zeroconf / Avahi unique name for
+# this MPD server on the network.
+#
+#zeroconf_name                 "Music Player"
+#
+###############################################################################
+
+
+# Permissions #################################################################
+#
+# If this setting is set, MPD will require password authorization. The password
+# can setting can be specified multiple times for different password profiles.
+#
+#password                        "password@read,add,control,admin"
+#
+# This setting specifies the permissions a user has who has not yet logged in.
+#
+#default_permissions             "read,add,control,admin"
+#
+###############################################################################
+
+
+# Input #######################################################################
+#
+
+#input {
+#        plugin "curl"
+#       proxy "proxy.isp.com:8080"
+#       proxy_user "user"
+#       proxy_password "password"
+#}
+
+#
+###############################################################################
+
+# Audio Output ################################################################
+#
+# MPD supports various audio output types, as well as playing through multiple
+# audio outputs at the same time, through multiple audio_output settings
+# blocks. Setting this block is optional, though the server will only attempt
+# autodetection for one sound card.
+#
+# See <http://mpd.wikia.com/wiki/Configuration#Audio_Outputs> for examples of
+# other audio outputs.
+#
+# board specific examples #####################################################
+# (feel free to add futher)
+#
+# gumstix overo (tested with TOBI expansion board)
+#audio_output {
+#      type            "alsa"
+#      name            "overo"
+#      mixer_control   "Headset"
+#      mixer_index     "0"
+#}
+
+audio_output {
+       type "pipewire"
+       name "AGL PipeWire"
+}
+
+# general examples ############################################################
+#
+# An example of an ALSA output:
+#
+#audio_output {
+#      type            "alsa"
+#      name            "My ALSA Device"
+##     device          "hw:0,0"        # optional
+##     format          "44100:16:2"    # optional
+##     mixer_type      "hardware"      # optional
+##     mixer_device    "default"       # optional
+##     mixer_control   "PCM"           # optional
+##     mixer_index     "0"             # optional
+#}
+#
+# An example of an OSS output:
+#
+#audio_output {
+#      type            "oss"
+#      name            "My OSS Device"
+##     device          "/dev/dsp"      # optional
+##     format          "44100:16:2"    # optional
+##     mixer_type      "hardware"      # optional
+##     mixer_device    "/dev/mixer"    # optional
+##     mixer_control   "PCM"           # optional
+#}
+#
+# An example of a shout output (for streaming to Icecast):
+#
+#audio_output {
+#      type            "shout"
+#      encoding        "ogg"                   # optional
+#      name            "My Shout Stream"
+#      host            "localhost"
+#      port            "8000"
+#      mount           "/mpd.ogg"
+#      password        "hackme"
+#      quality         "5.0"
+#      bitrate         "128"
+#      format          "44100:16:1"
+##     protocol        "icecast2"              # optional
+##     user            "source"                # optional
+##     description     "My Stream Description" # optional
+##     genre           "jazz"                  # optional
+##     public          "no"                    # optional
+##     timeout         "2"                     # optional
+##     mixer_type      "software"              # optional
+#}
+#
+# An example of a recorder output:
+#
+#audio_output {
+#      type            "recorder"
+#      name            "My recorder"
+#      encoder         "vorbis"                # optional, vorbis or lame
+#      path            "/var/lib/mpd/recorder/mpd.ogg"
+##     quality         "5.0"                   # do not define if bitrate is defined
+#      bitrate         "128"                   # do not define if quality is defined
+#      format          "44100:16:1"
+#}
+#
+# An example of a httpd output (built-in HTTP streaming server):
+#
+#audio_output {
+#      type            "httpd"
+#      name            "My HTTP Stream"
+#      encoder         "vorbis"                # optional, vorbis or lame
+#      port            "8000"
+#      bind_to_address "0.0.0.0"               # optional, IPv4 or IPv6
+##     quality         "5.0"                   # do not define if bitrate is defined
+#      bitrate         "128"                   # do not define if quality is defined
+#      format          "44100:16:1"
+#      max_clients     "0"                     # optional 0=no limit
+#}
+#
+# An example of a pulseaudio output (streaming to a remote pulseaudio server)
+#
+#audio_output {
+#      type            "pulse"
+#      name            "My Pulse Output"
+##     server          "remote_server"         # optional
+##     sink            "remote_server_sink"    # optional
+#}
+#
+## Example "pipe" output:
+#
+#audio_output {
+#      type            "pipe"
+#      name            "my pipe"
+#      command         "aplay -f cd 2>/dev/null"
+## Or if you're want to use AudioCompress
+#      command         "AudioCompress -m | aplay -f cd 2>/dev/null"
+## Or to send raw PCM stream through PCM:
+#      command         "nc example.org 8765"
+#      format          "44100:16:2"
+#}
+#
+## An example of a null output (for no audio output):
+#
+#audio_output {
+#      type            "null"
+#      name            "My Null Output"
+#      mixer_type      "none"                  # optional
+#}
+#
+# This setting will change all decoded audio to be converted to the specified
+# format before being passed to the audio outputs. By default, this setting is
+# disabled.
+#
+#audio_output_format           "44100:16:2"
+#
+# If MPD has been compiled with libsamplerate support, this setting specifies
+# the sample rate converter to use.  Possible values can be found in the
+# mpd.conf man page or the libsamplerate documentation. By default, this is
+# setting is disabled.
+#
+#samplerate_converter          "Fastest Sinc Interpolator"
+#
+###############################################################################
+
+
+# Normalization automatic volume adjustments ##################################
+#
+# This setting specifies the type of ReplayGain to use. This setting can have
+# the argument "off", "album" or "track". See <http://www.replaygain.org>
+# for more details. This setting is off by default.
+#
+#replaygain                    "album"
+#
+# This setting sets the pre-amp used for files that have ReplayGain tags. By
+# default this setting is disabled.
+#
+#replaygain_preamp             "0"
+#
+# This setting enables on-the-fly normalization volume adjustment. This will
+# result in the volume of all playing audio to be adjusted so the output has
+# equal "loudness". This setting is disabled by default.
+#
+#volume_normalization          "no"
+#
+###############################################################################
+
+
+# MPD Internal Buffering ######################################################
+#
+# This setting adjusts the size of internal decoded audio buffering. Changing
+# this may have undesired effects. Don't change this if you don't know what you
+# are doing.
+#
+#audio_buffer_size             "2048"
+#
+# This setting controls the percentage of the buffer which is filled before
+# beginning to play. Increasing this reduces the chance of audio file skipping,
+# at the cost of increased time prior to audio playback.
+#
+#buffer_before_play            "10%"
+#
+###############################################################################
+
+
+# Resource Limitations ########################################################
+#
+# These settings are various limitations to prevent MPD from using too many
+# resources. Generally, these settings should be minimized to prevent security
+# risks, depending on the operating resources.
+#
+connection_timeout             "120"
+#max_connections               "10"
+#max_playlist_length           "16384"
+#max_command_list_size         "2048"
+#max_output_buffer_size                "8192"
+#
+###############################################################################
+
+
+# Character Encoding ##########################################################
+#
+# If file or directory names do not display correctly for your locale then you
+# may need to modify this setting.
+#
+#filesystem_charset            "UTF-8"
+#
+# This setting controls the encoding that ID3v1 tags should be converted from.
+#
+#id3v1_encoding                        "ISO-8859-1"
+#
+###############################################################################
+
+
+# SIDPlay decoder #############################################################
+#
+# songlength_database:
+#  Location of your songlengths file, as distributed with the HVSC.
+#  The sidplay plugin checks this for matching MD5 fingerprints.
+#  See http://www.c64.org/HVSC/DOCUMENTS/Songlengths.faq
+#
+# default_songlength:
+#  This is the default playing time in seconds for songs not in the
+#  songlength database, or in case you're not using a database.
+#  A value of 0 means play indefinitely.
+#
+# filter:
+#  Turns the SID filter emulation on or off.
+#
+#decoder {
+#      plugin                  "sidplay"
+#      songlength_database     "/media/C64Music/DOCUMENTS/Songlengths.txt"
+#      default_songlength      "120"
+#      filter "true"
+#}
+#
+###############################################################################
+
diff --git a/recipes-multimedia/musicpd/libmpdclient_2.19.bb b/recipes-multimedia/musicpd/libmpdclient_2.19.bb
new file mode 100644 (file)
index 0000000..6cff3c4
--- /dev/null
@@ -0,0 +1,22 @@
+SUMMARY = "C client library for the Music Player Daemon"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=06b9dfd2f197dc514d8ef06549684b77"
+HOMEPAGE = "https://www.musicpd.org/libs/libmpdclient/"
+
+inherit meson
+
+SRC_URI = " \
+    git://github.com/MusicPlayerDaemon/libmpdclient;branch=master;protocol=https \
+"
+SRCREV = "27767959442ef390aabb16790494ba93fed962ef"
+S = "${WORKDIR}/git"
+
+PACKAGECONFIG ??= "tcp"
+PACKAGECONFIG[tcp] = "-Dtcp=true,-Dtcp=false"
+
+do_install:append() {
+    # libmpdclient's Vala bindings are outdated and unmaintained; it
+    # is likely that nobody will ever use them, so let's not install
+    # them
+    rm -rf ${D}${datadir}/vala
+}
diff --git a/recipes-multimedia/musicpd/mpc_0.33.bb b/recipes-multimedia/musicpd/mpc_0.33.bb
new file mode 100644 (file)
index 0000000..09190a8
--- /dev/null
@@ -0,0 +1,13 @@
+SUMMARY = "A minimalist command line interface to the Music Player Daemon"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+HOMEPAGE = "https://www.musicpd.org/clients/mpc/"
+
+inherit meson pkgconfig
+
+DEPENDS += "libmpdclient"
+
+SRC_URI = "git://github.com/MusicPlayerDaemon/mpc;branch=master;protocol=https"
+SRCREV = "ef16b280052ef0320cb80f79d74c8ce0324005ed"
+
+S = "${WORKDIR}/git"
diff --git a/recipes-multimedia/musicpd/mpd/mpd.conf.in b/recipes-multimedia/musicpd/mpd/mpd.conf.in
new file mode 100644 (file)
index 0000000..f9f92c9
--- /dev/null
@@ -0,0 +1,420 @@
+# An example configuration file for MPD
+# See the mpd.conf man page for a more detailed description of each parameter.
+
+
+# Files and directories #######################################################
+#
+# This setting controls the top directory which MPD will search to discover the
+# available audio files and add them to the daemon's online database. This
+# setting defaults to the XDG directory, otherwise the music directory will be
+# be disabled and audio files will only be accepted over ipc socket (using
+# file:// protocol) or streaming files over an accepted protocol.
+#
+music_directory                "%music_directory%"
+#
+# This setting sets the MPD internal playlist directory. The purpose of this
+# directory is storage for playlists created by MPD. The server will use
+# playlist files not created by the server but only if they are in the MPD
+# format. This setting defaults to playlist saving being disabled.
+#
+playlist_directory             "%playlist_directory%"
+#
+# This setting sets the location of the MPD database. This file is used to
+# load the database at server start up and store the database while the
+# server is not up. This setting defaults to disabled which will allow
+# MPD to accept files over ipc socket (using file:// protocol) or streaming
+# files over an accepted protocol.
+#
+db_file                        "%db_file%"
+#
+# These settings are the locations for the daemon log files for the daemon.
+# These logs are great for troubleshooting, depending on your log_level
+# settings.
+#
+# The special value "syslog" makes MPD use the local syslog daemon. This
+# setting defaults to logging to syslog, otherwise logging is disabled.
+#
+log_file                       "%log_file%"
+#
+# This setting sets the location of the file which stores the process ID
+# for use of mpd --kill and some init scripts. This setting is disabled by
+# default and the pid file will not be stored.
+#
+#pid_file                      "/var/run/mpd/mpd.pid"
+#
+# This setting sets the location of the file which contains information about
+# most variables to get MPD back into the same general shape it was in before
+# it was brought down. This setting is disabled by default and the server
+# state will be reset on server start up.
+#
+state_file             "%state_file%"
+#
+# The location of the sticker database.  This is a database which
+# manages dynamic information attached to songs.
+#
+#sticker_file                  "~/.mpd/sticker.sql"
+#
+###############################################################################
+
+
+# General music daemon options ################################################
+#
+# This setting specifies the user that MPD will run as. MPD should never run as
+# root and you may use this setting to make MPD change its user ID after
+# initialization. This setting is disabled by default and MPD is run as the
+# current user.
+#
+user "mpd"
+#
+# This setting specifies the group that MPD will run as. If not specified
+# primary group of user specified with "user" setting will be used (if set).
+# This is useful if MPD needs to be a member of group such as "audio" to
+# have permission to use sound card.
+#
+group                          "audio"
+#
+# This setting sets the address for the daemon to listen on. Careful attention
+# should be paid if this is assigned to anything other then the default, any.
+# This setting can deny access to control of the daemon.
+#
+# For network
+bind_to_address                "any"
+#
+# And for Unix Socket
+#bind_to_address               "~/.mpd/socket"
+#
+# This setting is the TCP port that is desired for the daemon to get assigned
+# to.
+#
+#port                          "6600"
+#
+# This setting controls the type of information which is logged. Available
+# setting arguments are "default", "secure" or "verbose". The "verbose" setting
+# argument is recommended for troubleshooting, though can quickly stretch
+# available resources on limited hardware storage.
+#
+#log_level                     "default"
+#
+# If you have a problem with your MP3s ending abruptly it is recommended that
+# you set this argument to "no" to attempt to fix the problem. If this solves
+# the problem, it is highly recommended to fix the MP3 files with vbrfix
+# (available from <http://www.willwap.co.uk/Programs/vbrfix.php>), at which
+# point gapless MP3 playback can be enabled.
+#
+#gapless_mp3_playback                  "yes"
+#
+# This setting enables MPD to create playlists in a format usable by other
+# music players.
+#
+#save_absolute_paths_in_playlists      "no"
+#
+# This setting defines a list of tag types that will be extracted during the
+# audio file discovery process. Optionally, 'comment' can be added to this
+# list.
+#
+#metadata_to_use       "artist,album,title,track,name,genre,date,composer,performer,disc"
+#
+# This setting enables automatic update of MPD's database when files in
+# music_directory are changed.
+#
+#auto_update   "yes"
+#
+# Limit the depth of the directories being watched, 0 means only watch
+# the music directory itself.  There is no limit by default.
+#
+#auto_update_depth "3"
+#
+###############################################################################
+
+
+# Symbolic link behavior ######################################################
+#
+# If this setting is set to "yes", MPD will discover audio files by following
+# symbolic links outside of the configured music_directory.
+#
+#follow_outside_symlinks       "yes"
+#
+# If this setting is set to "yes", MPD will discover audio files by following
+# symbolic links inside of the configured music_directory.
+#
+#follow_inside_symlinks                "yes"
+#
+###############################################################################
+
+
+# Zeroconf / Avahi Service Discovery ##########################################
+#
+# If this setting is set to "yes", service information will be published with
+# Zeroconf / Avahi.
+#
+#zeroconf_enabled              "yes"
+#
+# The argument to this setting will be the Zeroconf / Avahi unique name for
+# this MPD server on the network.
+#
+#zeroconf_name                 "Music Player"
+#
+###############################################################################
+
+
+# Permissions #################################################################
+#
+# If this setting is set, MPD will require password authorization. The password
+# can setting can be specified multiple times for different password profiles.
+#
+#password                        "password@read,add,control,admin"
+#
+# This setting specifies the permissions a user has who has not yet logged in.
+#
+#default_permissions             "read,add,control,admin"
+#
+###############################################################################
+
+
+# Input #######################################################################
+#
+
+input {
+        plugin "curl"
+#       proxy "proxy.isp.com:8080"
+#       proxy_user "user"
+#       proxy_password "password"
+}
+
+#
+###############################################################################
+
+# Audio Output ################################################################
+#
+# MPD supports various audio output types, as well as playing through multiple
+# audio outputs at the same time, through multiple audio_output settings
+# blocks. Setting this block is optional, though the server will only attempt
+# autodetection for one sound card.
+#
+# See <http://mpd.wikia.com/wiki/Configuration#Audio_Outputs> for examples of
+# other audio outputs.
+#
+# board specific examples #####################################################
+# (feel free to add futher)
+#
+# gumstix overo (tested with TOBI expansion board)
+#audio_output {
+#      type            "alsa"
+#      name            "overo"
+#      mixer_control   "Headset"
+#      mixer_index     "0"
+#}
+#
+# general examples ############################################################
+#
+# An example of an ALSA output:
+#
+#audio_output {
+#      type            "alsa"
+#      name            "My ALSA Device"
+##     device          "hw:0,0"        # optional
+##     format          "44100:16:2"    # optional
+##     mixer_type      "hardware"      # optional
+##     mixer_device    "default"       # optional
+##     mixer_control   "PCM"           # optional
+##     mixer_index     "0"             # optional
+#}
+#
+# An example of an OSS output:
+#
+#audio_output {
+#      type            "oss"
+#      name            "My OSS Device"
+##     device          "/dev/dsp"      # optional
+##     format          "44100:16:2"    # optional
+##     mixer_type      "hardware"      # optional
+##     mixer_device    "/dev/mixer"    # optional
+##     mixer_control   "PCM"           # optional
+#}
+#
+# An example of a shout output (for streaming to Icecast):
+#
+#audio_output {
+#      type            "shout"
+#      encoding        "ogg"                   # optional
+#      name            "My Shout Stream"
+#      host            "localhost"
+#      port            "8000"
+#      mount           "/mpd.ogg"
+#      password        "hackme"
+#      quality         "5.0"
+#      bitrate         "128"
+#      format          "44100:16:1"
+##     protocol        "icecast2"              # optional
+##     user            "source"                # optional
+##     description     "My Stream Description" # optional
+##     genre           "jazz"                  # optional
+##     public          "no"                    # optional
+##     timeout         "2"                     # optional
+##     mixer_type      "software"              # optional
+#}
+#
+# An example of a recorder output:
+#
+#audio_output {
+#      type            "recorder"
+#      name            "My recorder"
+#      encoder         "vorbis"                # optional, vorbis or lame
+#      path            "/var/lib/mpd/recorder/mpd.ogg"
+##     quality         "5.0"                   # do not define if bitrate is defined
+#      bitrate         "128"                   # do not define if quality is defined
+#      format          "44100:16:1"
+#}
+#
+# An example of a httpd output (built-in HTTP streaming server):
+#
+#audio_output {
+#      type            "httpd"
+#      name            "My HTTP Stream"
+#      encoder         "vorbis"                # optional, vorbis or lame
+#      port            "8000"
+#      bind_to_address "0.0.0.0"               # optional, IPv4 or IPv6
+##     quality         "5.0"                   # do not define if bitrate is defined
+#      bitrate         "128"                   # do not define if quality is defined
+#      format          "44100:16:1"
+#      max_clients     "0"                     # optional 0=no limit
+#}
+#
+# An example of a pulseaudio output (streaming to a remote pulseaudio server)
+#
+#audio_output {
+#      type            "pulse"
+#      name            "My Pulse Output"
+##     server          "remote_server"         # optional
+##     sink            "remote_server_sink"    # optional
+#}
+#
+## Example "pipe" output:
+#
+#audio_output {
+#      type            "pipe"
+#      name            "my pipe"
+#      command         "aplay -f cd 2>/dev/null"
+## Or if you're want to use AudioCompress
+#      command         "AudioCompress -m | aplay -f cd 2>/dev/null"
+## Or to send raw PCM stream through PCM:
+#      command         "nc example.org 8765"
+#      format          "44100:16:2"
+#}
+#
+## An example of a null output (for no audio output):
+#
+#audio_output {
+#      type            "null"
+#      name            "My Null Output"
+#      mixer_type      "none"                  # optional
+#}
+#
+# This setting will change all decoded audio to be converted to the specified
+# format before being passed to the audio outputs. By default, this setting is
+# disabled.
+#
+#audio_output_format           "44100:16:2"
+#
+# If MPD has been compiled with libsamplerate support, this setting specifies
+# the sample rate converter to use.  Possible values can be found in the
+# mpd.conf man page or the libsamplerate documentation. By default, this is
+# setting is disabled.
+#
+#samplerate_converter          "Fastest Sinc Interpolator"
+#
+###############################################################################
+
+
+# Normalization automatic volume adjustments ##################################
+#
+# This setting specifies the type of ReplayGain to use. This setting can have
+# the argument "off", "album" or "track". See <http://www.replaygain.org>
+# for more details. This setting is off by default.
+#
+#replaygain                    "album"
+#
+# This setting sets the pre-amp used for files that have ReplayGain tags. By
+# default this setting is disabled.
+#
+#replaygain_preamp             "0"
+#
+# This setting enables on-the-fly normalization volume adjustment. This will
+# result in the volume of all playing audio to be adjusted so the output has
+# equal "loudness". This setting is disabled by default.
+#
+#volume_normalization          "no"
+#
+###############################################################################
+
+
+# MPD Internal Buffering ######################################################
+#
+# This setting adjusts the size of internal decoded audio buffering. Changing
+# this may have undesired effects. Don't change this if you don't know what you
+# are doing.
+#
+#audio_buffer_size             "2048"
+#
+# This setting controls the percentage of the buffer which is filled before
+# beginning to play. Increasing this reduces the chance of audio file skipping,
+# at the cost of increased time prior to audio playback.
+#
+#buffer_before_play            "10%"
+#
+###############################################################################
+
+
+# Resource Limitations ########################################################
+#
+# These settings are various limitations to prevent MPD from using too many
+# resources. Generally, these settings should be minimized to prevent security
+# risks, depending on the operating resources.
+#
+#connection_timeout            "60"
+#max_connections               "10"
+#max_playlist_length           "16384"
+#max_command_list_size         "2048"
+#max_output_buffer_size                "8192"
+#
+###############################################################################
+
+
+# Character Encoding ##########################################################
+#
+# If file or directory names do not display correctly for your locale then you
+# may need to modify this setting.
+#
+#filesystem_charset            "UTF-8"
+#
+# This setting controls the encoding that ID3v1 tags should be converted from.
+#
+#id3v1_encoding                        "ISO-8859-1"
+#
+###############################################################################
+
+
+# SIDPlay decoder #############################################################
+#
+# songlength_database:
+#  Location of your songlengths file, as distributed with the HVSC.
+#  The sidplay plugin checks this for matching MD5 fingerprints.
+#  See http://www.c64.org/HVSC/DOCUMENTS/Songlengths.faq
+#
+# default_songlength:
+#  This is the default playing time in seconds for songs not in the
+#  songlength database, or in case you're not using a database.
+#  A value of 0 means play indefinitely.
+#
+# filter:
+#  Turns the SID filter emulation on or off.
+#
+#decoder {
+#      plugin                  "sidplay"
+#      songlength_database     "/media/C64Music/DOCUMENTS/Songlengths.txt"
+#      default_songlength      "120"
+#      filter "true"
+#}
+#
+###############################################################################
+
diff --git a/recipes-multimedia/musicpd/mpd_0.23.5.bb b/recipes-multimedia/musicpd/mpd_0.23.5.bb
new file mode 100644 (file)
index 0000000..3c6f3e4
--- /dev/null
@@ -0,0 +1,101 @@
+SUMMARY = "Music Player Daemon"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+HOMEPAGE ="http://www.musicpd.org"
+
+inherit meson useradd systemd pkgconfig
+
+DEPENDS += " \
+    curl \
+    sqlite3 \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)} \
+    yajl \
+    boost \
+    icu \
+    dbus \
+    expat \
+    fmt \
+"
+
+SRC_URI = "git://github.com/MusicPlayerDaemon/MPD;branch=v0.23.x;protocol=https \
+           file://mpd.conf.in \
+           "
+SRCREV = "df4b6b92f2c4bba1b55fe0a5559b19808abb28ff"
+S = "${WORKDIR}/git"
+
+EXTRA_OEMESON += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-Dsystemd=enabled -Dsystemd_system_unit_dir=${systemd_system_unitdir} -Dsystemd_user_unit_dir=${systemd_system_unitdir}', '-Dsystemd=disabled', d)}"
+
+PACKAGECONFIG ??= "${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "aac", "", d)} \
+                   alsa ao bzip2 daemon \
+                   ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "ffmpeg aac", "", d)} \
+                   fifo flac fluidsynth iso9660 \
+                   jack libsamplerate httpd \
+                   mms mpg123 modplug sndfile \
+                   upnp openal opus oss recorder \
+                   vorbis wavpack zlib"
+
+PACKAGECONFIG[aac] = "-Dfaad=enabled,-Dfaad=disabled,faad2"
+PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib"
+PACKAGECONFIG[ao] = "-Dao=enabled,-Dao=disabled,libao"
+PACKAGECONFIG[audiofile] = "-Daudiofile=enabled,-Daudiofile=disabled,audiofile"
+PACKAGECONFIG[bzip2] = "-Dbzip2=enabled,-Dbzip2=disabled,bzip2"
+PACKAGECONFIG[cdioparanoia] = "-Dcdio_paranoia=enabled,-Dcdio_paranoia=disabled,libcdio-paranoia"
+PACKAGECONFIG[daemon] = "-Ddaemon=true,-Ddaemon=false"
+PACKAGECONFIG[ffmpeg] = "-Dffmpeg=enabled,-Dffmpeg=disabled,ffmpeg"
+PACKAGECONFIG[fifo] = "-Dfifo=true,-Dfifo=false"
+PACKAGECONFIG[flac] = "-Dflac=enabled,-Dflac=disabled,flac"
+PACKAGECONFIG[fluidsynth] = "-Dfluidsynth=enabled,-Dfluidsynth=disabled,fluidsynth"
+PACKAGECONFIG[httpd] = "-Dhttpd=true,-Dhttpd=false"
+PACKAGECONFIG[id3tag] = "-Did3tag=enabled,-Did3tag=disabled,libid3tag"
+PACKAGECONFIG[iso9660] = "-Diso9660=enabled,-Diso9660=disabled,libcdio"
+PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack"
+PACKAGECONFIG[lame] = "-Dlame=enabled,-Dlame=disabled,lame"
+PACKAGECONFIG[libsamplerate] = "-Dlibsamplerate=enabled,-Dlibsamplerate=disabled,libsamplerate0"
+PACKAGECONFIG[mad] = "-Dmad=enabled,-Dmad=disabled,libmad"
+PACKAGECONFIG[mms] = "-Dmms=enabled,-Dmms=disabled,libmms"
+PACKAGECONFIG[modplug] = "-Dmodplug=enabled,-Dmodplug=disabled,libmodplug"
+PACKAGECONFIG[mpg123] = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
+PACKAGECONFIG[openal] = "-Dopenal=enabled,-Dopenal=disabled,openal-soft"
+PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus libogg"
+PACKAGECONFIG[oss] = "-Doss=enabled,-Doss=disabled,"
+PACKAGECONFIG[recorder] = "-Drecorder=true,-Drecorder=false"
+PACKAGECONFIG[smb] = "-Dsmbclient=enabled,-Dsmbclient=disabled,samba"
+PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1"
+PACKAGECONFIG[upnp] = "-Dupnp=pupnp,-Dupnp=disabled,libupnp"
+PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis libogg"
+PACKAGECONFIG[wavpack] = "-Dwavpack=enabled,-Dwavpack=disabled,wavpack"
+PACKAGECONFIG[zlib] = "-Dzlib=enabled,-Dzlib=disabled,zlib"
+
+do_install:append() {
+    install -o mpd -d \
+        ${D}/${localstatedir}/lib/mpd \
+        ${D}/${localstatedir}/lib/mpd/playlists
+    install -m775 -o mpd -g mpd -d \
+        ${D}/${localstatedir}/lib/mpd/music
+
+    install -d ${D}/${sysconfdir}
+    install -m 644 ${WORKDIR}/mpd.conf.in ${D}/${sysconfdir}/mpd.conf
+    sed -i \
+        -e 's|%music_directory%|${localstatedir}/lib/mpd/music|' \
+        -e 's|%playlist_directory%|${localstatedir}/lib/mpd/playlists|' \
+        -e 's|%db_file%|${localstatedir}/lib/mpd/mpd.db|' \
+        -e 's|%log_file%|${localstatedir}/log/mpd.log|' \
+        -e 's|%state_file%|${localstatedir}/lib/mpd/state|' \
+        ${D}/${sysconfdir}/mpd.conf
+
+    # we don't need the icon
+    rm -rf ${D}${datadir}/icons
+}
+
+RPROVIDES:${PN} += "${PN}-systemd"
+RREPLACES:${PN} += "${PN}-systemd"
+RCONFLICTS:${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE:${PN} = "mpd.socket"
+
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM:${PN} = " \
+    --system --no-create-home \
+    --home ${localstatedir}/lib/mpd \
+    --groups audio \
+    --user-group mpd"
diff --git a/recipes-multimedia/musicpd/mpd_0.23.5.bbappend b/recipes-multimedia/musicpd/mpd_0.23.5.bbappend
new file mode 100644 (file)
index 0000000..5377a54
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'mpd_agldemo.inc', '', d)}
diff --git a/recipes-multimedia/musicpd/mpd_agldemo.inc b/recipes-multimedia/musicpd/mpd_agldemo.inc
new file mode 100644 (file)
index 0000000..8bbd591
--- /dev/null
@@ -0,0 +1,57 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+# Remove curl dependency to disable WebDAV support.
+# Ideally this should be addressed by adding a PACKAGECONFIG option
+# in the upstream recipe.
+DEPENDS:remove = "curl"
+
+SRC_URI += "file://0001-Tweaks-to-allow-building-with-older-meson.patch \
+            file://mpd-volatiles.conf"
+
+# The older meson in poky dunfell complains about the use of the
+# build.{c_std,cpp_std} options even though they work, so we need to
+# flag them to be ignored in the unknown configure option QA test.
+# This can be removed after upgrading to Yocto Project 3.5.
+UNKNOWN_CONFIGURE_WHITELIST = "build.c_std build.cpp_std"
+
+# This also needs to be pushed upstream.
+PACKAGECONFIG[pipewire] = "-Dpipewire=enabled,-Dpipewire=disabled,pipewire"
+
+# Prune the default configuration a bit to remove various streaming/server
+# options that are not required.
+PACKAGECONFIG = " \
+    ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "aac", "", d)} \
+    bzip2 \
+    daemon \
+    ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "ffmpeg aac", "", d)} \
+    flac \
+    libsamplerate \
+    mpg123 \
+    sndfile \
+    opus \
+    vorbis \
+    wavpack \
+    zlib \
+    pipewire \
+    id3tag \
+"
+
+SYSTEMD_AUTO_ENABLE = "enable"
+
+# Override default as AGL's PipeWire configuration does not make use of audio
+# group.  As opposed to using the group setting in mpd.conf, this keeps the
+# files created in /var/lib/mpd as mpd.mpd, which seems safer.
+USERADD_PARAM:${PN} = " \
+    --system --no-create-home \
+    --home ${localstatedir}/lib/mpd \
+    --groups pipewire \
+    --user-group mpd"
+
+# Install volatile redirect for /var/lib/mpd to avoid any chance of metadata
+# corruption on reboot.  This matches what as previously done with the
+# lightmediascanner configuration.
+do_install:append() {
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+       install -D -m 0644 ${WORKDIR}/mpd-volatiles.conf ${D}${sysconfdir}/tmpfiles.d/mpd.conf
+    fi
+}
index 6ce928f..fcb31d9 100644 (file)
@@ -43,7 +43,7 @@ RDEPENDS:${PN}:append = " \
     launcher \
     qtquickcontrols2-agl \
     qtquickcontrols2-agl-style \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \
     ${AGL_APPS} \
     ${DEMO_PRELOAD} \
     "
index 2f6521a..dc60e9e 100644 (file)
@@ -13,7 +13,7 @@ ALLOW_EMPTY:${PN} = "1"
 RDEPENDS:${PN} += "\
     gstreamer1.0-plugins-base-meta \
     gstreamer1.0-plugins-good-meta \
-    lightmediascanner-meta \
+    mpd \
     "
 
 # for now: enable here for the AGL IVI demo (image-ivi and demo-platform)