Bump SRCREV for tbtnavi, take two 16/29516/2
authorMarius Vlad <marius.vlad@collabora.com>
Tue, 5 Dec 2023 14:48:03 +0000 (16:48 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 12 Dec 2023 14:10:13 +0000 (14:10 +0000)
This bumps tbtnavi to pick-up changes for using gRPC API for
placing it on a different output (remoting one) and conversion to
meson.

This was previously added with eed891f4e7, but reverted in 917739ba52,
due to the fact that tbtnavi wasn't really updated (some MRs where
still in-flight). Those are now merged, with SHA update being the same.

Bug-AGL: SPEC-5003
Change-Id: Id1a57c3008864124f72fed6bc6a15dac82cfb154
Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29516
ci-image-boot-test: Jenkins Job builder account
Tested-by: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
ci-image-build: Jenkins Job builder account

recipes-demo/navigation/tbtnavi_git.bb

index c3bacb3..1720e89 100644 (file)
@@ -16,8 +16,10 @@ DEPENDS = " \
     qtquickcontrols2 \
     qtlocation \
     libqtappfw \
-    wayland-native \
     qtwayland-native \
+    protobuf \
+    grpc \
+    grpc-native \
 "
 
 PV = "2.0+git${SRCPV}"
@@ -27,11 +29,11 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;b
            file://tbtnavi.conf \
            file://tbtnavi.token \
 "
-SRCREV = "7627784a867bd21e76d2889a3c99bbcfc12d3c3f"
+SRCREV = "f00c1e19f5c4cbcd185c8043f3062612bf1537f7"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5 systemd pkgconfig
+inherit meson systemd pkgconfig
 
 SYSTEMD_SERVICE:${PN} = "${BPN}.service"