recipes-automotive/hvacplugin: moved from meta-agl 99/6799/1
authorStephane Desneux <stephane.desneux@iot.bzh>
Tue, 18 Oct 2016 16:52:53 +0000 (16:52 +0000)
committerStephane Desneux <stephane.desneux@iot.bzh>
Tue, 18 Oct 2016 16:52:53 +0000 (16:52 +0000)
The new git repository for hvac plugin sources is now
AGL (gerrit.automotivelinux.org). As a consequence, the
previous repository (github.com/iotbzh/hvacplugin) is now
deprecated.

Change-Id: Ibaf7b01a97520d3c5e105b02aa1a321c66828797
Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
recipes-automotive/hvacplugin/files/hvacplugin [new file with mode: 0644]
recipes-automotive/hvacplugin/hvacplugin_0.1.bb [new file with mode: 0644]

diff --git a/recipes-automotive/hvacplugin/files/hvacplugin b/recipes-automotive/hvacplugin/files/hvacplugin
new file mode 100644 (file)
index 0000000..8a1a90d
--- /dev/null
@@ -0,0 +1,7 @@
+{
+       "name" : "hvacplugin",
+       "path" : "/usr/lib/automotive-message-broker/hvacplugin.so",
+       "delay" : "30",
+       "enabled" : true
+}
+
diff --git a/recipes-automotive/hvacplugin/hvacplugin_0.1.bb b/recipes-automotive/hvacplugin/hvacplugin_0.1.bb
new file mode 100644 (file)
index 0000000..8ac287f
--- /dev/null
@@ -0,0 +1,26 @@
+SUMMARY = "hvacplugin"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+                    file://hvacplugin.cpp;startline=4;endline=11;md5=5adb69b6702cd5745961047a30ef560a"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/hvacplugin;protocol=https \
+           file://hvacplugin \
+          "
+SRCREV = "00cb8ff4084d635d3a929cb41b8d853f6c4baf76"
+S = "${WORKDIR}/git"
+
+DEPENDS = "glib-2.0 json-c automotive-message-broker"
+RDEPENDS_{PN} = "automotive-message-broker"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE += "-DPLUGIN_INSTALL_PATH=${libdir}/automotive-message-broker"
+
+do_install_append() {
+       install -Dm 0644 ${WORKDIR}/hvacplugin ${D}/${sysconfdir}/ambd/plugins.d/hvacplugin
+}
+
+FILES_${PN} += "${libdir}/automotive-message-broker/*.so"
+FILES_${PN}-dbg += "${libdir}/automotive-message-broker/.debug"
+