agl-kvm-demo-platform: update guests 33/28433/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 17 Jan 2023 17:35:21 +0000 (12:35 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 29 Jan 2023 14:29:37 +0000 (14:29 +0000)
Switch default guest images to Flutter based demo platform images.
As well, the simple-can-simulator is added to the host to allow
testing or demos.

Bug-AGL: SPEC-4618

Change-Id: I2c57ca0ade168c2c3dfae8718e891f9af40e4d88
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
(cherry picked from commit 8b0fed47d196a938b44784d1fc8eaa25c36f84ca)

recipes-graphics/wayland/weston-ini-conf_agldemo.inc
recipes-platform/images/agl-kvm-demo-platform.bb

index 21d8014..003d411 100644 (file)
@@ -2,8 +2,8 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/weston-ini-conf:"
 
 SRC_URI += "file://weston.ini.kvm.in"
 
-GUEST_VM1_IMAGE ?= "agl-demo-platform"
-GUEST_VM2_IMAGE ?= "agl-cluster-demo-platform"
+GUEST_VM1_IMAGE ?= "agl-ivi-demo-platform-flutter"
+GUEST_VM2_IMAGE ?= "agl-cluster-demo-platform-flutter"
 
 do_compile:append() {
     # Put all of our cfg files together for a default portrait
index e2f5fd2..d04186b 100644 (file)
@@ -19,6 +19,7 @@ IMAGE_INSTALL:append = " \
     ${QEMU_GUEST_CONFIGS} \
     util-linux-taskset \
     screen \
+    simple-can-simulator \
     alsa-utils \
 "
 
@@ -28,8 +29,8 @@ IMAGE_INSTALL:append = " \
 
 GUEST_MACHINE ?= "virtio-${TUNE_ARCH}"
 
-GUEST_VM1_IMAGE ?= "agl-demo-platform"
-GUEST_VM2_IMAGE ?= "agl-cluster-demo-platform"
+GUEST_VM1_IMAGE ?= "agl-ivi-demo-platform-flutter"
+GUEST_VM2_IMAGE ?= "agl-cluster-demo-platform-flutter"
 
 GUEST_IMAGES ?= "agl-kvm-guest:${GUEST_VM1_IMAGE} agl-kvm-guest:${GUEST_VM2_IMAGE}"