Change SRCREV for flutter instrument cluster recipe 70/27970/2
authorAakash Solanki <tech2aks@gmail.com>
Fri, 2 Sep 2022 09:55:26 +0000 (11:55 +0200)
committerAakash Solanki <tech2aks@gmail.com>
Sat, 3 Sep 2022 21:51:44 +0000 (23:51 +0200)
- Change SRCREV to use latest commit
- Change packagename from `ic` to `flutter_cluster_dashboard`
- Change kuksa_vss_init.py to add signals for navigation

Latest commit of the flutter app includes the new navigation
in the instrument cluster, more indicators and unnecessary
files and folders are also removed.

Bug-AGL: SPEC-4508

Change-Id: I766b410cd66774bfb84eeb0ce9654ed85e8d2af3
Signed-off-by: Aakash Solanki <tech2aks@gmail.com>
recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json [new file with mode: 0644]
recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json [new file with mode: 0644]
recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json [new file with mode: 0644]
recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-debug.json [deleted file]
recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-profile.json [deleted file]
recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-release.json [deleted file]
recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
recipes-demo/kuksa-vss-init/files/kuksa_vss_init.py

diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json
new file mode 100644 (file)
index 0000000..3d92b45
--- /dev/null
@@ -0,0 +1,17 @@
+{
+        "view": [
+                {
+                        "window_type": "BG",
+                        "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
+                        "vm_args": [
+                                "--observatory-host",
+                                "0.0.0.0",
+                                "--observatory-port",
+                                "1234"
+                        ],
+                        "width": 1920,
+                        "height": 1080,
+                        "fullscreen": true
+                }
+        ]
+}
\ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json
new file mode 100644 (file)
index 0000000..aca303f
--- /dev/null
@@ -0,0 +1,18 @@
+{
+        "view": [
+                {
+                        "window_type": "BG",
+                        "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
+                        "vm_args": [
+                                "--observatory-host",
+                                "0.0.0.0",
+                                "--observatory-port",
+                                "1234",
+                                "--start-paused"
+                        ],
+                        "width": 1920,
+                        "height": 1080,
+                        "fullscreen": true
+                }
+        ]
+}
\ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json
new file mode 100644 (file)
index 0000000..eb75dc4
--- /dev/null
@@ -0,0 +1,11 @@
+{
+        "view": [
+                {
+                        "window_type": "BG",
+                        "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
+                        "width": 1920,
+                        "height": 1080,
+                        "fullscreen": true
+                }
+        ]
+}
\ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-debug.json b/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-debug.json
deleted file mode 100644 (file)
index 3cee350..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-{
-        "view" : [ {
-                "window_type" : "BG",
-                "bundle_path" : "/usr/share/flutter/ic",
-                "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234"],
-                "width" : 1920,
-                "height": 1080,
-                "fullscreen": true
-                }
-        ]
-}
diff --git a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-profile.json b/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-profile.json
deleted file mode 100644 (file)
index c7ea10f..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-{
-        "view" : [ {
-                "window_type" : "BG",
-                "bundle_path" : "/usr/share/flutter/ic",
-                "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234", "--start-paused"],
-                "width" : 1920,
-                "height": 1080,
-                "fullscreen": true
-                }
-        ]
-}
diff --git a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-release.json b/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-release.json
deleted file mode 100644 (file)
index fdff54f..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-{
-        "view" : [ {
-                "window_type" : "BG",
-                "bundle_path" : "/usr/share/flutter/ic",
-                "width" : 1920,
-                "height": 1080,
-                "fullscreen": true
-                }
-        ]
-}
index 44be070..4647f20 100644 (file)
@@ -8,27 +8,27 @@ SECTION = "graphics"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE.md;md5=0c52b0e4b5f0dbf57ea7d44bebb2e29d"
 
-SRC_URI = "git://github.com/aakash-s45/ic;protocol=https;branch=main \
+SRC_URI = "git://github.com/aakash-s45/ic;protocol=https;branch=master \
     file://flutter-cluster-dashboard.service \
-    file://ic_on_bg-debug.json \
-    file://ic_on_bg-profile.json \
-    file://ic_on_bg-release.json \
+    file://flutter_cluster_dashboard_on_bg-debug.json \
+    file://flutter_cluster_dashboard_on_bg-profile.json \
+    file://flutter_cluster_dashboard_on_bg-release.json \
 "
 
 PV = "1.0+git${SRCPV}"
-SRCREV = "32f72bb68142a0dbde9ccf28b27c445598c95112"
+SRCREV = "798851a33bb614fb1e5473a8046e63cd9b9026f4"
 
 S = "${WORKDIR}/git"
 
-PUBSPEC_APPNAME = "ic"
+PUBSPEC_APPNAME = "flutter_cluster_dashboard"
 
 FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
 
 inherit flutter-app
 
-APP_CONFIG = "ic_on_bg-release.json"
-APP_CONFIG:class-runtimedebug = "ic_on_bg-debug.json"
-APP_CONFIG:class-runtimeprofile = "ic_on_bg-profile.json"
+APP_CONFIG = "flutter_cluster_dashboard_on_bg-release.json"
+APP_CONFIG:class-runtimedebug = "flutter_cluster_dashboard_on_bg-debug.json"
+APP_CONFIG:class-runtimeprofile = "flutter_cluster_dashboard_on_bg-profile.json"
 
 
 do_install:append() {
index 5453112..0177e3c 100644 (file)
@@ -50,6 +50,12 @@ class VSS:
         self.cruiseControlSpeedSet = "Vehicle.ADAS.CruiseControl.SpeedSet"
         self.cruiseControlisActive = "Vehicle.ADAS.CruiseControl.IsActive"
         self.batteryChargingStatus = "Vehicle.Powertrain.Battery.Charging.Status"
+        # 
+        self.currLat = "Vehicle.Cabin.Infotainment.Navigation.CurrentLocation.Latitude"
+        self.currLng = "Vehicle.Cabin.Infotainment.Navigation.CurrentLocation.Longitude"
+        self.desLat = "Vehicle.Cabin.Infotainment.Navigation.DestinationSet.Latitude"
+        self.desLng = "Vehicle.Cabin.Infotainment.Navigation.DestinationSet.Longitude"
+        self.steeringInfo = "Vehicle.Cabin.SteeringWheel.Switches.Info"
 
     def setInitialValues(self):
         print("Setting values")
@@ -74,6 +80,13 @@ class VSS:
         self.client.setValue(self.cruiseControlisActive, "false")
         self.client.setValue(self.cruiseControlSpeedSet, '60')
         self.client.setValue(self.batteryChargingStatus, "true")
+        # 
+        self.client.setValue(self.currLat, "31.708643")
+        self.client.setValue(self.currLng, "76.931882")
+        self.client.setValue(self.desLat, "31.781456")
+        self.client.setValue(self.desLng, "76.997469")
+        # Show the map
+        self.client.setValue(self.steeringInfo, "true")
         print("All value set succesfully")