weston-terminal-conf: add systemd-sandboxed demo configuration 55/27755/2
authorDenys Dmytriyenko <denys@konsulko.com>
Thu, 7 Jul 2022 16:17:57 +0000 (16:17 +0000)
committerDenys Dmytriyenko <denys@konsulko.com>
Mon, 11 Jul 2022 19:56:28 +0000 (19:56 +0000)
Add a secondary .desktop file for weston-terminal to demonstrate new
applaunchd systemd_manager with sandboxing capabilities.

The sandboxing example enables PrivateNetwork - only loopback interface
is available with localhost access only, easy to verify in the terminal

Bug-AGL: SPEC-4466
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Change-Id: Ib17880050056a2801f03bcc54caef921e8bdb516

recipes-graphics/wayland/weston-terminal-conf.bb
recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop [new file with mode: 0644]

index abc23cb..573e2df 100644 (file)
@@ -4,6 +4,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
 
 SRC_URI = " \
     file://org.freedesktop.weston.wayland-terminal.desktop \
+    file://weston-terminal.desktop \
 "
 
 inherit allarch
@@ -11,9 +12,19 @@ inherit allarch
 do_install() {
     install -d ${D}${datadir}/applications
     install -m 0644 ${WORKDIR}/org.freedesktop.weston.wayland-terminal.desktop ${D}${datadir}/applications
+
+    # Enable systemd sandboxing override as a demonstration
+    mkdir -p ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
+    ln -sf ${sysconfdir}/systemd/sandboxing/no-network.conf ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
+
+    # HACK - install .desktop file for systemd until applaunchd can do enumeration with homescreen names and icons
+    install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications/
 }
 
-FILES:${PN} = "${datadir}/applications"
+FILES:${PN} = " \
+    ${datadir}/applications \
+    ${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d \
+"
 
 RDEPENDS:${PN} = " \
     weston \
diff --git a/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop b/recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop
new file mode 100644 (file)
index 0000000..d1cb2c8
--- /dev/null
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Name=Weston Terminal (systemd)
+Comment=Terminal Emulator
+GenericName=Terminal Emulator
+Exec=weston-terminal
+Icon=utilities-terminal
+Terminal=false
+Type=Application
+Categories=System;TerminalEmulator;
+DBusActivatable=true
+StartupNotify=true