Fix recipes on chinook branch 43/8043/1
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Mon, 2 Jan 2017 18:29:19 +0000 (19:29 +0100)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Mon, 2 Jan 2017 18:29:19 +0000 (19:29 +0100)
This change fixes the evaluation of the SRC_URI. As SRC_URI_chinook is a parsed variable we need to use _append.

Change-Id: Ifa5c3dabb025a1a185190d8b2eb35414db5266f5
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-demo-hmi/unicens/unicens_0.1.bb
recipes-demo-hmi/vod-server/vod-server_0.1.bb

index 37c943a..e055731 100644 (file)
@@ -10,8 +10,8 @@ DEPENDS += "libxml2"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/unicens;protocol=https"
 SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/src/unicens;protocol=https;branch=chinook"
-SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch"
-SRC_URI += "file://0001-Support-booting-by-systemd.patch \
+SRC_URI_append = " file://0001-Fix-cross-compilation-with-yocto.patch"
+SRC_URI_append = " file://0001-Support-booting-by-systemd.patch \
             file://most-network-startup.service \
             file://most-network-manager.service"
 
index d76c82d..29f7272 100644 (file)
@@ -8,8 +8,8 @@ PV = "0.1"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https"
 SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https;branch=chinook"
-SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch \
-            file://vod-demo.service"
+SRC_URI_append  = " file://0001-Fix-cross-compilation-with-yocto.patch \
+                    file://vod-demo.service "
 
 S = "${WORKDIR}/git"
 #SRCREV = "8c5f2324d7aa61669324aec1a0ad091fe1379489"